X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 3.6.3 won't reload pages, pages reload blank, refresh won't work.

Posted

I have a problem with 3.6.3 in Windows 7 64-bit with pages not reloading when I navigate back to them or refresh due to a change in the page. As an example, on eBay, but when I hit resend, the page loads blank (over and over). I have to renavigate to the page to get it to load. For instance, if I am viewing my "watching" list and remove an item, the page would normally refresh with my changes (old Firefox), now it notifies me that I have changed the page, but the page itself won't load. Refreshing does nothing. I have taken a screen shot. I have to renavigate to the page to see it. This is very time consuming and therefore, annoying. Any help would be appreciated. I am using Windows 7, 64 bit.

URL of affected sites

http://ebay.com

Additional System Details

Installed Plug-ins

  • -Adobe PDF Plug-In For Firefox and Netscape
  • Contribute Firefox IBE Plugin DLL
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r52
  • Picasa plugin
  • 3.0.50106.0
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

More Information

bcman 2 solutions 9 answers

Try reinstalling Firefox.

Question owner

You can empty the Cache. This will fix the problem temporarily but when you load the page again it tends to cause the same problem...

Question owner

Firefox is continuously refreshing my facebook page.. it goes on refreshing before the last refresh laods the page properly.. so annoying.. it's refreshing every 3 seconds..

Question owner

I have the same problem too. Sometimes clicking on the home button and the back button after the facebook home page loads works but not always. I often lose gifts I have received in doing this but can't find any other way to play.The problem is actually getting worse. Sometimes clearing out cookies and caches works (click on tools and clear recent history, you will have to log in again since it will delete your login cookie or whatever it is callled.) These aren't perement fixes. I had the same problem back in high school with some BBS games too. How many of us are using dial-up? I don't think switching to broadband fixes it. I think it just masks the problem.

Question owner

I am having same issue.

I reinstalled firefox 2 times. Clear Cache and what not to sort out the issue...it didn't help.

does anybody from development team really read these tickets? now this is really annoying to develop web applications with Firefox. please fix it asap.

Question owner

Well, I found a fix that seems to work for me. I have dial-up so it may not work if you have broadband. These facebook games reference a great deal of links that can time-out on you and take forever to load. Oddly this came to me while watching the Isabella & Filomina Bing commerical. Your browser has to ping each link to find the proxy before it will load properly. So go to tools->options->advanced->settings and change it from manual to auto-detect. This should get your browser to load all the different links the facebook games need and won't time-out as much. It seems to work in Mafia Wars. I didn't want to mention it yet because I am still having problems loading facebook. Broadband modems usually have auto-detect hardwired which is usually faster than the browser auto-detect so if you have broadband i would leave it on manual, but you could try and see if it still works.

Question owner

Whoops I meant still have problems loading FarmVille.

Question owner

When Firefox browser comes up, a warning box under toolbar comes up saying "Firefox prevented this page from refreshing". I click on the "allow" button on far right but nothing happens. I've tried uninstalling ver. 3.6.6 and reinstalled an earlier version but this does not clear the warning. Even restoring to earlier date does not cure problem.