Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why are my commercials on Fox News suddenly in Spanish?

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

In my news clips and news videos a short commercial usually appears. Suddenly, these are all in Spanish--I have not changed anything, nor requested a language change. When I check my mozilla settings, English is my designated language of preference. I cannot find a listing for Spanish nor another way to change my language to English.

All Replies (2)

more options

Hi please check Windows 10 Settings --> Time & Language and make sure all settings are as you want them, also under Region & Language see if anything is changed, Also check Speech

Then Settings --> Privacy --> Location (I have mine turned off but that is done by me)

So this is thinking that your Windows 10 has changed location/language settings and is causing Firefox to think the same. So please check all the above and restart if any changes.

Let us know if that was the issue if solves it and if not I guess you will be back.

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

You can check the order of the installed languages.

  • Options/Preferences -> General -> Languages

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":