Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google translate

  • 2 replies
  • 1 has this problem
  • 202 views
  • Last reply by nevlnliz

more options

Google translate has suddenly appeared and is translating websites from Spanish to English. How do I block it and/or remove it? I have English set as the prime language but also have Spanish on my list of languages.

Google translate has suddenly appeared and is translating websites from Spanish to English. How do I block it and/or remove it? I have English set as the prime language but also have Spanish on my list of languages.

All Replies (2)

more options

Hmm, is this just on one site that might that built in, or is it happening on a lot of different sites?

One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything here that mentions translation? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Can you track it down?

more options

I had checked the add-ons but there was nothing there I hadn´t considered that it might be built into the site!