X
Tap here to go to the mobile version of the site.

Support Forum

Firefox still sluggish after following all recommended steps, including refresh

Posted

Hi everyone

I've been struggling with a Firefox (v52.6) sluggishness problem for several months, and since in the meantime I tried all fixes I could find suggested in these pages, I thought to try and seek help in the forums.

Firefox is still usable, but resource-intensive pages (e.g. Facebook, Google Maps) are slow to respond, and often freeze the Firefox window (the no-response mouse cursor) for a few seconds. Meanwhile, the same pages (and the same amount of total load, i.e. open tabs) in Chrome produce normal performance, which suggests the sluggishness is a problem with Firefox rather than a performance issue with my PC, which is of decent specs (8GB RAM, i7 CPU).

Typically, Firefox becomes more sluggish the more it's been without a restart, and the memory resources it uses seem to grow proportionately. However, even when it's only using a few hundreds MB (after a restart), it's still quite sluggish, while Chrome, with a similar amount of memory used, is just fine. Likewise, when after a while the RAM consumed by Firefox/Chrome goes up to >1GB (not sure if this is in itself normal or not!), while Firefox is crawling, Chrome is still fast.

What I tried, which did not fix Firefox's sluggishness (or only did so for a short while):

- disable extensions one by one, and even all at once

- disable all plugins

- start Firefox in safe mode

- ultimately, I used the refresh function, and immediately afterwards Firefox seemed to be as fast as Chrome. I subsequently reinstalled all my addons (which include ABP, Zotero Connector, Classic Theme Restorer, NoScript) and settings. The next day, it seems my joy was shortlived, as Firefox is back to its usual sluggishness.


I would not want to migrate to Chrome unless I really cannot find a fix for this problem. Can anyone suggest more things I can try?

Thanks so much for any help.

Hi everyone I've been struggling with a Firefox (v52.6) sluggishness problem for several months, and since in the meantime I tried all fixes I could find suggested in these pages, I thought to try and seek help in the forums. Firefox is still usable, but resource-intensive pages (e.g. Facebook, Google Maps) are slow to respond, and often freeze the Firefox window (the no-response mouse cursor) for a few seconds. Meanwhile, the same pages (and the same amount of total load, i.e. open tabs) in Chrome produce normal performance, which suggests the sluggishness is a problem with Firefox rather than a performance issue with my PC, which is of decent specs (8GB RAM, i7 CPU). Typically, Firefox becomes more sluggish the more it's been without a restart, and the memory resources it uses seem to grow proportionately. However, even when it's only using a few hundreds MB (after a restart), it's still quite sluggish, while Chrome, with a similar amount of memory used, is just fine. Likewise, when after a while the RAM consumed by Firefox/Chrome goes up to >1GB (not sure if this is in itself normal or not!), while Firefox is crawling, Chrome is still fast. What I tried, which did not fix Firefox's sluggishness (or only did so for a short while): - disable extensions one by one, and even all at once - disable all plugins - start Firefox in safe mode - ultimately, I used the refresh function, and immediately afterwards Firefox seemed to be as fast as Chrome. I subsequently reinstalled all my addons (which include ABP, Zotero Connector, Classic Theme Restorer, NoScript) and settings. The next day, it seems my joy was shortlived, as Firefox is back to its usual sluggishness. I would not want to migrate to Chrome unless I really cannot find a fix for this problem. Can anyone suggest more things I can try? Thanks so much for any help.

Modified by longtalker

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • Firefox 52.6.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.6.0/WINNT/en-GB/

Extensions

  • Adblock Plus 3.0.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Search Bar 2.9 (add-to-searchbox@maltekraus.de)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Classic Theme Restorer 1.7.3.4 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Downloads Window 0.6.8 ({a7213cf2-fa1e-4373-88ff-255d0abd3020})
  • Multi Links Plus 3.9.3 (multilinksplus@hugsmile.eu)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • NoScript 5.1.8.4 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Owl - For comfortable reading 2.2.4 (@owl-comfortable-reading-addon)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Zotero Connector 5.0.35 (zotero@chnm.gmu.edu)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 620
  • adapterDescription2:
  • adapterDeviceID: 0x5916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 39c517aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.15
  • driverDate: 1-18-2017
  • driverDate2:
  • driverVersion: 21.20.16.4590
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct2D', u'name': u'DIRECT2D'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 620 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 620 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Helpful Reply

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

Thanks! I've disabled hardware acceleration, but it doesn't seem to change much. Will keep observing it.

Disabling addons one by one is something I've already done. did it with a binary search rather than one by one actually, to get to the faulty one quicker. But as I said, even in safe mode I experienced slowness, so I think an addon culprit is unlikely.

I do have an AV, but it does not have any addons for Firefox. I am not sure what toolbars I could disable, as I only have the standard ones and the ones added by the Classic Theme addon, which is itself not problematic according to the Safe Mode test.

Thanks! I've disabled hardware acceleration, but it doesn't seem to change much. Will keep observing it. Disabling addons one by one is something I've already done. did it with a binary search rather than one by one actually, to get to the faulty one quicker. But as I said, even in safe mode I experienced slowness, so I think an addon culprit is unlikely. I do have an AV, but it does not have any addons for Firefox. I am not sure what toolbars I could disable, as I only have the standard ones and the ones added by the Classic Theme addon, which is itself not problematic according to the Safe Mode test.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Helpful Reply

As a test, disable your protection programs. Is the problem still there?

As a test, disable your protection programs. Is the problem still there?

Question owner

that's a good call. I disabled the AV and web-scanning & containment components of my Comodo Internet Security Premium. Alas, Firefox is the same...

that's a good call. I disabled the AV and web-scanning & containment components of my Comodo Internet Security Premium. Alas, Firefox is the same...
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Then you will need to check the rest of your programs.

Then you will need to check the rest of your programs.

Question owner

If you mean the programs that I have installed on my PC, there are none that spring to mind as immediate suspects - and doing a similar binary search to see which one might affect Firefox would be much more time consuming than was the case with disabling the addons.

Also, I do find it strange that Chrome - the "control subject" in this case!- has no performance issues at all even though it runs on the same PC.. makes me think it's not an external program that's interfering with browser performance, but something in Firefox itself..

If you mean the programs that I have installed on my PC, there are none that spring to mind as immediate suspects - and doing a similar binary search to see which one might affect Firefox would be much more time consuming than was the case with disabling the addons. Also, I do find it strange that Chrome - the "control subject" in this case!- has no performance issues at all even though it runs on the same PC.. makes me think it's not an external program that's interfering with browser performance, but something in Firefox itself..

Modified by longtalker

FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

That is possible but not likely. I called for more help.

longtalker said

start Firefox in safe mode

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

That is possible but not likely. I called for more help. ''longtalker [[#question-1207666|said]]'' <blockquote> start Firefox in safe mode </blockquote> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Question owner

Any more ideas?...

Any more ideas?...
Shadow110 1072 solutions 14836 answers

Give a try on this :

  • Repair System Registry and Files

Find the Dos Prompt Right Click and Run as Administrator then : Copy/Paste to Dos Window : DISM /Online /Cleanup-Image /RestoreHealth then hit Enter Note : DISM goes up to Microsoft for new ones.

Give a try on this : *Repair System Registry and Files Find the Dos Prompt Right Click and Run as Administrator then : Copy/Paste to Dos Window : DISM /Online /Cleanup-Image /RestoreHealth then hit Enter Note : DISM goes up to Microsoft for new ones.

Modified by Shadow110

Shadow110 1072 solutions 14836 answers

Wrong post. Ignore, Thanks

Wrong post. Ignore, Thanks
Shadow110 1072 solutions 14836 answers

Hi, uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 52.6.0 with a Full Version Installer

Then follow some of this for the SSD : https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/

Please let us know if this solved your issue or if need further assistance.

Hi, uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 52.6.0 with a Full Version Installer *https://www.mozilla.org/en-US/firefox/organizations/all/ Then follow some of this for the SSD : https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/ Please let us know if this solved your issue or if need further assistance.