X
Tap here to go to the mobile version of the site.

Support Forum

when I type to reply to email in my Gmail account the format of the text disappears

Posted

In the last month( i think after updating to frfx 58) when I type to reply to email in my Gmail account in my browser ( firefox 58.0.2) I get to see the standard formatting of the text (blue, comic sans etc) but when I actually send it, the sent email has the format disappeared and is standard format instead (in black plain font for example). This also happens in my other Gmail accounts too. I tried in MS IntExplorer and there is not a problem (meaning it is NOT my GMAIL's account settings)

Any suggestion/help?

In the last month( i think after updating to frfx 58) when I type to reply to email in my Gmail account in my browser ( firefox 58.0.2) I get to see the standard formatting of the text (blue, comic sans etc) but when I actually send it, the sent email has the format disappeared and is standard format instead (in black plain font for example). This also happens in my other Gmail accounts too. I tried in MS IntExplorer and there is not a problem (meaning it is NOT my GMAIL's account settings) Any suggestion/help?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' [v57+] Select '''Privacy. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''Start Firefox in Safe Mode''' https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Question owner

No, it didn't solve it.

I unckecked Hardware acceleration I removed ALL cookies, NOT just Gmail's I cleared all Cached web content I cleared all Site Data I started in Safe Mode and while in Safe Mode, it did it again, right away.

What's also weird is that my signature remains formatted alright! It's only the text that I TYPE that changes to plain after the email is sent.

No, it didn't solve it. I unckecked Hardware acceleration I removed ALL cookies, NOT just Gmail's I cleared all Cached web content I cleared all Site Data I started in Safe Mode and while in Safe Mode, it did it again, right away. What's also weird is that my signature remains formatted alright! It's only the text that I TYPE that changes to plain after the email is sent.

Modified by akmsupport

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Start your Computer in safe mode with network support. Then start Firefox.

If the problem is still there, this may be a website issue.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. If the problem is still there, this may be a website issue. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Question owner

First, let me take the opportunity to thank you for your effort to provide support to my problem.

Unfortunately, I just tried the Windows Safe Mode w/ Networking and I had again the exact same problem.

I also tried disabling any adblock, also tweeking with firefox's options (like accepting all cookies etc etc..), but with no improvement.

I stress the fact once more, that only in http Gmail (on any of my accounts) I experience this problem. Not on Hotmail or Yahoo.

I have an updated antivirus installed and also ran antimalware software.

First, let me take the opportunity to thank you for your effort to provide support to my problem. Unfortunately, I just tried the Windows Safe Mode w/ Networking and I had again the exact same problem. I also tried disabling any adblock, also tweeking with firefox's options (like accepting all cookies etc etc..), but with no improvement. I stress the fact once more, that only in http Gmail (on any of my accounts) I experience this problem. Not on Hotmail or Yahoo. I have an updated antivirus installed and also ran antimalware software.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

I called for more help.

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 +++++++++++++++++++++++++++++++++++++++++++++++ Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering

Would you please try this : Type in the address bar about:config (press Enter) (promise to be careful if asked)

Type in the search bar gfx.canvas and look for the preference: gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia

Type in the search bar gfx.content and look for the preference: gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia

Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'. +++++++++++++++++++++++++++++++++++++++++++++++ Execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction,

I called for more help. Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors, ''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Under '''fonts and colors, ''' press the '''Advanced''' button. Scroll to the bottom, turn on '''Allow Web Sites To Choose Their Own. ''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 +++++++++++++++++++++++++++++++++++++++++++++++ Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar '''about:config''' (press Enter) (promise to be careful if asked) Type in the search bar '''gfx.canvas''' and look for the preference: '''gfx.canvas.azure.backends''' and set its value to '''direct2d1.1,cairo,skia ''' Type in the search bar '''gfx.content''' and look for the preference: '''gfx.content.azure.backends''' and set its value to '''direct2d1.1,cairo,skia ''' Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking ''''Reset''''. +++++++++++++++++++++++++++++++++++++++++++++++ Execute '''cttune.exe''' from Win+R, and enable ClearType and follow the onscreen instruction,

Question owner

Nope. Nothing!

I followed your latest instructions.

->Allow Web Sites To Choose Their Own: was already turned on.

->In gfx.canvas & gfx.content, the value was already direct2d1.1,cairo,skia

Nope. Nothing! I followed your latest instructions. ->Allow Web Sites To Choose Their Own: was already turned on. ->In gfx.canvas & gfx.content, the value was already direct2d1.1,cairo,skia
guigs 1072 solutions 11697 answers

I think this is a gmail setting, can you please confirm that Plain text mode is not selected in this set of instructions when you send an email to

https://www.lifewire.com/how-to-send-a-message-in-plain-text-from-gmail-1171963

me: guigs@mozilla.com

Thank you, I look forward to your reply.

I think this is a gmail setting, can you please confirm that Plain text mode is not selected in this set of instructions when you send an email to https://www.lifewire.com/how-to-send-a-message-in-plain-text-from-gmail-1171963 me: guigs@mozilla.com Thank you, I look forward to your reply.

Question owner

Just to clarify a bit more, The format stays intact in my signature (color, fonts, etc), it is only the text inside the message-reply that gets "unformated" into plain text.

Just to clarify a bit more, The format stays intact in my signature (color, fonts, etc), it is only the text inside the message-reply that gets "unformated" into plain text.

Modified by akmsupport

Question owner

guigs thank you!

I see what you mean. I checked it and the plain text was NOT selected. In fact when I type the text inside the new mail or reply mail, the format is right and visible (together with the format choices, ie. fonts, size etc, as normal). Its only when I hit the send button, then inside the SENT email the text is changed to unformatted (plain/generic) text. Also as I mentioned above the signature remains alright with the chosen format. And yes, the sent email's body is viewed as PLAIN on the recipient's side.

Is there a way to show screenshots of the whole damn problem???

And as I mentioned before this problem does NOT arise when I log into my Gmail account through InternetExplorer. Its only on Frfx and for the last 1-2months probably since I upgraded to FF58.

guigs thank you! I see what you mean. I checked it and the plain text was NOT selected. In fact when I type the text inside the new mail or reply mail, the format is right and visible (together with the format choices, ie. fonts, size etc, as normal). Its only when I hit the send button, then inside the SENT email the text is changed to unformatted (plain/generic) text. Also as I mentioned above the signature remains alright with the chosen format. And yes, the sent email's body is viewed as PLAIN on the recipient's side. Is there a way to show screenshots of the whole damn problem??? And as I mentioned before this problem does NOT arise when I log into my Gmail account through InternetExplorer. Its only on Frfx and for the last 1-2months probably since I upgraded to FF58.

Modified by akmsupport

woodsterman 0 solutions 8 answers

I'm on a new Mac Book Pro with High Sierra and my gmail exactly the same thing in Firefox 58.0.2. It didn't do this until your last update. I have some before and after photos for you. The second is what Firefox does to my font. Other browsers do not do this.

I'm on a new Mac Book Pro with High Sierra and my gmail exactly the same thing in Firefox 58.0.2. It didn't do this until your last update. I have some before and after photos for you. The second is what Firefox does to my font. Other browsers do not do this.

Question owner

woodsterman,

this is EXACLTY what happens, on my system (completely different configuration, Windows 7)

Hold on! tell, what kind of text choice you have in the formatting of your reply text?

woodsterman, this is EXACLTY what happens, on my system (completely different configuration, Windows 7) Hold on! tell, what kind of text choice you have in the formatting of your reply text?
woodsterman 0 solutions 8 answers

Explanation is on attachment. Firefox is the only browser doing this.

Explanation is on attachment. Firefox is the only browser doing this.

Modified by woodsterman

Question owner

Oooooooooooh! OK!!! I think I got it!!! Your same-problem shed a light to my mysterious conversion from formated to plain text.

Guys, I figured it out finally! I hope the following remarks will help firefox community/programmers to correct the "code?" error:

When I use Comic Sans as the predefined fonts for my edit/replies of emails then they are converted in Plain text. However, when I choose ANY OTHER FONT (tried: Tahoma, Verdana, Wide) from the Gmail's settings, as predefined font for editing/replying email, then ALL IS AS NORMAL, that is my reply is sent with the chosen formated text, without any unexpected change. Everytime!

And then, if i chose again as default font the COMIC sans serif... presto! The same bug converts my text to plain text in any of my emails/replies.

Woodsterman: Thanks for joining in! You made it clear. Please try to use as default text TAHOMA or any other convenient font (in you Mac system) and report back the outcome.

I have not the faintest idea what this causes the problem. Probably to the tech people to understand/solve the bug/problem. Please you tech-savvy-frfx-people have a look and provide in the next update a solution.

Lastly, I summerize, that the problem occurs ONLY in default format COMIC SANS SERIF, only when I use Gmail (not in i.e. Hotmail/Firefox) and ONly from within Firefox 5802 (not in Gmail/InternetExplorer)

My guess is that not many people reported this problem, just because they dont use in Frfx58, COMIC SANS SERIF as their default font in Gmail's Settings. If they do, you'll get many more problem reports.

That's my 2.78Cents of worth. I keep fingers crossed.

Oooooooooooh! OK!!! I think I got it!!! Your same-problem shed a light to my mysterious conversion from formated to plain text. Guys, I figured it out finally! I hope the following remarks will help firefox community/programmers to correct the "code?" error: When I use Comic Sans as the predefined fonts for my edit/replies of emails then they are converted in Plain text. However, when I choose ANY OTHER FONT (tried: Tahoma, Verdana, Wide) from the Gmail's settings, as predefined font for editing/replying email, then ALL IS AS NORMAL, that is my reply is sent with the chosen formated text, without any unexpected change. Everytime! And then, if i chose again as default font the COMIC sans serif... presto! The same bug converts my text to plain text in any of my emails/replies. Woodsterman: Thanks for joining in! You made it clear. Please try to use as default text TAHOMA or any other convenient font (in you Mac system) and report back the outcome. I have not the faintest idea what this causes the problem. Probably to the tech people to understand/solve the bug/problem. Please you tech-savvy-frfx-people have a look and provide in the next update a solution. Lastly, I summerize, that the problem occurs ONLY in default format COMIC SANS SERIF, only when I use Gmail (not in i.e. Hotmail/Firefox) and ONly from within Firefox 5802 (not in Gmail/InternetExplorer) My guess is that not many people reported this problem, just because they dont use in Frfx58, COMIC SANS SERIF as their default font in Gmail's Settings. If they do, you'll get many more problem reports. That's my 2.78Cents of worth. I keep fingers crossed.
woodsterman 0 solutions 8 answers

It hits me really good. It turns all of my brown to black and changes quite a few fonts. The received email is quite different than what was sent.

This seems to think I'm fixing this. No, I have the same problem.

Example below:

It hits me really good. It turns all of my brown to black and changes quite a few fonts. The received email is quite different than what was sent. This seems to think I'm fixing this. No, I have the same problem. Example below:

Modified by woodsterman

Question owner

I checked again and no problem when using Tahoma. Problem persists when using Comic Sans. Examples in attachments.


On the other hand I just realized the problem exists and when using the Trebuchet fonts, in exact manner as in the Comic sans serif.  :-(

I checked again and no problem when using Tahoma. Problem persists when using Comic Sans. Examples in attachments. On the other hand I just realized the problem exists and when using the Trebuchet fonts, in exact manner as in the Comic sans serif. :-(
ptski 0 solutions 1 answers

Helpful Reply

akmsupport said

On the other hand I just realized the problem exists and when using the Trebuchet fonts, in exact manner as in the Comic sans serif.  :-(

I have the exactly the same problem, with Trebuchet. I checked it with both Linux Mint (FF, Chrome, Opera) and Win10 (FF, Chrome, Opera, Edge). ONLY Firefox causes this problem, in BOTH systems! The predefined format disappears at the stage of saving the message in drafts. Try to write sth having default font set to Trebuchet, then close message and open the draft again.

Devs, please react. It is really annoying and forces people to use other browsers...

''akmsupport [[#answer-1083284|said]]'' <blockquote> On the other hand I just realized the problem exists and when using the Trebuchet fonts, in exact manner as in the Comic sans serif. :-( </blockquote> I have the exactly the same problem, with Trebuchet. I checked it with both Linux Mint (FF, Chrome, Opera) and Win10 (FF, Chrome, Opera, Edge). ONLY Firefox causes this problem, in BOTH systems! The predefined format disappears at the stage of saving the message in drafts. Try to write sth having default font set to Trebuchet, then close message and open the draft again. Devs, please react. It is really annoying and forces people to use other browsers...

Modified by ptski

alex_mayorga
  • Top 25 Contributor
  • Moderator
365 solutions 2866 answers

¡Hola!

Given this affect more than just one person, seems like we're dealing with a legit bug in Firefox.

Please follow https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines to report it.

Once you have a Bugzilla URL, please post it here.

¡Gracias!

¡Hola! Given this affect more than just one person, seems like we're dealing with a legit bug in Firefox. Please follow https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines to report it. Once you have a Bugzilla URL, please post it here. ¡Gracias!

Modified by alex_mayorga

guigs 1072 solutions 11697 answers

To follow up on this issue, this is the link to the bug that was filed: https://bugzilla.mozilla.org/show_bug.cgi?id=1449320

To follow up on this issue, this is the link to the bug that was filed: https://bugzilla.mozilla.org/show_bug.cgi?id=1449320