Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't play Netflix video, even in safe mode. Version 58.0.2, Windows 10 16299.248

  • 6 replies
  • 7 have this problem
  • 364 views
  • Last reply by spgfr

more options

Netflix plays fine in Edge. Disabling hardware acceleration was of no help.

Chosen solution

Is Silverlight required?

This may be your problem,

Firefox v52+ disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link} ++++++++++++++++++++++++++++++++++++++++++++++ Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Read this answer in context 👍 1

All Replies (6)

more options

Right-click on the player. Does it say what type of player it is?

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

In safe mode, trying to play Netflix video brings up a prompt to install the Silverlight plug-in.

Installing Silverlight in safe mode and trying Netflix again brings up the same prompt. Netflix has some fixes for the recurring prompt to install, none of which were of any help.

In either normal or safe mode, Silverlight doesn't show up in Firefox's list of plug-ins.

Viewing Netflix video in normal mode doesn't bring up the prompt to install Silverlight, and after a second or so shows nothing but a black screen.

more options

spgfr said

In either normal or safe mode, Silverlight doesn't show up in Firefox's list of plug-ins.

Please see : https://support.mozilla.org/en-US/kb/npapi-plugins

And also : https://en.wikipedia.org/wiki/Microsoft_Silverlight

more options

Chosen Solution

Is Silverlight required?

This may be your problem,

Firefox v52+ disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link} ++++++++++++++++++++++++++++++++++++++++++++++ Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

Instead of using the ESR Firefox version :

You could try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

3-bar menu => General => Digital Rights Management (DRM) Content

Also see :

https://support.mozilla.org/en-US/kb/enable-drm

Worked for the OP in this thread : https://support.mozilla.org/en-US/questions/1178557

more options

No Joy... The prompt for Silverlight installation is now showing up in normal mode. I'm content to view Netflix with another browser for the time being, and consider this ticket closed.

Thanks to all who offered their help..