Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ever since the latest update, I can't watch netflix. How can I fix this?

  • 6 replies
  • 219 have this problem
  • 17378 views
  • Last reply by lee_terry_jr

more options

Firefox was fine until it updated itself yesterday (10-5-17) and now the damn thing won't run Netflix. (all other sites are fine after I rebooted the computer)

When I go to the site, this msg pops up (see printscreen) "Firefox is installing components to play the audio or video on this page. Please try again later" It lies. It's not. It has this message all damn day yesterday and all of today.

When I try to watch a show, it tells me I need to install Silverlight. (see printscreen)

I've installed silverlight, which it wouldn't let me do until I uninstalled the previous version. So, I did that, installed the latest version but STILL get that message.

Would re-installing the previous version of firefox be a security risk? Is there something that can be done with this current version?

Attached screenshots

Modified by RebelWheelsNYC

Chosen solution

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

Read this answer in context 👍 5

All Replies (6)

more options

Chosen Solution

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

more options

This worked! THANK YOU <3 Passing this on to the others I know who were also having this problem (some who just left the browser)

more options

Unfortunately toggling DRM dosnt work for me. Freshinstall, cleared cookies cache no success. Any solutions?

more options

I was having a problem after upgrading to Firefox 57.0.3 (64 bit). Strange thing was that after signing into Netflix, if I just waited, the preview video (Christmas Inheritance) would start playing. But when I tried to actually play something, I would get an error message (F7702-1003) . What I ended up doing was downgrading to Firefox 56 (https://support.mozilla.org/en-US/kb/install-older-version-of-firefox) (click on "I still want to downgrade-where can I get the previous version"). After Firefox 56 installed, since it was set to automatic upgrades, it immediately downloaded the upgrade files for Firefox 57.0.3, which I went ahead and installed. And somehow, Netflix now runs fine.The other thing is to make sure you are not in private browsing. If you click on menu>options>privacy &security, history should be set to "Remember history" or"Use custom setting for history"

Modified by bsmith56

more options

Hello,

I had the same problem since a month as I remember, and I tried a lot of things unsuccessfully until that :

Apparentely firefox is not supporting some internet protocols (doesnt remember the name of it) because of the thing becoming obsolete.

But in the same time some sites continue to use these obsolete protocols so... they "don't work anymore"

This package seems to enables your firefox to continue using some of these old protocols, it's called "Firefox Extended Support Release" , or "Firefox ESR".

https://www.mozilla.org/en-US/firefox/organizations/


It solved the issue of Netflix videos not running for me.


I hope this'll help

more options

I am having this problem even with DRM enabled and I use Firefox ESR (so that won't fix it). However, I have found a way to get it working for me. 1st I installed this addon https://addons.mozilla.org/en-US/firefox/addon/random-agent-spoofer/?src=search Once I had it installed I set it to Firefox 48.0 (win 7 wow64) but that was because I use a 64-bit version of windows and Firefox ESR. So the 32 bit versions should work fine. After that, I restarted Firefox just to be sure it changed the profile and disabled the play DRM content option (not sure if that was needed but I figured that option was not around with that firefox and wanted to be safe). Once all of that was done Netflix worked fine for me on Firefox 52.7.3 ESR