Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Screen freeze on windows when resizing Firefox window

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

Resizing the Firefox browser window is prone to resulting in a system/screen freeze. Ctrl-Alt-Del does not bring up the menu to start the task manager, no mouse movement anymore, the system simply ssems to hang and I can only do a hard reboot (which the last time I had to do it resulting in Firefox having lost information about all profiles installed, so I had to re-add them).

I yet have to make tests whether this is related to some add-on installed, if not, it could either be Firefox Quantum or the Creator's update of Windows 10 (these are the things which recently changed).

So far I never experienced these system freezes when resizing any other application window, only Firefox. Using hardware acceleration is switched off in Firefox settings.

The moment the system freezes, the fan of my laptop goes on high speed.

I understand that this is a really complex issue and might also be related to the graphics card or many other things. I just wanted to check whether anyone maybe already knows that there is a problem with certain AddOns.

All Replies (3)

more options

Please : Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to.

Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

more options

Hi, hold down Shift when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any theme and add-ons - Add-ons Manager (Ctrl+Shift+A) > Themes/Extensions, then if it's OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some add-ons.

Failing that, as you said, it may be a graphics issue, so try updating the drivers.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

Try to start Firefox in Safe Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox