X
Tap here to go to the mobile version of the site.

Support Forum

Purple and green colour in firefox, how can I fix it?

Posted

After renewal by Firefox, Facebook and Youtube video turned green and purple. I tried to change to default but didn't work at all. I download that firefox suggested, but didn't work. Can you do reset for me, please?

After renewal by Firefox, Facebook and Youtube video turned green and purple. I tried to change to default but didn't work at all. I download that firefox suggested, but didn't work. Can you do reset for me, please?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23328 answers

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. otherwise you can do the following to work around the problem: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.windows-media-foundation.use-nv12-format'''. double-click it and change its value to '''false'''.

Question owner

Hi I tried both way that you suggested. But it didn't work on my computer. It is not my computer problems because chrome and other video are fine. Only facebook and youtubu has purple and green screen after the Firefox automatic update. Can you please give me another solutions?

Regards

Hi I tried both way that you suggested. But it didn't work on my computer. It is not my computer problems because chrome and other video are fine. Only facebook and youtubu has purple and green screen after the Firefox automatic update. Can you please give me another solutions? Regards
philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23328 answers

can you please double/triple check, that you have toggled the right about:config entry - also restart firefox once afterwards. numerous other users with the same symptoms have confirmed, that this is fixing the problem: https://support.mozilla.org/questions/firefox?tagged=bug1417442&show=done

only as a last resort you could disable hardware acceleration in firefox: Firefox's performance settings

can you please double/triple check, that you have toggled the right about:config entry - also restart firefox once afterwards. numerous other users with the same symptoms have confirmed, that this is fixing the problem: https://support.mozilla.org/questions/firefox?tagged=bug1417442&show=done only as a last resort you could disable hardware acceleration in firefox: [[Firefox's performance settings]]

Question owner

At about: config, I did double click and change to default but that was false. And When I downloaded, one couldn't download which was radeon-crimon relive-17.11.2-minimalsetup-171116-web.exe.

Obviously not my computer problems. Can you change the false to true?

At about: config, I did double click and change to default but that was false. And When I downloaded, one couldn't download which was radeon-crimon relive-17.11.2-minimalsetup-171116-web.exe. Obviously not my computer problems. Can you change the false to true?