Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Firefox prevented this page from automatically redirecting to another page"

  • 7 replies
  • 94 have this problem
  • 3756 views
  • Last reply by cor-el

more options

I checked on the support forum and found a solution: Go to Options, in the left pane select Advanced settings. My version (56) does not have Advanced as a selection. I found that it was last on version 55. I tried uninstalling version 56 and downloading version 55, but only version 56 will download.

I prefer using Firefox, but this constant clicking to allow it to access another webpage is driving me crazy. I don't want to switch to Chrome, but will if this can not be changed.

Chosen solution

The warning about reloading or redirecting is meant as an accessibility feature so people with disabilities or people who use screen readers do not get confused and isn't meant as a safety protection to stop redirecting.

You can toggle the involved pref directly on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 12

All Replies (7)

more options

Chosen Solution

The warning about reloading or redirecting is meant as an accessibility feature so people with disabilities or people who use screen readers do not get confused and isn't meant as a safety protection to stop redirecting.

You can toggle the involved pref directly on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

cor-el said

The warning about reloading or redirecting is meant as an accessibility feature so people with disabilities or people who use screen readers do not get confused and isn't meant as a safety protection to stop redirecting. You can toggle the involved pref directly on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.
more options

Thank you so much for the help.

It seems like an unnecessarily complicated 'solution' for the average user. Why couldn't the Advanced category be continued in the Options section. Simple and straightforward for most people.

more options

Most settings that were previously under Advanced have been moved to one of the other tabs. For some reason they have decided to remove this specific redirect warning setting possibly because it is badly named and doesn't work correctly in some cases (location redirect via the response headers).

more options

Jmyishi said

Thank you so much for the help. It seems like an unnecessarily complicated 'solution' for the average user. Why couldn't the Advanced category be continued in the Options section. Simple and straightforward for most people.

I agree with "jmyishi", it is too much mitigation for the average user. I have adequate knowledge and experience to understand what needs to be done but it just is too much for most people including myself to handle this each time. My solution is going to be the same as most, chose another browser - it just costs too much time. I would consider this a development defect and give it attention as this will drain your user base.

Kevin

Modified by Scott

more options

what are we supposed to look up in 'about:config' ?

there's stuff there about reloading and whatnot and first line statements about everything having the wrong title - and a post there saying it's about notifications anyway and not 'stopping' the redirects.

point is: how to detect and stop redirects?

Modified by abrogard

more options

You can modify this pref on the about:config page to enable or disable this block redirect feature.