X
Tap here to go to the mobile version of the site.

Support Forum

can't play youtube videos

Posted

Lately I have been unable to play some videos, youtube, vimeo. I can play them on Chrome. Today I removed firefox and downloaded a fresh install. No help. Same problem. Help please?

Lately I have been unable to play some videos, youtube, vimeo. I can play them on Chrome. Today I removed firefox and downloaded a fresh install. No help. Same problem. Help please?

Chosen solution

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 2
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • Firefox 55.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
  • Support URL: https://support.mozilla.org/1/firefox/55.0.3/WINNT/en-US/

Extensions

  • Emoji Keyboard 3.8.9 (@emojikeyboard)
  • Flash and Video Download 2.08 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Honey 9.7.1 (jid1-93CWPmRbVPjRQA@jetpack)
  • HTML5 Video Everywhere! 0.3.8 (html5-video-everywhere@lejenome.me)
  • YouTube Flash Video Player 54.0 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898})
  • YouTube™ Flash® Player 2.0.2 (jid1-HAV2inXAnQPIeA@jetpack)
  • HTML5 Player for YouTube™ 0.1.4 (jid1-e3wSQaH5t1HqKp@jetpack) (Inactive)
  • IBM Security Rapport 1.4 (rapportext@trusteer.com) (Inactive)
  • YouTube ALL HTML5 3.2.0 (jid1-qj0w91o64N7Eeg@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6570
  • adapterDescription2:
  • adapterDeviceID: 0x6759
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 10-24-2011
  • driverDate2:
  • driverVersion: 8.892.1.1000
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6570 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000dd0c) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6570 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000dd0c) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Zachary_ 30 solutions 191 answers

Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks!

Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks!
Was this helpful to you? 10
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15592 solutions 141164 answers
See also: *https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues *https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you? 1
Quote

Question owner

Zachary_ said

Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks!

When the video is supposed to play all I get is a black screen.

''Zachary_ [[#answer-1004353|said]]'' <blockquote> Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks! </blockquote> When the video is supposed to play all I get is a black screen.
Was this helpful to you? 2
Quote

Question owner

Zachary_ said

Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks!

When the video is supposed to play all I get is a black screen. FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Video plays in safe mode. What does this tell me?

''Zachary_ [[#answer-1004353|said]]'' <blockquote> Hello, can you provide more description around the problem. Such as how far you get with the video. If the video loads and plays. Or if the video has any disruptions while playing. Etc. Thanks! </blockquote> When the video is supposed to play all I get is a black screen. ''FredMcD [[#answer-1004529|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Video plays in safe mode. What does this tell me?
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

Chosen Solution

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Was this helpful to you? 2
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

Your System Details shows;

Installed Plug-ins

YouTube Flash Video Player 54.0 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898}) YouTube™ Flash® Player 2.0.2 (jid1-HAV2inXAnQPIeA@jetpack)

These may be the issue.

Your System Details shows; Installed Plug-ins YouTube Flash Video Player 54.0 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898}) YouTube™ Flash® Player 2.0.2 (jid1-HAV2inXAnQPIeA@jetpack) These may be the issue.
Was this helpful to you? 0
Quote

Question owner

I did what you suggested and disabled one at a time. There was an HTML5 Video Everywhere that seems to be the one causing the problem. With it disabled YouTube videos play fine. Thanks for your help Ray G

I did what you suggested and disabled one at a time. There was an HTML5 Video Everywhere that seems to be the one causing the problem. With it disabled YouTube videos play fine. Thanks for your help Ray G
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

Good to hear. Contact their support.

Good to hear. Contact their support.
Was this helpful to you? 1
Quote
tjphoto40 0 solutions 11 answers

I get an error message in the black window for every YouTube video now saying "Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video." I don't know what the problem is, since YouTube worked fine with Firefox for Mac, my browser, in the past and is fine with Chrome as someone else mentions here. I have the current 55.0.3 version, so what's wrong here?

I have had one or two ad blockers in my Firefox browser for quite awhile with no problems in playing YouTube videos. I would prefer to keep them active and wonder why, if I've added no new add-ons for awhile, why would YouTube suddenly have any issues because of these.

I get an error message in the black window for every YouTube video now saying "Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video." I don't know what the problem is, since YouTube worked fine with Firefox for Mac, my browser, in the past and is fine with Chrome as someone else mentions here. I have the current 55.0.3 version, so what's wrong here? I have had one or two ad blockers in my Firefox browser for quite awhile with no problems in playing YouTube videos. I would prefer to keep them active and wonder why, if I've added no new add-ons for awhile, why would YouTube suddenly have any issues because of these.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

I see you have several YouTube add-ons. Disable them.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I see you have several YouTube add-ons. Disable them. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you? 0
Quote
ckbrownla 0 solutions 2 answers

Raytgal said

Lately I have been unable to play some videos, youtube, vimeo. I can play them on Chrome. Today I removed firefox and downloaded a fresh install. No help. Same problem. Help please?

I am not sure but the Firefox install may leave some of the settings from the old installation in the configuration file. I have no proof of this but the suggestion of FredMcD at post 3 or 4 will show a list of what is active in your installation

''Raytgal [[#question-1174591|said]]'' <blockquote> Lately I have been unable to play some videos, youtube, vimeo. I can play them on Chrome. Today I removed firefox and downloaded a fresh install. No help. Same problem. Help please? </blockquote> I am not sure but the Firefox install may leave some of the settings from the old installation in the configuration file. I have no proof of this but the suggestion of FredMcD at post 3 or 4 will show a list of what is active in your installation

Modified by ckbrownla

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

tjphoto40 Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

'''tjphoto40''' Please go to the top of any '''support.mozilla.org''' web page and use the '''Ask A Question link; https://support.mozilla.org/en-US/questions/new''' Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other. Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; '''None Of These Solve My Problem.''' Now enter all the relative information on the problem. At the bottom of this, you can Add Images. Under this is '''Troubleshooting Information.''' Please press the '''Share Data button.''' This will let us look at your system details. '''No Personal Information Is Collected.'''
Was this helpful to you?
Quote
ckbrownla 0 solutions 2 answers

Hi Guys,

I have been miserable with a issue where YouTube Videos says that the player in my browser is not on a list of supported players. When I ran across the question started here I Read it down to the reply from FredMcD.

Here is the part that helped me:< In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

This page showed that I have a legacy YouTube Flash Player extension. There was a options button!!!! I pressed the button and there it was, A selection box popped up and it was titled, YouTube Video Player. the selection window showed, Flash Video Player. There was a selection arrow button to the right side. I clicked it and there it was, HTML5 Video Player. This legacy YouTube Flash Player extension was forcing all YouTube videos to play using Flash. When I restarted the page with the video, BAMM there it was. I have checked this with several YouTube pages that did not play and they are all good!!!

Hi Guys, I have been miserable with a issue where YouTube Videos says that the player in my browser is not on a list of supported players. When I ran across the question started here I Read it down to the reply from FredMcD. Here is the part that helped me:< In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. This page showed that I have a legacy YouTube Flash Player extension. There was a options button!!!! I pressed the button and there it was, A selection box popped up and it was titled, YouTube Video Player. the selection window showed, Flash Video Player. There was a selection arrow button to the right side. I clicked it and there it was, HTML5 Video Player. This legacy YouTube Flash Player extension was forcing all YouTube videos to play using Flash. When I restarted the page with the video, BAMM there it was. I have checked this with several YouTube pages that did not play and they are all good!!!

Modified by ckbrownla

Was this helpful to you? 2
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

That was very good work. Well done.

Legacy just means that in a future version, those add-oms will not work in Firefox. They will need to be rewritten or replaced.

That was very good work. Well done. Legacy just means that in a future version, those add-oms will not work in Firefox. They will need to be rewritten or replaced.
Was this helpful to you? 0
Quote
tjphoto40 0 solutions 11 answers

FredMcD said

I see you have several YouTube add-ons. Disable them. Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Before I received this and another reply that seemed directed to my posting, I noticed a little icon in the upper right of the Firefox window, next to the menu icon, that is a Flash Player button that can be turned on or off. (Is this what's meant by a Legacy version of Flash?) I simply clicked on it to turn it off, and the YouTube videos all appeared normal again. So I didn't need to do anything more than that. Some of the other methods suggested here struck me as overly complex or questionable, and I was worried about harming some other aspect of my browser function. But at least I figured out this simple fix. Thanks.

''FredMcD [[#answer-1006948|said]]'' <blockquote> I see you have several YouTube add-ons. Disable them. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Before I received this and another reply that seemed directed to my posting, I noticed a little icon in the upper right of the Firefox window, next to the menu icon, that is a Flash Player button that can be turned on or off. (Is this what's meant by a Legacy version of Flash?) I simply clicked on it to turn it off, and the YouTube videos all appeared normal again. So I didn't need to do anything more than that. Some of the other methods suggested here struck me as overly complex or questionable, and I was worried about harming some other aspect of my browser function. But at least I figured out this simple fix. Thanks.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42863 answers

Good Work.

Good Work.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.