X
Tap here to go to the mobile version of the site.

Support Forum

How do I fix Firefox so the Captcha boxes are back?

Posted

PROBLEM: Accessing a site I've always used with ease, and siumilar others, login pages no longer show the Captcha "I'm not a robot." that uses the images "Click on the street signs", or "cars" or... etcetera. Yet, Chrome displays it fine, as does IE.

TESTS: - Tried to access with add-ons at normal. FF has, as always, has Adobe products blocked. FF refuses to let me use it anyway, refuses to let me upgrade it because the FF "Upgrade" link just opena a Moz wall of geekinese attempting to explain that FF is protecting me - but no update. I fought FF and was still able to update Adobe stuff.

- Tried with all addons disabled.

- The "About Mozilla Firefox" screen that cannot be copied and pasted here on barely visible, very light gray font "Firefox is up to date". 52.1.2 (32-bit) Apparently, it is now called Firefox ESR. What ever that means.

I've attached an image showing both versions. The working one by the Stalker - Chrome, and the one that quit by Firefox.

How do I fix Firefox so the Captcha boxes are back?

O

PROBLEM: Accessing a site I've always used with ease, and siumilar others, login pages no longer show the Captcha "I'm not a robot." that uses the images "Click on the street signs", or "cars" or... etcetera. Yet, Chrome displays it fine, as does IE. TESTS: - Tried to access with add-ons at normal. FF has, as always, has Adobe products blocked. FF refuses to let me use it anyway, refuses to let me upgrade it because the FF "Upgrade" link just opena a Moz wall of geekinese attempting to explain that FF is protecting me - but no update. I fought FF and was still able to update Adobe stuff. - Tried with all addons disabled. - The "About Mozilla Firefox" screen that cannot be copied and pasted here on barely visible, very light gray font "Firefox is up to date". 52.1.2 (32-bit) Apparently, it is now called Firefox ESR. What ever that means. I've attached an image showing both versions. The working one by the Stalker - Chrome, and the one that quit by Firefox. How do I fix Firefox so the Captcha boxes are back? O
Attached screenshots

Chosen solution

I also had this problem, and found another thing to try if none of the above work. If you hate being tracked and are a browser tweaker, you may (at some point in the past) have adjusted the value of network.http.sendRefererHeader to zero (0) from an about:config window. If nothing else works, you might try setting its value to either 1 or restoring the default value. Setting it to 1 allowed the Captcha boxes to work again on many of the sites I had started having trouble logging into even in Safe Mode.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Shockwave Flash 25.0 r0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected. You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window. *Options/Preferences > Privacy: "Use Tracking Protection in Private Windows" *https://support.mozilla.org/en-US/kb/tracking-protection-firefox *https://support.mozilla.org/en-US/kb/control-center-site-privacy-and-security-firefox ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 1
Quote

Question owner

cor-el said

....... Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
........

Thanks very much. Following all of your advice (steps), from top down and eventually using process of elimination of add-ons, and even with the most recent update, I found the culprit to be Mozilla. I would copy and paste from FF the information, but we apparently are not allowed to copy any text out of the Add-ons screens. Looks like the battle with the corporate Stalkers is almost lost. Lightbeam was a good add-on for me that helped me block cheesy, sleazy stalkers, and other nefarious sites.

''cor-el [[#answer-976222|said]]'' <blockquote> ....... Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window ........ </blockquote> Thanks very much. Following all of your advice (steps), from top down and eventually using process of elimination of add-ons, and even with the most recent update, I found the culprit to be Mozilla. I would copy and paste from FF the information, but we apparently are not allowed to copy any text out of the Add-ons screens. Looks like the battle with the corporate Stalkers is almost lost. Lightbeam was a good add-on for me that helped me block cheesy, sleazy stalkers, and other nefarious sites.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

You can find information about extensions that you can copy on the Help -> Troubleshooting Information page.

You can find information about extensions that you can copy on the Help -> Troubleshooting Information page. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox
Was this helpful to you? 1
Quote
wendygoerl 0 solutions 9 answers

I turned Tracking Protection off completely and I'm still getting "Google re-CAPTCHA failed to load. Please check your internet connection and reload this page."

Did I mention this is a just-opened browser? And it's happening on MULTIPLE sites, and has been going on for MONTHS.

I also have sites where video fails to load--not even the frame appears. Is this related?

I turned Tracking Protection off completely and I'm still getting "Google re-CAPTCHA failed to load. Please check your internet connection and reload this page." Did I mention this is a just-opened browser? And it's happening on MULTIPLE sites, and has been going on for MONTHS. I also have sites where video fails to load--not even the frame appears. Is this related?
Was this helpful to you? 0
Quote
fizzbowen 1 solutions 4 answers

I am having the same problem with Firefox 54.0.1 32-bit under Windows 10. The site is <https://verified.capitalone.com/challenge.html#/>, which is accessed via a redirect from <https://verified.capitalone.com/sic-ui/#/esignin?Product=360Bank>. I can get in via Google Chrome, but not Firefox. I've done the following:

  • Started Firefox in safe mode (no addons/default theme)
  • Not using private browsing
  • Cleared cache
  • Allowed all third-party cookies
  • Allowed pop-ups
  • Turned off all tracking protection
  • Used native Windows 10 firewall and antivirus only

Over time, I've had increasing problems with more and more sites in Firefox as they adopt the latest Recaptcha version. Capital One stopped working a couple of weeks ago when they switched to the Recaptcha version that requires identifying images containing cars, and pops up new images to replace the ones you select until there are no more cars. I am hoping this can be fixed, please.

I am having the same problem with Firefox 54.0.1 32-bit under Windows 10. The site is <https://verified.capitalone.com/challenge.html#/>, which is accessed via a redirect from <https://verified.capitalone.com/sic-ui/#/esignin?Product=360Bank>. I can get in via Google Chrome, but not Firefox. I've done the following: * Started Firefox in safe mode (no addons/default theme) * Not using private browsing * Cleared cache * Allowed all third-party cookies * Allowed pop-ups * Turned off all tracking protection * Used native Windows 10 firewall and antivirus only Over time, I've had increasing problems with more and more sites in Firefox as they adopt the latest Recaptcha version. Capital One stopped working a couple of weeks ago when they switched to the Recaptcha version that requires identifying images containing cars, and pops up new images to replace the ones you select until there are no more cars. I am hoping this can be fixed, please.

Modified by fizzbowen

Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

Did you try Firefox Safe Mode in case an extension in blocking content?

An URL with a hash appended usually means that some JavaScript is involved. You can check the Web Console for error messages.


Are you allowing redirection?

  • "3-bar" menu button -> Options/Preferences -> Advanced -> General
    Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

Did you try Firefox Safe Mode in case an extension in blocking content? An URL with a hash appended usually means that some JavaScript is involved. You can check the Web Console for error messages. *https://developer.mozilla.org/Tools/Web_Console ---- Are you allowing redirection? *"3-bar" menu button -> Options/Preferences -> Advanced -> General<br>Accessibility : [ ] "Warn me when web sites try to redirect or reload the page" The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting. See also: *https://support.mozilla.org/en-US/kb/settings-network-updates-and-encryption#w_general-tab *http://kb.mozillazine.org/accessibility.blockautorefresh *http://kb.mozillazine.org/Accessibility_features_of_Firefox
Was this helpful to you? 0
Quote

Helpful Reply

I don't understand why is it that we have to step back, click links and read walls of text chock full of techinese just to use a browser in it's basic bare-bone off-the-rack, completely updated, upgraded with anti-virus dropped, malware protection dropped.

I thought the idea behind FF was so we didn't have to become kiddie-koders just to grasp some of the volumes of contents from the many 'try this' links.

It would also help here if those responding, named to whom the answer is directed. i.e. Who are you talking to? And who are you suggesting your tweaks to?

I have used Moz products since Netscape first version and it's amazing how, with the Internet, once called the "Information Highway", now the Google Catalogue" of junk, that a browser user needs so much knowledge, pay so much attention to tweaking and twonking just to get past a simple captcha.

Suggestion to the coders. Stop trying to make it better, just make it work remembering that just because so many kids out there want to add so many totally unnecessary bells a whistles to a site, doesn't mean Mozilla needs to accommodate them.

I use both now. Firefox and Chrome. Firefox for privacy when researching, and Chrome when I'm forced by government, utility, and corporate sites, to disrobe and run naked on their sites whilst they review my once personal information and Internet habits.

I don't understand why is it that we have to step back, click links and read walls of text chock full of techinese just to use a browser in it's basic bare-bone off-the-rack, completely updated, upgraded with anti-virus dropped, malware protection dropped. I thought the idea behind FF was so we didn't have to become kiddie-koders just to grasp some of the volumes of contents from the many 'try this' links. It would also help here if those responding, named to whom the answer is directed. i.e. Who are you talking to? And who are you suggesting your tweaks to? I have used Moz products since Netscape first version and it's amazing how, with the Internet, once called the "Information Highway", now the Google Catalogue" of junk, that a browser user needs so much knowledge, pay so much attention to tweaking and twonking just to get past a simple captcha. Suggestion to the coders. Stop trying to make it better, just make it work remembering that just because so many kids out there want to add so many totally unnecessary bells a whistles to a site, doesn't mean Mozilla needs to accommodate them. I use both now. Firefox and Chrome. Firefox for privacy when researching, and Chrome when I'm forced by government, utility, and corporate sites, to disrobe and run naked on their sites whilst they review my once personal information and Internet habits.
Was this helpful to you? 2
Quote
Steve 2 solutions 32 answers

I agree 100% with Outernaut. FF was once a user-friendly, easy to use browser that handled everything. Now if I want to watch a video on any site but Youtube or visit a site that requires a Captcha I've got to switch to Chrome or IE - WHY? All those pages of Gobledegeek you've got to wade thru' only to find the fix doesn't work should not be necessary. How about you bring out 2 versions of FF - one for the whizz-kid, kiddie-koder, all the bells & whistles gobledegeek lovers to play with, & another simple version for us normal users? I have tried every fix & found that it is impossible to get a Captcha or a non-Youtube video to work on FF - WHY? Come-on guys, putting out browser that only partially works is just not good enough.

I agree 100% with Outernaut. FF was once a user-friendly, easy to use browser that handled everything. Now if I want to watch a video on any site but Youtube or visit a site that requires a Captcha I've got to switch to Chrome or IE - WHY? All those pages of Gobledegeek you've got to wade thru' only to find the fix doesn't work should not be necessary. How about you bring out 2 versions of FF - one for the whizz-kid, kiddie-koder, all the bells & whistles gobledegeek lovers to play with, & another simple version for us normal users? I have tried every fix & found that it is impossible to get a Captcha or a non-Youtube video to work on FF - WHY? Come-on guys, putting out browser that only partially works is just not good enough.
Was this helpful to you? 1
Quote
fizzbowen 1 solutions 4 answers

Chosen Solution

I also had this problem, and found another thing to try if none of the above work. If you hate being tracked and are a browser tweaker, you may (at some point in the past) have adjusted the value of network.http.sendRefererHeader to zero (0) from an about:config window. If nothing else works, you might try setting its value to either 1 or restoring the default value. Setting it to 1 allowed the Captcha boxes to work again on many of the sites I had started having trouble logging into even in Safe Mode.

I also had this problem, and found another thing to try if none of the above work. If you hate being tracked and are a browser tweaker, you may (at some point in the past) have adjusted the value of '''network.http.sendRefererHeader''' to zero (0) from an about:config window. If nothing else works, you might try setting its value to either 1 or restoring the default value. Setting it to 1 allowed the Captcha boxes to work again on many of the sites I had started having trouble logging into even in Safe Mode.

Modified by fizzbowen

Was this helpful to you? 0
Quote

Helpful Reply

Why does everyone politely call it "tracking"? If any one of us did what these 'trackers' do, we'd be charged with "Stalking" and that is what hey are, they are Stalkers. Painting these Stalkers with the illusion of being just a tracker only encourages those [ redacted ] to build even more intrusive privacy invaders. Call them out for what they are; spying stalkers, peeping Stalkers - Orwellian Overseers or worse, for they are no longer trackers - not anymore.

Why does everyone politely call it "tracking"? If any one of us did what these 'trackers' do, we'd be charged with "Stalking" and that is what hey are, they are Stalkers. Painting these Stalkers with the illusion of being just a tracker only encourages those [ redacted ] to build even more intrusive privacy invaders. Call them out for what they are; spying stalkers, peeping Stalkers - Orwellian Overseers or worse, for they are no longer trackers - not anymore.
Was this helpful to you? 2
Quote
Steve 2 solutions 32 answers

what does this setting do?

network.http.sendRefererHeader;2

what does this setting do? network.http.sendRefererHeader;2

Modified by Steve

Was this helpful to you? 0
Quote
wendygoerl 0 solutions 9 answers

Outernaut said

Why does everyone politely call it "tracking"? If any one of us did what these 'trackers' do, we'd be charged with "Stalking" and that is what hey are, they are Stalkers. Painting these Stalkers with the illusion of being just a tracker only encourages those [ redacted ] to build even more intrusive privacy invaders. Call them out for what they are; spying stalkers, peeping Stalkers - Orwellian Overseers or worse, for they are no longer trackers - not anymore.

You "agreed" to it in the fine print when you started using it. Not any different from what cell phones and even cars do. Unfortunately the time to put the brakes on this stuff came and went years ago.

''Outernaut [[#answer-991566|said]]'' <blockquote> Why does everyone politely call it "tracking"? If any one of us did what these 'trackers' do, we'd be charged with "Stalking" and that is what hey are, they are Stalkers. Painting these Stalkers with the illusion of being just a tracker only encourages those [ redacted ] to build even more intrusive privacy invaders. Call them out for what they are; spying stalkers, peeping Stalkers - Orwellian Overseers or worse, for they are no longer trackers - not anymore. </blockquote> You "agreed" to it in the fine print when you started using it. Not any different from what cell phones and even cars do. Unfortunately the time to put the brakes on this stuff came and went years ago.
Was this helpful to you?
Quote
wendygoerl 0 solutions 9 answers

fizzbowen said

I also had this problem, and found another thing to try if none of the above work. If you hate being tracked and are a browser tweaker, you may (at some point in the past) have adjusted the value of network.http.sendRefererHeader to zero (0) from an about:config window. If nothing else works, you might try setting its value to either 1 or restoring the default value. Setting it to 1 allowed the Captcha boxes to work again on many of the sites I had started having trouble logging into even in Safe Mode.

Mine's set at "2" and I'm having trouble with more and more sites.

''fizzbowen [[#answer-991563|said]]'' <blockquote> I also had this problem, and found another thing to try if none of the above work. If you hate being tracked and are a browser tweaker, you may (at some point in the past) have adjusted the value of '''network.http.sendRefererHeader''' to zero (0) from an about:config window. If nothing else works, you might try setting its value to either 1 or restoring the default value. Setting it to 1 allowed the Captcha boxes to work again on many of the sites I had started having trouble logging into even in Safe Mode. </blockquote> Mine's set at "2" and I'm having trouble with more and more sites.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer.

You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer.
Was this helpful to you?
Quote

Question owner

cor-el said

You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer.

Is it not possible that one of those "odd effects" might result in a tad more added privacy? ;)

I'm very afraid that FireFox may no longer hold it's own. It is the last true user-controlled browser that may protect us from the scoundrels, shysters, and ner'r-do-wells (they would be government, corporations and ISP stalkers; AKA PIPs (Peeping Internet Perverts).

O

''cor-el [[#answer-992196|said]]'' <blockquote> You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer. </blockquote> Is it not possible that one of those "odd effects" might result in a tad more added privacy? ;) I'm very afraid that FireFox may no longer hold it's own. It is the last true user-controlled browser that may protect us from the scoundrels, shysters, and ner'r-do-wells (they would be government, corporations and ISP stalkers; AKA PIPs (Peeping Internet Perverts). O
Was this helpful to you?
Quote
Steve 2 solutions 32 answers

cor-el said

You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer.

I don't know enough to mess with this so it's still at its original setting. It says 'default' in the settings column so I guess 2 is the default. I will change it from 2 to 0 & see what happens. I'll report back on the result. I've just read a few more replies & I'm confused. What to the numbers mean? Is 0 disable & then 1 = allow & 2 = ask user etc? What is the best setting 0 or 1?

''cor-el [[#answer-992196|said]]'' <blockquote> You should leave prefs like network.http.sendRefererHeader (2) to their default. You may see odd effects when you disable the referrer. </blockquote> I don't know enough to mess with this so it's still at its original setting. It says 'default' in the settings column so I guess 2 is the default. I will change it from 2 to 0 & see what happens. I'll report back on the result. I've just read a few more replies & I'm confused. What to the numbers mean? Is 0 disable & then 1 = allow & 2 = ask user etc? What is the best setting 0 or 1?

Modified by Steve

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

The default is best and makes Firefox send the referrer with all request. Some servers use the referrer to make sure the request originates from a page on their website and block files if the referrer is missing or incorrect.

More information:

The default is best and makes Firefox send the referrer with all request. Some servers use the referrer to make sure the request originates from a page on their website and block files if the referrer is missing or incorrect. More information: *http://kb.mozillazine.org/network.http.sendRefererHeader
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.