X
Tap here to go to the mobile version of the site.

Support Forum

Why when I click forget history button, I select last 24 hours, then click last forget button it switches me to 5 minutes, won't let me forget 24 hours why

Posted

When I click the button to forget browser history, and then I select the option of forgetting the last 24 hours, at first it selects what I wanted BUT as soon as i click the final "forget" button, it automatically switches me to only 5 minutes and then disappears with the "thank you" message for me to click on. It won't let me forget 24 hours. This happened over and over. This is not something a user can fix. Only Mozilla Firefox can fix it. I know you are made up of volunteers, so I will appreciate your time whenever you can reply and whenever you can fix the problem. Also, I will appreciate if you are able to make it so we can forget all browser history, not just 24 hours. Thank you for your generous time and hard work.

When I click the button to forget browser history, and then I select the option of forgetting the last 24 hours, at first it selects what I wanted BUT as soon as i click the final "forget" button, it automatically switches me to only 5 minutes and then disappears with the "thank you" message for me to click on. It won't let me forget 24 hours. This happened over and over. This is not something a user can fix. Only Mozilla Firefox can fix it. I know you are made up of volunteers, so I will appreciate your time whenever you can reply and whenever you can fix the problem. Also, I will appreciate if you are able to make it so we can forget all browser history, not just 24 hours. Thank you for your generous time and hard work.

Additional System Details

Installed Plug-ins

  • This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ----------------- '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.