X
Tap here to go to the mobile version of the site.

Support Forum

New OUTLOOK email Inbox shows only blank page

Posted

My HOTMAIL account some months ago changed itself to OUTLOOK. Since then my iMac screen loads up with the Outlook format, but the INBOX page remains a total blank, which does not respond to clicking. Outlook Support tested my iPad. It does deliver full Oulook service but does it through an App. They suggest the problem is due to some failing in my browser function when working with my iMac. Can any Firey Foxcub help me out?

My HOTMAIL account some months ago changed itself to OUTLOOK. Since then my iMac screen loads up with the Outlook format, but the INBOX page remains a total blank, which does not respond to clicking. Outlook Support tested my iPad. It does deliver full Oulook service but does it through an App. They suggest the problem is due to some failing in my browser function when working with my iMac. Can any Firey Foxcub help me out?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

FredMcD
  • Top 10 Contributor
4149 solutions 57940 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart.

Question owner

Dear Fred McD. thank you very much for your help. It is Sunday so I have not had time to try it yet. But I am hoping to. But even if it doesn't, it is still heartwarming to have such akind response from the global MOZILLA community. David the ASBESTOSFOX.

Dear Fred McD. thank you very much for your help. It is Sunday so I have not had time to try it yet. But I am hoping to. But even if it doesn't, it is still heartwarming to have such akind response from the global MOZILLA community. David the ASBESTOSFOX.

Question owner

Dear Fred McD. Thanks to you I have successfully cleared out my cache and cookies. But problem persists. Numerous chats with Hotmail/Outlook advisers point to the conclusion that my computer is no longer modern and fast enough to load the latest FIREFOX upgrades. So my problem is insoluble. Without further help from Santa Claus who brought me my present present. Meanwhile friends have mentioned MOZILLA THUNDERBIRD (?) which I shall investigate Thank you again for taking the time to help me with your expertise. David ASBESTOSFOX

Dear Fred McD. Thanks to you I have successfully cleared out my cache and cookies. But problem persists. Numerous chats with Hotmail/Outlook advisers point to the conclusion that my computer is no longer modern and fast enough to load the latest FIREFOX upgrades. So my problem is insoluble. Without further help from Santa Claus who brought me my present present. Meanwhile friends have mentioned MOZILLA THUNDERBIRD (?) which I shall investigate Thank you again for taking the time to help me with your expertise. David ASBESTOSFOX

Modified by ASBESTOSFOX