Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove bing search

  • 84 replies
  • 15 have this problem
  • 270 views
  • Last reply by KeithElmer

more options

Home page is Google. When I search I get bing results. How do I stop this

Modified by guigs

Chosen solution

Hi KeithElmer, thanks for the list. This is the one mufngruf was saying you need to remove:

SafeSearch Incognito 0.1.8 true @safesearchincognito

Can you find that on the Add-ons page? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. See whether you can remove "SafeSearch Incognito" (look for a Remove button). If you do not find a Remove button, that usually indicates it was installed in a shared folder, and I can suggest a roundabout way to track down where that is.

Of course, all extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Success?

Read this answer in context 👍 3

All Replies (20)

more options

could we try, what may be, the easiest solution? How do I export all the settings, passwords, boookmarks , add ons etc from my current FF profile and then, get rid of all them other profiles, start afresh and import the "personal stuff...? that may be the easiest thing to do BUT will it then re-load whatever setting is causing this issue?

more options

do you know if this earlier suggestion was successful? https://addons.mozilla.org/en-US/firefox/addon/searchreset/

more options

The one with default-1471697844806 looks largest. That kind of name is created if you use the Refresh feature while your default profile was named default.

> I found a "prefs.js" file and also a "prefs-2.js"

Firefox creates numbered prefs files when there is some kind of lock on writing to prefs.js. This is one of the problems that can cause settings to be lost every time you quit Firefox and start it up again. (See: How to fix preferences that won't save)

It's also possible prefs-2.js is an old leftover that has no current relevance. You'll need to check the file dates.

When you copy your current prefs.js file from one profile to another, the destination profile should acquire settings such as: preferred startup/home page settings, tiles pinned on Firefox's new tab page, privacy settings, etc. You wouldn't notice the changes created by extensions such as Classic Theme Restorer because without CTR, those preferences are just meaningless to Firefox.

So what does the "restart with add-ons disabled" function do that manually disabling all the add ons doesn't do?

The best list I've seen is in this article, but I can't say for sure that it is complete: http://kb.mozillazine.org/Safe_Mode

How do I export all the settings, passwords, boookmarks , add ons etc from my current FF profile and then, get rid of all them other profiles, start afresh and import the "personal stuff...?

No need to export/delete. I suggest copying one or two files at a time from your main profile to your test profile. This article lists the function of the various built-in files: Recovering important data from an old profile.

That article doesn't cover extensions and their data. Most of that should be in the extensions folder. Note also the gm_scripts folder for your Greasemonkey userscripts.

more options

well - now, in the largest profile, I have a prefs-.js and prefs.old (which I renamed after the instructions). If the plan is to move all the old stuff into the new profiel - why do I do it "justa couple of files at a time"?

I really HATE to be such a bother and so STOOPID abut this.. but I'm almost 70 and I can get lost very easily and I'm TERRIFIED of losing all my "stuff" Isn't there just some way to "ungrey" the option to reset the Bing thing to "false"?

more options

or maybe I should just get used to bing and wait until this same thing affects more folks and FF fixes it. I realise that you think that it's just ME and must be something wrong with MY settings - but I didn't change any... I did nothing different..

more options

mufngruf said

do you know if this earlier suggestion was successful? https://addons.mozilla.org/en-US/firefox/addon/searchreset/

It was.
The link FredMcD provided looked different from mine,  but led to the same URL.
FredMcD's   post was marked :   'Chosen Solution',   because it   worked   ........

more options

ok - just now, out of the blue, I got another "security update" option.. see picture which I clicked on and it gave me something called "safe search" see picture but the search still takes me to bing.. are you familiar with this "safe search" thing?

more options

Happy112 said

mufngruf said
do you know if this earlier suggestion was successful? https://addons.mozilla.org/en-US/firefox/addon/searchreset/

It was.
The link FredMcD provided looked different from mine,  but led to the same URL.
FredMcD's   post was marked :   'Chosen Solution',   because it   worked   ........

I went there - downladed it and it told me that it was installed - but it's not in my add on folder.. or anywhere that I can find. I did a restart and it has now given me a new startup pa=ge (default Firefox) and done away with my own.. and the search is still bing....

more options

mufngruf said

or maybe I should just get used to bing and wait until this same thing affects more folks and FF fixes it. I realise that you think that it's just ME and must be something wrong with MY settings - but I didn't change any... I did nothing different..

You said earlier that you had tried everything that had been suggested;   but you didn't try the   SearchReset,   did you   ? Come on and give it a try   ! You want to give up now and   'get used to   Bing'   ? You don't strike me as a quitter   ..........

more options

I just tried it.. we're passing each other..

It DID reset my home page, but did nothing to the search issue.

more options

I fixed it.

more options

mufngruf said

ok - just now, out of the blue, I got another "security update" option.. see picture which I clicked on and it gave me something called "safe search" see picture but the search still takes me to bing.. are you familiar with this "safe search" thing?

That's some kind of crap you should get rid of. Please never ever install "updates" to Firefox from popups on web pages.

mufngruf said

I fixed it.

Completely fixed it? I don't need to reply to the other questions?

more options

remember I said that all was well until I updated a 'FF security" option, a day ago? When I did that, I didn't pay attention to the new "safesearch" window that opened... but that's when it all went titsup...

and then, just a few moments ago, I got the same "update" message which at least LOOKS very official.. and reinstalled it, but this time, I paid attention to the new search site that it sent me to... "SafeSearch (apparently a google offshoot) So, I finally looked all the way down the list of disabled add ons and found this thing... "SafeSearch Incognito 0.1.7 false @safesearchincognito" I "removed" it - restarted - and all is back to normal....

except - the bing entries in "about:config" are still there and stil greyed out...

more options

On your last screenshot I noticed   SafeSearch.net,   and a bell began to ring;   see:
https://malwaretips.com/blogs/safesearch-net-removal/

more options

Happy112 said

On your last screenshot I noticed   SafeSearch.net,   and a bell began to ring;   see:
https://malwaretips.com/blogs/safesearch-net-removal/

...... and while I was posting this;   you already fixed it;   good for you   !!!

more options

mufngruf said

So, I finally looked all the way down the list of disabled add ons and found this thing...
"SafeSearch Incognito 0.1.7 false @safesearchincognito" I "removed" it - restarted - and all is back to normal....

except - the bing entries in "about:config" are still there and stil greyed out...

Wow, I thought disabling the extension would be enough to actually disable it. Perhaps they know some new trick.

Regarding the preferences in about:config, do they start with extension. ? To clear those, you can right-click (or Ctrl+click) and then choose Reset. When you exit about:config and open it again, they should be gone, unless they are created by a different extension that is still installed.

more options

those "extensions" in about:config are greyed out - and cannot be reset.

more options

mufngruf said

those "extensions" in about:config are greyed out - and cannot be reset.

They are greyed out because they are disabled   !
Main question is:   do you still get  Bing-results   ???
You shouldn't,   but if you do:   SearchReset   !

more options

the items themselves ar enot greyed out, just the 'reset' option, If you look back in the thread, you'll see that i tried "search/reset" and what the results were.

And, no, I no longer get Bing results.

more options

mufngruf said

the items themselves ar enot greyed out, just the 'reset' option,

I see, that means the preference has the default value created by the extension when it was installed, so there's nothing to reset. Are there particular preferences that look like a problem?

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5