Search Support

Firefox won't remember homepage, or some settings, replaces with yahoo.

  • 3 replies
  • 1 has this problem
  • 166 views
  • Last reply by FredMcD

more options

I've never had a problem with Firefox until recently and this is starting to get on my nerves. My problem is yahoo.

Yahoo keeps showing up as my home page. I go into the settings and I fix it. It doesn't last, and before you know it. Yahoo. It sometimes loads itself as my preferred search bar, as well. Under settings where you can add your own homepage, mine keeps resetting to this: http://searchinterneat-a.akamaihd.net/hm?eq=U0EeCFZVBB8SRggQc1oNWF8VQBgWdwkJTA0QGAAOeFsAU RRHFlcVcQlcVwpHRAMFIk0FA18DB0VXfWFoKB8fHGZGIUtbCXcUVmJKLl1XFg== Which brings me to yahoo. There is also an ad-on that shows up occasionally. I don't know if it is related, I keep disabling/removing it. But it comes back, too.

I've searched and have tried everything. I'm using Windows 10, on a brand new computer. I've tried changing the settings {constantly}. I've tried looking into the properties after right clicking the firefox icon {but there was nothing wrong with that part}. I have even tried refreshing Firefox. That did nothing. I've done some scans and I'm not finding anything

I'm getting rather frustrated. I love Firefox but I'm not going to continue to use it if this doesn't go away. I use this computer for work and I need something that is reliable.

~ thanks

Attached screenshots

Modified by Flooboo

Chosen solution

Separate Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.


Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Read this answer in context 👍 3

All Replies (3)

more options

Chosen Solution

Separate Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.


Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

more options

This seems to have worked!

Thank you for the help!

more options

Glad to help. Safe Surfing.