Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using 70-90% cpu 411K+ ram no addons or flash a couple tabs & locks my XP netbook anyway to use less resource killing me

more options

Hi I saw the article about getting firefox to use less resource but I have no extensions or addons and removed flash entirely really bare bones vanilla firefox version 43 - its killing me. Using up to 90% CPU and hits over 411K memory - nothing else really running closed everything I could in task manager except what won't close or needed to keep things running and a few web pages open - locks me up. Thanks

Chosen solution

The Firefox uses too much memory or CPU resources - How to fix article was recently updated with a solution of deleting content-prefs.sqlite file. Try that solution, and tell us if it works.

Read this answer in context 👍 1

All Replies (16)

more options
more options

I'll take another look at these but I don't have anything else no add ons, extensions, apps, themes - the ones like adobe require to ask me before running and I removed flash from the computer entirely. I'll check adobe but I don't see any other apps running but firefox when it does this - using 547K memory now - one other tab besides this one open although the cpu is calm less than 10% right now so not sure why or how it hits 70- 90% with normal use at other times

more options

Well if nobody else has an idea how to lighten up Foxfire, I think I"m going to have to replace Foxfire with Chrome much as I've no trust in Google but I can't have the computer maxing out just by opening a browser and clicking a single website or two. Cookies cache automatically deletes every time I close out too so its not that either.

more options

poorgirl said

Well if nobody else has an idea how to lighten up Foxfire, I think I"m going to have to replace Foxfire with Chrome much as I've no trust in Google but I can't have the computer maxing out just by opening a browser and clicking a single website or two. Cookies cache automatically deletes every time I close out too so its not that either.

Good luck with Chrome. Support for WinXP ended back in April. http://arstechnica.com/gadgets/2015/11/chrome-to-end-support-for-windows-xp-vista-and-os-x-10-8-on-april-2016/

As far as Flash goes, your initial posting shows that Flash is available for Firefox. Check the Control Panel > Add or Remove Programs and locate the Plugin version of Flash; uninstall it.

IE uses the ActiveX version of Flash - maybe that is what you removed.

more options

the-edmeister said

poorgirl said
Well if nobody else has an idea how to lighten up Foxfire, I think I"m going to have to replace Foxfire with Chrome much as I've no trust in Google but I can't have the computer maxing out just by opening a browser and clicking a single website or two. Cookies cache automatically deletes every time I close out too so its not that either.

Good luck with Chrome. Support for WinXP ended back in April. http://arstechnica.com/gadgets/2015/11/chrome-to-end-support-for-windows-xp-vista-and-os-x-10-8-on-april-2016/

As far as Flash goes, your initial posting shows that Flash is available for Firefox. Check the Control Panel > Add or Remove Programs and locate the Plugin version of Flash; uninstall it.

IE uses the ActiveX version of Flash - maybe that is what you removed.

I didn't know Chrome wasn't supported for XP anymore but I no longer update Firefox because each update soaks more and more resources and it is going to crash my machine. Checked and there is no Flash in programs. It was always giving me trouble so I just got rid of it & I don't use IE on that machine either although it is still there but never opened. Very few programs on that little netbook - used mostly for internet/email but now it just sits unused because it is virtually unusable after a few minutes with using Firefox. CPU gets fully absorbed and slow as 80s dialup then browser becomes non responsive and that's it. Done for. Wish there was a lightweight Firefox version. Maybe Opera?

more options

Chosen Solution

The Firefox uses too much memory or CPU resources - How to fix article was recently updated with a solution of deleting content-prefs.sqlite file. Try that solution, and tell us if it works.

more options

Chris Ilias said

The Firefox uses too much memory or CPU resources - How to fix article was recently updated with a solution of deleting content-prefs.sqlite file. Try that solution, and tell us if it works.

No idea what that is - where I'd find it or how to delete it. But when I ran spybot I let it delete all temp files if that's a sqlite file I don't know.

more options

The instructions are at the bottom section of the article. :)

more options

Chris Ilias said

The instructions are at the bottom section of the article. :)

Thanks . Ok I just deleted it - now if it makes any difference over the next day or so I'll let you know. Fingers crossed.

Modified by Disappointeduser

more options

Chris Ilias said

The Firefox uses too much memory or CPU resources - How to fix article was recently updated with a solution of deleting content-prefs.sqlite file. Try that solution, and tell us if it works.

Chris you rock - that seemed to do it and Firefox is flying again. So happy. I'm booking this fix in my favorites incase I get bogged down again. THANK YOU!

Modified by Disappointeduser

more options

poorgirl said

I'm booking this fix in my favorites incase I get bogged down again.

What you can do is create a Word file and place links and other information there. And use tags for easy searching.

more options

FredMcD said

poorgirl said
I'm booking this fix in my favorites incase I get bogged down again.

What you can do is create a Word file and place links and other information there. And use tags for easy searching.

Thanks!

more options

Chris Ilias said

The Firefox uses too much memory or CPU resources - How to fix article was recently updated with a solution of deleting content-prefs.sqlite file. Try that solution, and tell us if it works.

What about the sqlite folder holding cookies? Using a lot of space there too. Can that be deleted without problems as well? Thanks.

more options

Bad cookies; You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.

more options

poorgirl said

What about the sqlite folder holding cookies? Using a lot of space there too. Can that be deleted without problems as well? Thanks.

I assume you're talking about the cookies.sqlite file. That holds your web cookies, so assuming it's not corrupt, you can delete all cookies using the clear recent history function. For instructions, visit Clear cookies and site data in Firefox.

How big it is depends on how many cookies you have. My largest one is 1MB.

If you suspect that it is corrupt, you can delete it with Firefox closed. All of your cookies will be cleared. If you're looking to purge files from your profile, you should try refreshing your profile. For instructions, visit Refresh Firefox - reset add-ons and settings

more options

Chris Ilias said

poorgirl said
What about the sqlite folder holding cookies? Using a lot of space there too. Can that be deleted without problems as well? Thanks.

I assume you're talking about the cookies.sqlite file. That holds your web cookies, so assuming it's not corrupt, you can delete all cookies using the clear recent history function. For instructions, visit Clear cookies and site data in Firefox.

How big it is depends on how many cookies you have. My largest one is 1MB.

If you suspect that it is corrupt, you can delete it with Firefox closed. All of your cookies will be cleared. If you're looking to purge files from your profile, you should try refreshing your profile. For instructions, visit Refresh Firefox - reset add-ons and settings

Thanks will check it all - just deleted a sqlite that said places having over 10K data. Not sure what that was either but I thought once I closed browser all cookies were being deleted so I'm surprised to learn they're still lingering in these sqlite folders. Thanks again. Running better now anyway & I've encountered no problems after deleting all these files.