X
Tap here to go to the mobile version of the site.

Support Forum

Google search has slowed down and almost stopped after last Firefox upgrade -- what to do

Posted

Question is as above. Firefox is also often challenging the security of google search or other google sites. How to fix?

Question is as above. Firefox is also often challenging the security of google search or other google sites. How to fix?

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Citrix Online App Detector Plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • Firefox 45.0b2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0/WINNT/en-US/

Extensions

  • Adguard AdBlocker 2.0.20 (adguardadblocker@adguard.com)
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • Kaspersky Protection 4.6.2.23.1 (light_plugin_D772DC8D6FAF43A29B25C4EBAA5AD1DE@kaspersky.com)
  • E-Web Print 1.23.00 (e-webprint@epson.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: AMD Radeon HD 8690A
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x6660
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 05db1028
  • adapterSubsysID2: 05db1028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x1002
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 7-17-2015
  • driverDate2: 12-1-2015
  • driverVersion: 10.18.15.4256
  • driverVersion2: 15.301.1101.0
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
FredMcD
  • Top 10 Contributor
4308 solutions 60504 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Regarding the certificate issue, it's probably a Kaspersky setup issue, but I'll give you my whole spiel just in case it's something else.

When you get untrusted connection errors for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.


To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

Regarding the certificate issue, it's probably a Kaspersky setup issue, but I'll give you my whole spiel just in case it's something else. When you get untrusted connection errors for pretty much all secure sites, the problem usually is one of the following: (1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem. (2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites. (3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: [http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings]) (4) Malware on your system intercepting secure connections. So... which is it? If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us. ---- To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting: Load my test page at: https://jeffersonscher.com/res/jstest.php You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button. ''Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.'' Click Add Exception, and the certificate exception dialog should open. Click the View button. If View is not enabled, try the Get Certificate button first. This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

Question owner

Thank you for both replies. I've cleared my cache but not tried google search yet. The site blocking is really covering a lot of sites and so I'm interested too in the second reply. Yes, I do have Kaspersky, and yes I just recently renewed my licence to that. So what do I do to make it stop blocking sites or saying their certs are not valid? Thanks

Thank you for both replies. I've cleared my cache but not tried google search yet. The site blocking is really covering a lot of sites and so I'm interested too in the second reply. Yes, I do have Kaspersky, and yes I just recently renewed my licence to that. So what do I do to make it stop blocking sites or saying their certs are not valid? Thanks
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Hi Plumbuddle, if you recently updated from KIS 2015 to KIS 2016, you may need to remove an old certificate and import a new one. Check out my reply in the following thread for the steps: https://support.mozilla.org/questions/1105976#answer-835774

Hi Plumbuddle, if you recently updated from KIS 2015 to KIS 2016, you may need to remove an old certificate and import a new one. Check out my reply in the following thread for the steps: https://support.mozilla.org/questions/1105976#answer-835774

Question owner

I got into the certificate section and there was no old certificate. I clicked import and pasted in the file you mention in the other question. The response was that that file did not exist. Is there another way round this, do you know? Thanks so much for your time

I got into the certificate section and there was no old certificate. I clicked import and pasted in the file you mention in the other question. The response was that that file did not exist. Is there another way round this, do you know? Thanks so much for your time
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Could you do the "Issued by" check that I mentioned in an earlier reply to make sure the issue is caused by Kaspersky? It's the part below the line: https://support.mozilla.org/questions/1108001#answer-839700

Could you do the "Issued by" check that I mentioned in an earlier reply to make sure the issue is caused by Kaspersky? It's the part below the line: https://support.mozilla.org/questions/1108001#answer-839700

Question owner

HI there, I just got your browser test page from that link and could not view anything by clicking it. There were no links on the page. Sorry to be slow at this!

HI there, I just got your browser test page from that link and could not view anything by clicking it. There were no links on the page. Sorry to be slow at this!
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

If you could view the page, in other words, if you didn't get a certificate error, then we'll have to investigate Google more directly.

If you copy/paste the following to Firefox's address bar and press Enter to load it, you should get a tab with a form to make a certificate exception:

chrome://pippki/content/exceptionDialog.xul

Try https://www.google.com/ in the form, click Get certificate and if it is retrieved successfully, click the View button.

What do you see in the Issued by section and Details tab (comparison screen shot attached)?

If you could view the page, in other words, if you didn't get a certificate error, then we'll have to investigate Google more directly. If you copy/paste the following to Firefox's address bar and press Enter to load it, you should get a tab with a form to make a certificate exception: chrome://pippki/content/exceptionDialog.xul Try https://www.google.com/ in the form, click Get certificate and if it is retrieved successfully, click the View button. What do you see in the Issued by section and Details tab (comparison screen shot attached)?

Helpful Reply

Hi all, thanks so much for your kind advice. I noticed that on the bottom left of my screen I was getting a Kaspersky message whenever I moved between pages and sites, so I contacted Kaspersky tech support, who collected info on my system and then identified that their software was clashing with Super Anti Spyware software that I also had installed. I have now deleted the SAS and am back to normal! Interestingly this did not affect my internet explorer usage, just Mozilla.

Hi all, thanks so much for your kind advice. I noticed that on the bottom left of my screen I was getting a Kaspersky message whenever I moved between pages and sites, so I contacted Kaspersky tech support, who collected info on my system and then identified that their software was clashing with Super Anti Spyware software that I also had installed. I have now deleted the SAS and am back to normal! Interestingly this did not affect my internet explorer usage, just Mozilla.