X
Tap here to go to the mobile version of the site.

Support Forum

Hardware Acceleration Causes Blue Screen

Posted

I have been trying to get firefox to play 60fps videos on youtube (either flash or HTML5, preferably the latter) but to do this, I need to enable hardware acceleration on firefox (it's the only solution I've found so far) and doing so causes random Blue Screens. I might mention that this only happens in firefox and without hardware acceleration, my youtube videos don't even play at above 20fps. I've been looking for a solution to this issue for days now and haven't found anything, don't understand what's happening.

I have been trying to get firefox to play 60fps videos on youtube (either flash or HTML5, preferably the latter) but to do this, I need to enable hardware acceleration on firefox (it's the only solution I've found so far) and doing so causes random Blue Screens. I might mention that this only happens in firefox and without hardware acceleration, my youtube videos don't even play at above 20fps. I've been looking for a solution to this issue for days now and haven't found anything, don't understand what's happening.

Chosen solution

Tyler Downer said

Download the latest driver from http://support.amd.com/en-us/download/desktop?os=Windows+8.1+-+64

so... I did that... annnnnd it worked

I updated my drivers and downloaded the new Crimson Catalyst, and now it doesn't seem to crash anymore, been waiting for a crash all day, and none so far, so cool

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

Tyler Downer
  • Top 10 Contributor
  • Moderator
1469 solutions 10104 answers

There are a few things you can try:

There are a few things you can try: * Update Firefox: [[Update Firefox to the latest version]] * Update your Graphics Driver: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] * Consider updating to Windows 10 (though that won't likely change this issue). * Refresh Firefox [[Refresh Firefox - reset add-ons and settings]]

Question owner

Tyler Downer said

There are a few things you can try:

I have already tried all of that, no updates, latest version of firefox (v44) doesn't change anything, and I'm on windows 8.1, and refuse to go to windows 10 untill I know that it's not broken

''Tyler Downer [[#answer-836326|said]]'' <blockquote> There are a few things you can try: * Update Firefox: [[Update Firefox to the latest version]] * Update your Graphics Driver: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] * Consider updating to Windows 10 (though that won't likely change this issue). * Refresh Firefox [[Refresh Firefox - reset add-ons and settings]] </blockquote> I have already tried all of that, no updates, latest version of firefox (v44) doesn't change anything, and I'm on windows 8.1, and refuse to go to windows 10 untill I know that it's not broken
cor-el
  • Top 10 Contributor
  • Moderator
16605 solutions 149932 answers

Does Firefox crash or does Windows only crash?

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-":

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the report ID of recent crash reports on the "Help > Troubleshooting Information" page (about:support).

  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

Alternatively you can open about:crashes via the location/address bar.

See also:


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

Does Firefox crash or does Windows only crash? If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-": *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports on the "Help > Troubleshooting Information" page (about:support). *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *http://kb.mozillazine.org/Mozilla_Crash_Reporter *https://support.mozilla.org/kb/Mozilla+Crash+Reporter ----- Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

cor-el said

Does Firefox crash or does Windows only crash? If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-":
  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
You can find the report ID of recent crash reports on the "Help > Troubleshooting Information" page (about:support).
  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.
Alternatively you can open about:crashes via the location/address bar. See also:

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

Just Windows crashes, I have a duel monitor setup on my laptop, and I can see that Firefox is still open when the blue screen occurs because it only occurs on my main screen

''cor-el [[#answer-836344|said]]'' <blockquote> Does Firefox crash or does Windows only crash? If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-": *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports on the "Help > Troubleshooting Information" page (about:support). *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *http://kb.mozillazine.org/Mozilla_Crash_Reporter *https://support.mozilla.org/kb/Mozilla+Crash+Reporter ----- Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> Just Windows crashes, I have a duel monitor setup on my laptop, and I can see that Firefox is still open when the blue screen occurs because it only occurs on my main screen

Question owner

I might also Note that 60fps works on Chrome just fine, but not sure if Hardware Acceleration is on in Chrome

I might also Note that 60fps works on Chrome just fine, but not sure if Hardware Acceleration is on in Chrome
Phoxuponyou 51 solutions 517 answers

The dual monitors might have something to do with it, but what sort of hardware are you running them on? AMD/Nvidia/Intel? Model(s)?

Meanwhile, I found this solution from not too long ago that has similar features: https://support.mozilla.org/en-US/questions/1090298. The rest were really old issues that got fixed with software and driver updates or by disabling Flash's hw acceleration or add-ons. One case was helped by a fresh profile. W8 kept cropping up in the issues, but they were probably from when it was first released and still problematic.

The dual monitors might have something to do with it, but what sort of hardware are you running them on? AMD/Nvidia/Intel? Model(s)? Meanwhile, I found this solution from not too long ago that has similar features: https://support.mozilla.org/en-US/questions/1090298. The rest were really old issues that got fixed with software and driver updates or by disabling Flash's hw acceleration or add-ons. One case was helped by a fresh profile. W8 kept cropping up in the issues, but they were probably from when it was first released and still problematic.

Question owner

Phoxuponyou said

The dual monitors might have something to do with it, but what sort of hardware are you running them on? AMD/Nvidia/Intel? Model(s)? Meanwhile, I found this solution from not too long ago that has similar features: https://support.mozilla.org/en-US/questions/1090298. The rest were really old issues that got fixed with software and driver updates or by disabling Flash's hw acceleration or add-ons. One case was helped by a fresh profile. W8 kept cropping up in the issues, but they were probably from when it was first released and still problematic.

I have an Intergrated AMD Radeon R5 and I have had the problem of hardware acceleration blue screening since I got the computer, I have only recently gotten a second monitor

''Phoxuponyou [[#answer-836377|said]]'' <blockquote> The dual monitors might have something to do with it, but what sort of hardware are you running them on? AMD/Nvidia/Intel? Model(s)? Meanwhile, I found this solution from not too long ago that has similar features: https://support.mozilla.org/en-US/questions/1090298. The rest were really old issues that got fixed with software and driver updates or by disabling Flash's hw acceleration or add-ons. One case was helped by a fresh profile. W8 kept cropping up in the issues, but they were probably from when it was first released and still problematic. </blockquote> I have an Intergrated AMD Radeon R5 and I have had the problem of hardware acceleration blue screening since I got the computer, I have only recently gotten a second monitor

Question owner

The crash occurs on BOTH flash and Firefox Hardware Acceleration, and I have already tried a fresh profile, the real problem I have is why I can't get a decent frame rate on youtube vidoes anymore

The crash occurs on BOTH flash and Firefox Hardware Acceleration, and I have already tried a fresh profile, the real problem I have is why I can't get a decent frame rate on youtube vidoes anymore
Phoxuponyou 51 solutions 517 answers

I have the same setup in my laptop, R5 with Windows 8.1. No bluescreens though, and no dual monitor (I use a 24" monitor for work, but always disable the laptop display when I do).

If you can't get decent FPS without hardware acceleration, then the CPU is probably too low power for the rendering options used in Firefox. Chrome getting all the way to 60 sounds like HWA is on.

Did you try tweaking Firefox settings (in the link for starters) to get HWA not to bluescreen?

I have the same setup in my laptop, R5 with Windows 8.1. No bluescreens though, and no dual monitor (I use a 24" monitor for work, but always disable the laptop display when I do). If you can't get decent FPS without hardware acceleration, then the CPU is probably too low power for the rendering options used in Firefox. Chrome getting all the way to 60 sounds like HWA is on. Did you try tweaking Firefox settings (in the link for starters) to get HWA not to bluescreen?

Modified by Phoxuponyou

Question owner

Phoxuponyou said

I have the same setup in my laptop, R5 with Windows 8.1. No bluescreens though, and no dual monitor (I use a 24" monitor for work, but always disable the laptop display when I do). If you can't get decent FPS without hardware acceleration, then the CPU is probably too low power for the rendering options used in Firefox. Chrome getting all the way to 60 sounds like HWA is on. Did you try tweaking Firefox settings (in the link for starters) to get HWA not to bluescreen?

No Idea how, or what HWA is, mind filling me in?

''Phoxuponyou [[#answer-836432|said]]'' <blockquote> I have the same setup in my laptop, R5 with Windows 8.1. No bluescreens though, and no dual monitor (I use a 24" monitor for work, but always disable the laptop display when I do). If you can't get decent FPS without hardware acceleration, then the CPU is probably too low power for the rendering options used in Firefox. Chrome getting all the way to 60 sounds like HWA is on. Did you try tweaking Firefox settings (in the link for starters) to get HWA not to bluescreen? </blockquote> No Idea how, or what HWA is, mind filling me in?

Question owner

Also, my computer is an AMD quad-core A8 with 2.00GHz

Also, my computer is an AMD quad-core A8 with 2.00GHz
Phoxuponyou 51 solutions 517 answers

Sure; HWA is just shorthand for hardware acceleration. As luck would have it, mine is also a 2 GHz A8 (A8-6410) and it is an utter slug, never mind the core count. It's about as budget as decent budget processors get.

Sure; HWA is just shorthand for ''hardware acceleration''. As luck would have it, mine is also a 2 GHz A8 (A8-6410) and it is an utter slug, never mind the core count. It's about as budget as decent budget processors get.

Question owner

Phoxuponyou said

Sure; HWA is just shorthand for hardware acceleration. As luck would have it, mine is also a 2 GHz A8 (A8-6410) and it is an utter slug, never mind the core count. It's about as budget as decent budget processors get.

well, enabling hardware acceleration in firefox causes my whole computer to crash, so I don't want to test that right now, but I used to be able to get 30fps no problem, but not anymore for some reason, especiall in fullscreen, the frame rate drops down to about 10 or less

''Phoxuponyou [[#answer-836435|said]]'' <blockquote> Sure; HWA is just shorthand for ''hardware acceleration''. As luck would have it, mine is also a 2 GHz A8 (A8-6410) and it is an utter slug, never mind the core count. It's about as budget as decent budget processors get. </blockquote> well, enabling hardware acceleration in firefox causes my whole computer to crash, so I don't want to test that right now, but I used to be able to get 30fps no problem, but not anymore for some reason, especiall in fullscreen, the frame rate drops down to about 10 or less

Modified by Madog24

Question owner

I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help.

The one in chrome is the one with in mime type video/webm

I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm

Question owner

Just a Note I switched to Flash player on Firefox, after updating it to the latest version, it still can't do 60fps on any videos, but I at least get a stable frame rate, but I would like to solve my issue still, because flash is made up into squares, and they are very easy to see, and very annoying, plus, they sometimes get cut unevenly so parts of the video will not line up properly

Just a Note I switched to Flash player on Firefox, after updating it to the latest version, it still can't do 60fps on any videos, but I at least get a stable frame rate, but I would like to solve my issue still, because flash is made up into squares, and they are very easy to see, and very annoying, plus, they sometimes get cut unevenly so parts of the video will not line up properly
Phoxuponyou 51 solutions 517 answers

Madog24 said

I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm

The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you?

To do this, go to about:config and toggle media.webm.enabled. I tested this on my Firefox and it switched rendering from WebM to MP4.

''Madog24 [[#answer-836532|said]]'' <blockquote> I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm </blockquote> The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you? To do this, go to '''about:config''' and toggle ''media.webm.enabled''. I tested this on my Firefox and it switched rendering from WebM to MP4.

Question owner

Phoxuponyou said

Madog24 said
I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm

The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you?

To do this, go to about:config and toggle media.webm.enabled. I tested this on my Firefox and it switched rendering from WebM to MP4.

Actually, it's the other way around, chrome is the one with more bold text, and it's using WebM

''Phoxuponyou [[#answer-836650|said]]'' <blockquote> ''Madog24 [[#answer-836532|said]]'' <blockquote> I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm </blockquote> The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you? To do this, go to '''about:config''' and toggle ''media.webm.enabled''. I tested this on my Firefox and it switched rendering from WebM to MP4. </blockquote> Actually, it's the other way around, chrome is the one with more bold text, and it's using WebM

Modified by Madog24

Phoxuponyou 51 solutions 517 answers

Madog24 said

Phoxuponyou said
Madog24 said
I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm

The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you?

To do this, go to about:config and toggle media.webm.enabled. I tested this on my Firefox and it switched rendering from WebM to MP4.

Actually, it's the other way around, chrome is the one with more bold text, and it's using WebM

OH... I assumed it was Firefox because of all the Dropped Frames and larger frame count (since we're troubleshooting FF). Those are frames your system is too slow to render so they drop out of the pipeline, never to be seen. 1-2% drop is not horrible, but for all intents and purposes it should be 0%.

You can try the toggle with MP4 in that case, the value to toggle is media.fragmented-mp4.enabled.

PS. There are apparently quite a few MP4 settings, so trying until you get it is the way to go.

PPS. I was curious and looked up the video (The Boston Wanderer LP of FO4). It is definitely clunky with MP4, but while WebM drops frames just as horribly, the viewing experience is much smoother!

''Madog24 [[#answer-836728|said]]'' <blockquote> ''Phoxuponyou [[#answer-836650|said]]'' <blockquote> ''Madog24 [[#answer-836532|said]]'' <blockquote> I pulled up the "stats for nerds" in htm5 on the same video, on the same quality (720p60fps) on both Firefox and Chrome, I don't know what it all means, but maybe it can help. The one in chrome is the one with in mime type video/webm </blockquote> The thing that immediately strikes me is that FF is using WebM and Chrome is using MP4. Can you try disabling WebM in Firefox to see if MP4 is more effective for you? To do this, go to '''about:config''' and toggle ''media.webm.enabled''. I tested this on my Firefox and it switched rendering from WebM to MP4. </blockquote> Actually, it's the other way around, chrome is the one with more bold text, and it's using WebM </blockquote> OH... I assumed it was Firefox because of all the ''Dropped Frames'' and larger frame count (since we're troubleshooting FF). Those are frames your system is too slow to render so they drop out of the pipeline, never to be seen. 1-2% drop is not horrible, but for all intents and purposes it should be 0%. You can try the toggle with MP4 in that case, the value to toggle is '''media.fragmented-mp4.enabled'''. PS. There are apparently quite a few MP4 settings, so trying until you get it is the way to go. PPS. I was curious and looked up the video (The Boston Wanderer LP of FO4). It is definitely clunky with MP4, but while WebM drops frames just as horribly, the viewing experience is much smoother!

Modified by Phoxuponyou

Question owner

toggling media.fragmented-mp4.enabled to false causes HTML5 to start with an error (picture) and then it immediately switches to flash.

toggling media.fragmented-mp4.enabled to false causes HTML5 to start with an error (picture) and then it immediately switches to flash.
Phoxuponyou 51 solutions 517 answers

Disable what you don't want, Flash included (unless you for some reason like Flash).

Disable what you don't want, Flash included (unless you for some reason like Flash).