Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blue screen of death WITHOUT Flash Player!

  • 4 replies
  • 4 have this problem
  • 987 views
  • Last reply by jscher2000

more options

Whenever I try to watch video on YouTube I get Blue Screen Of Death. Sometimes after 1 min, and sometimes after 10 min. I don't have installed Adobe Flash Player since it is not required to watch videos on YouTube. I have de-checked "Enable hardware acceleration and I still get BSOD. I'm running Windows 8.1 with all updates, and also I always update Firefox whenever there is a new update. I have tried to install Flash Player and tried all solutions I found on internet but non of them worked so I uninstalled Flash Player. On Google Chrome everything works normal but I don't want to switch to it whenever I want to watch some video in fear of getting BSOD. Please if anyone has a solution or idea it would be much helpful. Thanks in advance!

Chosen solution

Hmm, since you already disabled the main hardware acceleration, it could be a problem with video decoding (or audio). For video decoding, could you try these settings changes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false

(4) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

(5) Double-click the media.mediasource.webm.enabled preference to switch it from false to true

(6) Double-click the media.windows-media-foundation.enabled preference to switch it from true to false

The effect of that all that should be to block MP4/h.264 decoding and switch YouTube to the latest WebM (VP9) format. You could check the result on this page, although that might not all show until after you exit Firefox and start it up again:

https://www.youtube.com/html5 (both h.264 should be red)

This isn't so practical for other video sites, but I'm curious whether it helps on YouTube or has the same issues.

Read this answer in context 👍 2

All Replies (4)

more options

Ouch. A BSOD nearly always indicates a compatibility problem between Firefox and a device driver, such as the software for your graphics card or audio device. Does the blue screen indicate anything specific that might point toward a particular culprit?

For graphical issues, try disabling Firefox from using hardware acceleration:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves video decoding and the appearance of fonts and animations, you may want to check to see whether any graphics card/chipset driver updates are available for your system. This article suggest safe ways to check: Upgrade your graphics drivers to use hardware acceleration and WebGL.

more options

Chosen Solution

Hmm, since you already disabled the main hardware acceleration, it could be a problem with video decoding (or audio). For video decoding, could you try these settings changes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false

(4) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

(5) Double-click the media.mediasource.webm.enabled preference to switch it from false to true

(6) Double-click the media.windows-media-foundation.enabled preference to switch it from true to false

The effect of that all that should be to block MP4/h.264 decoding and switch YouTube to the latest WebM (VP9) format. You could check the result on this page, although that might not all show until after you exit Firefox and start it up again:

https://www.youtube.com/html5 (both h.264 should be red)

This isn't so practical for other video sites, but I'm curious whether it helps on YouTube or has the same issues.

more options

@jscher2000 Your second answer solved my problem. BSOD is gone. I also enabled Hardware Acceleration after I tried without it (works with or without it). Only now videos on YouTube are freezing for a few seconds approximatly every 10 seconds when I play them in 1080p (in fullscreen or not) whethet or not is enabled Hardware Acceleration. On 720p and below videos play perfectly. Any idea what may cause this? Thanks again :)

more options

Every 10 seconds is disappointing! I suspect the reason media.mediasource.webm.enabled is defaulted to false is that there are still bugs in it. Once it is fully working and set to true (in a future version, presumably), I think it will be the best way to use YouTube. But I guess we're stuck for the moment if your system crashes decoding MP4.

There must be a way to repair or at least diagnose the issues with the Media Foundation components. Will your system allow reinstalling them using this download: Download Media Feature Pack for N and KN versions of Windows 8.1 from Official Microsoft Download Center?