X
Tap here to go to the mobile version of the site.

Support Forum

Firefox using too much CPU (40-50%)

Posted

Hello all! For the past few weeks, Firefox seems to be a large CPU hog. It uses around 30-50% of the CPU for seemingly no reason. I have ADBlock off (As you can see) There are only two tabs open (I am running Opera as well) I've cleared the cache, I've refreshed the download of Firefox as well. Could someone give me any other suggestions?

By the way, my laptop is a Dell XPS 12 (2014) with an Intel Core i5 4200U and 4GB of RAM Thanks!

Hello all! For the past few weeks, Firefox seems to be a large CPU hog. It uses around 30-50% of the CPU for seemingly no reason. I have ADBlock off (As you can see) There are only two tabs open (I am running Opera as well) I've cleared the cache, I've refreshed the download of Firefox as well. Could someone give me any other suggestions? By the way, my laptop is a Dell XPS 12 (2014) with an Intel Core i5 4200U and 4GB of RAM Thanks!
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • GEPlugin
  • Version 5.41.2.0
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Plugin for Wacom tablets.
  • iTunes Detector Plug-in

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Grammarly Spell Checker & Grammar Checker 1.415.464 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)
  • Skype Click to Call 7.5.0.9082 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 05e31028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-17-2015
  • driverDate2:
  • driverVersion: 10.18.15.4256
  • driverVersion2:
  • failures: [u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(266,21675) Code: 0x80070057 format 0', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(266,21675) Code: 0x80070057 format 0', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(266,21675) Code: 0x80070057 format 0']
  • indices: [0, 1, 2]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers
Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? --------------- '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding'''

Question owner

Unfortunately, yes it's still there. This was in safe mode.

Unfortunately, yes it's still there. This was in safe mode.
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers

Did you check out the above links?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Did you check out the above links? Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

That seems to have kinda fixed it. (Still using 20% cpu on youtube)

That seems to have kinda fixed it. (Still using 20% cpu on youtube)
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers

As a test, disable your protection programs.

As a test, disable your protection programs.
#367259 3 solutions 37 answers

TheGhzGuy said

That seems to have kinda fixed it. (Still using 20% cpu on youtube)

This usage looks quite roughly reasonable when comparing to your CPU. On my Celeron D 2,8Ghz (single thread/core) im going 100% for 1-3 seconds on normal webpages, youtube is frozing & 100% cpu even on medium video quality).

''TheGhzGuy [[#answer-809003|said]]'' <blockquote> That seems to have kinda fixed it. (Still using 20% cpu on youtube) </blockquote> This usage looks quite roughly reasonable when comparing to your CPU. On my Celeron D 2,8Ghz (single thread/core) im going 100% for 1-3 seconds on normal webpages, youtube is frozing & 100% cpu even on medium video quality).