X
Tap here to go to the mobile version of the site.

Support Forum

Why have some YouTube interface pieces become invisible?

Posted

I've encountered a strange glitch with YouTube specifically, only in Firefox. Namely, numerous pieces of the interface - the icons on buttons (like the Like/Dislike buttons) and things, menu buttons, the logo in the upper left - are simply invisible. It's most noticeable along the top. I've attached a screenshot. You can see the logo is absent, there's no button for the upper left dropdown (even when I'm logged in), and there's even no magnifying glass in the search bar button. These are only missing in Firefox. Strangest of all, these DO appear when I access the site via a proxy. I've tried mucking with my hosts file and flushing my DNS, as well as running Firefox in safe mode and resetting it, to no avail. It's possible I'm overlooking something, but I haven't yet noticed similar problems on any other sites.

I've encountered a strange glitch with YouTube specifically, only in Firefox. Namely, numerous pieces of the interface - the icons on buttons (like the Like/Dislike buttons) and things, menu buttons, the logo in the upper left - are simply invisible. It's most noticeable along the top. I've attached a screenshot. You can see the logo is absent, there's no button for the upper left dropdown (even when I'm logged in), and there's even no magnifying glass in the search bar button. These are only missing in Firefox. Strangest of all, these DO appear when I access the site via a proxy. I've tried mucking with my hosts file and flushing my DNS, as well as running Firefox in safe mode and resetting it, to no avail. It's possible I'm overlooking something, but I haven't yet noticed similar problems on any other sites.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.65.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • Unity Player 5.2.0f3

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Copy Plain Text 2 1.4 (copyplaintext@teo.pl)
  • Element Hiding Helper for Adblock Plus 1.3.4 (elemhidehelper@adblockplus.org)
  • F.B. Purity - Cleans Up Facebook 9.3.2.1-signed (fbp@fbpurity.com)
  • fallenlondonitemequiper 3 ({e1652031-cdaf-4aae-8f8f-5ab34efc25bf})
  • Fasterfox 3.9.85.1-signed ({c36177c0-224a-11da-8cd6-0800200c9a91})
  • Feed Sidebar 8.0.4.1-signed (feedbar@efinke.com)
  • Firebug 2.0.13 (firebug@software.joehewitt.com)
  • Greasemonkey 3.5 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Lazarus: Form Recovery 2.3.1-signed (lazarus@interclue.com)
  • MEGA EXTENSION 1.0.3.1-signed (firefox@mega.co.nz)
  • RightToClick 2.9.5.1-signed ({cd617375-6743-4ee8-bac4-fbf10f35729e})
  • Skype Click to Call 7.5.0.9082 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • YouTube mp3 1.0.9.1-signed (info@youtube-mp3.org)
  • User Agent Switcher 0.7.3.1-signed ({e968fc70-8f95-4ab9-9e79-304de2a71ee1}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 770
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x1184
  • adapterDeviceID2: 0x0412
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterRAM: 2048
  • adapterRAM2: Unknown
  • adapterSubsysID: 37723842
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x10de
  • adapterVendorID2: 0x8086
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 11-2-2015
  • driverDate2: 7-17-2015
  • driverVersion: 10.18.13.5887
  • driverVersion2: 10.18.15.4256
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 770 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4192 solutions 58521 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! ------------ Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

FredMcD said

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Sorry! I thought I had uploaded a screenshot, but it didn't work. Let me try again.

''FredMcD [[#answer-803526|said]]'' <blockquote> Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] </blockquote> Sorry! I thought I had uploaded a screenshot, but it didn't work. Let me try again.
jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

YouTube uses image "sprites" for various of its buttons. For example, when I inspect the page, it is using this one (I'm logged out, in case that makes any difference):

https://s.ytimg.com/yts/imgbin/www-hitchhiker-2x-vflzIV6yE.png

If you follow that link, do you get a block of little icons?

YouTube uses image "sprites" for various of its buttons. For example, when I inspect the page, it is using this one (I'm logged out, in case that makes any difference): https://s.ytimg.com/yts/imgbin/www-hitchhiker-2x-vflzIV6yE.png If you follow that link, do you get a block of little icons?
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156790 answers

Are you running Firefox in Private Browsing mode?

Firefox 42+ has a new Tracking Protection feature that is enabled by default in Private Browsing mode. You can see a shield icon at the left end of the location/address bar when you are in private browsing mode that some content is blocked. You can disable this feature in "Options/Preferences > Privacy".

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Are you running Firefox in Private Browsing mode? Firefox 42+ has a new Tracking Protection feature that is enabled by default in Private Browsing mode. You can see a shield icon at the left end of the location/address bar when you are in private browsing mode that some content is blocked. You can disable this feature in "Options/Preferences > Privacy". *Options/Preferences > Privacy: "Use Tracking Protection in Private Windows" *https://support.mozilla.org/kb/tracking-protection-firefox *https://support.mozilla.org/kb/control-center-site-privacy-and-security-firefox ----- If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

jscher2000 said

YouTube uses image "sprites" for various of its buttons. For example, when I inspect the page, it is using this one (I'm logged out, in case that makes any difference): https://s.ytimg.com/yts/imgbin/www-hitchhiker-2x-vflzIV6yE.png If you follow that link, do you get a block of little icons?

Thank you! Yes, I do see a single .png showing many little various icons.

''jscher2000 [[#answer-803548|said]]'' <blockquote> YouTube uses image "sprites" for various of its buttons. For example, when I inspect the page, it is using this one (I'm logged out, in case that makes any difference): https://s.ytimg.com/yts/imgbin/www-hitchhiker-2x-vflzIV6yE.png If you follow that link, do you get a block of little icons? </blockquote> Thank you! Yes, I do see a single .png showing many little various icons.
jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

Hi Levicus, that's good, so that server is not blocked completely.

But why aren't the images showing on the page? They are displayed as background images, which is different from how the red icons on the left are displayed; those are inline images. One reason that background images might not show is if Firefox is overriding the colors selected by the website. It would be strange if this only happens on one site, but you can check that setting here just in case:

"3-bar" menu button (or Tools menu) > Options > Content

Click the "Colors" button, then check the selector below "Override the colors specified by the page with my selections above." Try "Never" and see whether that makes any difference. (Example screen shot attached)

Hi Levicus, that's good, so that server is not blocked completely. But why aren't the images showing on the page? They are displayed as background images, which is different from how the red icons on the left are displayed; those are inline images. One reason that background images might not show is if Firefox is overriding the colors selected by the website. It would be strange if this only happens on one site, but you can check that setting here just in case: "3-bar" menu button (or Tools menu) > Options > Content Click the "Colors" button, then check the selector below "Override the colors specified by the page with my selections above." Try "Never" and see whether that makes any difference. (Example screen shot attached)

Question owner

That is a good idea! However, it doesn't seem to have done the trick. The fact that accessing the site via a proxy allows the images to load makes me think that somehow their addresses are being blocked. I tried disabling my firewall, but that didn't help. I would almost wonder if my ISP is somehow causing it, but other browsers don't have the same problem.

That is a good idea! However, it doesn't seem to have done the trick. The fact that accessing the site via a proxy allows the images to load makes me think that somehow their addresses are being blocked. I tried disabling my firewall, but that didn't help. I would almost wonder if my ISP is somehow causing it, but other browsers don't have the same problem.
jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

It's really hard to think of an explanation for why you can view the image "stand alone" in a tab but not as a background image, if Firefox is following the site's color scheme. Did you try the Firefox "Safe Mode" test?

It's really hard to think of an explanation for why you can view the image "stand alone" in a tab but not as a background image, if Firefox is following the site's color scheme. Did you try the Firefox "Safe Mode" test?

Question owner

That is a good question. Yes, I thought it was a conflict with some extension or addon at first, so I did test it in safe mode. I also tried resetting the browser fully. Neither seemed to rectify the problem, unfortunately! It's odd enough I almost suspected some strange, very specific malware problem, but scans have not revealed anything amiss.

That is a good question. Yes, I thought it was a conflict with some extension or addon at first, so I did test it in safe mode. I also tried resetting the browser fully. Neither seemed to rectify the problem, unfortunately! It's odd enough I almost suspected some strange, very specific malware problem, but scans have not revealed anything amiss.
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156790 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156790 answers

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.