Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I enable javascript on my Mac OSX for Firefox 41.0.2?

  • 5 replies
  • 33 have this problem
  • 8673 views
  • Last reply by jscher2000

more options

When I pull down the menu under tools, there is no choice called OPTIONS. I want to enable javascript, but am not sure how.

Chosen solution

By the way Options is the term used on Windows. On Mac, it's called Preferences and you can find it on the application menu ("3-bar" menu button) or the Firefox menu on the classic menu bar.

Also, I suspect you might have a filtering extension (e.g., ad blocker, tracking blocker, script blocker) that is causing this issue, but please work through the suggestions in cor-el's reply in case it's one of the simpler things.

Read this answer in context 👍 1

All Replies (5)

more options

hi, javascript is enabled by default in firefox and there is no user-facing option to change that. what problem are you trying to address in particular? could you also go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

more options

My bank's website isn't working with firefox after their new design. I've been getting a message that tells me to enable javascript, and the site is no longer fully functional for me as it was before. I'm updated with firefox 41.0.2, but it seems to make no difference.

more options

Here's a screenshot of the website and the message I'm getting.

more options

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Chosen Solution

By the way Options is the term used on Windows. On Mac, it's called Preferences and you can find it on the application menu ("3-bar" menu button) or the Firefox menu on the classic menu bar.

Also, I suspect you might have a filtering extension (e.g., ad blocker, tracking blocker, script blocker) that is causing this issue, but please work through the suggestions in cor-el's reply in case it's one of the simpler things.