Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

add IDM to verified add-on list

  • 1 reply
  • 57 have this problem
  • 12297 views
  • Last reply by jscher2000

more options

Older versions of Mozilla Firefox allowed for Internet Download Manager add-on and I used it frequently, but with the latest update I can no longer use it. When will this be remedied?

Thanks!

Chosen solution

Hi ragempa, Mozilla has announced a procedure for the publishers of extensions to submit them and get them signed by the Add-ons team. Probably IDM will do that eventually. But it shouldn't be mandatory yet...

In the final release of Firefox 40 and 41, the signing requirement is not enforced, there is only a warning. If yours says that the extension is blocked because it is not signed, please check the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpi and pause while the list is filtered

(3) If the xpinstall.signatures.required preference is bolded and "user set" to true, double-click it to switch it to false


If that is already set to false, then there must be some other problem with the add-on that is causing it not to work. Could you check for updates to IDM?

Read this answer in context 👍 35

All Replies (1)

more options

Chosen Solution

Hi ragempa, Mozilla has announced a procedure for the publishers of extensions to submit them and get them signed by the Add-ons team. Probably IDM will do that eventually. But it shouldn't be mandatory yet...

In the final release of Firefox 40 and 41, the signing requirement is not enforced, there is only a warning. If yours says that the extension is blocked because it is not signed, please check the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpi and pause while the list is filtered

(3) If the xpinstall.signatures.required preference is bolded and "user set" to true, double-click it to switch it to false


If that is already set to false, then there must be some other problem with the add-on that is causing it not to work. Could you check for updates to IDM?