X
Tap here to go to the mobile version of the site.

Support Forum

How do I enable a Blocked addon or Plugin to display website and content the same as in IE

Posted

I have to use a Java Plugin to run a java applet used for my work. Google Chrome has recently stopped the support of this plugin, I have customers that cannot work in Internet Explorer and would like to offer them an alternative.

I can only do this if all functionality of my site works in Firefox. Presently there are some display issues experienced in Chrome and Firefox with the site. Only IE displays it correctly.

I have to use a Java Plugin to run a java applet used for my work. Google Chrome has recently stopped the support of this plugin, I have customers that cannot work in Internet Explorer and would like to offer them an alternative. I can only do this if all functionality of my site works in Firefox. Presently there are some display issues experienced in Chrome and Firefox with the site. Only IE displays it correctly.

Chosen solution

Does that website need the Java Deployment Toolkit plugin? Or just the main Java plugin?

If the former, the best you can do is to advise your users to use "Ask to Activate" for that plugin. Oracle has never fixed the reported security faults with that Deployment plugin for a couple of years now; Firefox won't allow it to activate automatically even when the user has the latest, up-to-date version of Java installed.

Here's a couple of support articles that might help you, somewhat. https://support.mozilla.org/en-US/kb/how-allow-java-trusted-sites https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins


Java is basically dead for all practical purposes other than for Oracle applications. And Oracle better be working on their own web browser for all platforms or Oracle business applications will appear on the tombstone with Java. I'm curious what their joint epitaph will be.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-GB/

Extensions

  • Trend Micro Osprey Firefox Extension 2.0.0.1077 ({BBB77B49-9FF4-4d5c-8FE2-92B1D6CD696C})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Quadro FX 880M
  • adapterDescription2:
  • adapterDeviceID: 0x0a3c
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 040c1028
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 5-22-2010
  • driverDate2:
  • driverVersion: 8.17.12.5729
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA Quadro FX 880M Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40088 answers

Chosen Solution

Does that website need the Java Deployment Toolkit plugin? Or just the main Java plugin?

If the former, the best you can do is to advise your users to use "Ask to Activate" for that plugin. Oracle has never fixed the reported security faults with that Deployment plugin for a couple of years now; Firefox won't allow it to activate automatically even when the user has the latest, up-to-date version of Java installed.

Here's a couple of support articles that might help you, somewhat. https://support.mozilla.org/en-US/kb/how-allow-java-trusted-sites https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins


Java is basically dead for all practical purposes other than for Oracle applications. And Oracle better be working on their own web browser for all platforms or Oracle business applications will appear on the tombstone with Java. I'm curious what their joint epitaph will be.

Does that website need the Java Deployment Toolkit plugin? Or just the main Java plugin? If the former, the best you can do is to advise your users to use '''"Ask to Activate"''' for that plugin. Oracle has never fixed the reported security faults with that Deployment plugin for a couple of years now; Firefox won't allow it to activate automatically even when the user has the latest, up-to-date version of Java installed. Here's a couple of support articles that might help you, somewhat. https://support.mozilla.org/en-US/kb/how-allow-java-trusted-sites https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins ---------------- Java is basically dead for all practical purposes other than for Oracle applications. And Oracle better be working on their own web browser for all platforms or Oracle business applications will appear on the tombstone with Java. I'm curious what their joint epitaph will be.
James
  • Moderator
1594 solutions 11232 answers

https://addons.mozilla.org/en-US/firefox/blocked/

Java Plugin 8 update 45 and older are on blocklist as All versions of the Java plugin up to 45 are vulnerable to a publicly disclosed vulnerability: http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html

The current version is Java Plugin 8 update 60 (as of August 18, 2015) at https://java.com/en/download/manual.jsp

https://addons.mozilla.org/en-US/firefox/blocked/ Java Plugin 8 update '''45''' and older are on blocklist as All versions of the Java plugin up to '''45''' are vulnerable to a publicly disclosed vulnerability: http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html The current version is Java Plugin 8 update '''60''' (as of August 18, 2015) at https://java.com/en/download/manual.jsp

Modified by James

Question owner

Hi Guys, thanks very much. I used the Allow for the plugin on my trusted site. I updated Java to 8.0.60 it's on Ask to Activate but working.

Now one more issue... See attached image. Displaying my website in IE vs. Firefox. There are discrepancies that I can't quite figure out what could be the cause. Please let me know if you need any more info from me to be able to assist.

Hi Guys, thanks very much. I used the Allow for the plugin on my trusted site. I updated Java to 8.0.60 it's on Ask to Activate but working. Now one more issue... See attached image. Displaying my website in IE vs. Firefox. There are discrepancies that I can't quite figure out what could be the cause. Please let me know if you need any more info from me to be able to assist.
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157425 answers

Are you referring to the font size or some other difference (broken colored bar)?

Can you elaborate?

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Are you referring to the font size or some other difference (broken colored bar)? Can you elaborate? You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Modified by cor-el

Question owner

Hi Wow the Zoom is the issue, yes it's the broken color bar but.... I can only see all the colors when zooming out to 60% which makes everything illegible.

Is there any other way? See attached pic.

Hi Wow the Zoom is the issue, yes it's the broken color bar but.... I can only see all the colors when zooming out to 60% which makes everything illegible. Is there any other way? See attached pic.