Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes even when I disable all add ons and plug ins

  • 5 replies
  • 3 have this problem
  • 298 views
  • Last reply by FredMcD

more options

Hey Community,

I love firefox and that's why I want to get it work again. since few days my firefox crashes and I don't know why. Sometimes it crashes when I type something in the search tool bar and sometimes when i scrall on a page, sometimes when i want to type an URL. I disabled all add ons and plugins. but the error appeared again. I also tried to fix it by installing the 64 bit version but it does not help. Here is the last crash report:

a9d8cd89-0156-4e90-939a-f2f912150831

https://crash-stats.mozilla.com/report/index/a9d8cd89-0156-4e90-939a-f2f912150831

Please, can someone help me?

Thank you!

Attached screenshots

Chosen solution

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Read this answer in context 👍 1

All Replies (5)

more options

Product Firefox Version 41.0b5

Release Channel beta OS Windows NT OS Version 6.1.7601 Service Pack 1

The crash report flagged these programs;

Kernel32.dll = Microsoft

ntdll.dll = Microsoft

dwmapi.dll = Microsoft

KERNELBASE.dll = Microsoft

igdumd64.dll = NVIDIA D3D shim drivers = NVIDIA Corporation

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder


Perform a System File Check to fix corrupted system files Win 7, 8, Vista: https://support.microsoft.com/en-us/kb/929833

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

thank you, FredMcD! But that doesn't solve the problem. Graphic Driver is up-to-date and i have no corrupt files... But I noticed that when I run firefox in "Safe Mode" the error does not occur. Why? When I disable all Add-Ons by hand the error still occurs... Plug-Ins seem to be active in "Safe Mode", so that should not be the problem. Is there any other solution. I want my Firefox back! :-)

more options

Chosen Solution

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

more options

Hey FredMcD, the turned off Hardware Acceleration seems to have solved the problem! I still wonder why it occurs, because I use this Computer and Firefox since many years and had no problems with it. Anyway, thank you!

more options

Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.