X
Tap here to go to the mobile version of the site.

Support Forum

Can't log into MSN account (Bing) from Firefox (Win10)

Posted

I have Windows 10 and the latest version of Firefox. I clear my history and cookies weekly and this time afterward I cannot log into my Microsoft Account on Bing as my homepage. It gives me a bad certificate error message. My computer will also not go into sleep mode now. Related or coincidence?

I have Windows 10 and the latest version of Firefox. I clear my history and cookies weekly and this time afterward I cannot log into my Microsoft Account on Bing as my homepage. It gives me a bad certificate error message. My computer will also not go into sleep mode now. Related or coincidence?

Chosen solution

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin
  • NPWLPG

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/WINNT/en-US/

Extensions

  • Avast Online Security 10.2.0.187 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7560D
  • adapterDescription2:
  • adapterDeviceID: 0x9904
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 2ae0103c
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-15-2015
  • driverDate2:
  • driverVersion: 15.200.1062.1002
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7560D Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4272 solutions 59923 answers

Perform a System File Check to fix corrupted system files Win 7, 8, Vista: https://support.microsoft.com/en-us/kb/929833

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Perform a System File Check to fix corrupted system files Win 7, 8, Vista: https://support.microsoft.com/en-us/kb/929833 See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

This did not fix it. This is what I get when trying to log in.

An error occurred during a connection to www.bing.com. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
This did not fix it. This is what I get when trying to log in. An error occurred during a connection to www.bing.com. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
FredMcD
  • Top 10 Contributor
4272 solutions 59923 answers
http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Chosen Solution

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis. To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.