Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox fail to load the bookmarks toolbar on startup? I have to restart it several times to get it to work

  • 8 replies
  • 4 have this problem
  • 583 views
  • Last reply by Banban

more options

When I start Firefox, over half the time the bookmarks toolbar does not load. Even right-clicking on the toolbar gives no joy as the bookmarks toolbar option is not available when it does not load by itself. There is blue space there under the menu bar, but it is blank. I have to close Firefox and restart it, sometimes two or three times, to get the bookmarks toolbar to load or show with the browser. I run fully updated Windows 7 Home Premium, and use Avast antivirus. I have tried disabling the Avast, and all the add-ons, but it makes no difference. Closing the browser and restarting it with the computer still running, or closing the browser and restarting the browser after restarting the computer makes no difference. I have run a complete antivirus and several antimalware scans and ran CCleaner in case it was junk causing it. Makes no difference. The only way to fix it is to close and restart Firefox until it decides to load/show the bookmarks toolbar. That works, but it sure is annoying.

Chosen solution

Try this:

  1. Tape about:config in the address bar then enter
  2. Accept the warning
  3. Search browser.uiCustomization.state
  4. Right-click on the value, something like {"placements":{"PanelUI-contents…
  5. Click on Reset
  6. Close and open again Firefox and check if your problem is solved
Read this answer in context 👍 2

All Replies (8)

more options

Chosen Solution

Try this:

  1. Tape about:config in the address bar then enter
  2. Accept the warning
  3. Search browser.uiCustomization.state
  4. Right-click on the value, something like {"placements":{"PanelUI-contents…
  5. Click on Reset
  6. Close and open again Firefox and check if your problem is solved
more options
more options

Note that browser.uiCustomization.state stores the toolbar customization, so you need to redo the toolbar customization when you reset the pref.

If you use Restore Defaults in the Customize palette then you at least have an Undo button.

Do you otherwise have problems with the bookmarks?

more options

Other than failing to load or show the bookmarks, it works fine when they are shown. It doesn't lose bookmarks or anything. I tried the fixes both you and banban suggested. Time will tell as it is a random problem.

It leaves space under the menu bar for the bookmarks folder icons/text but it simply didn't show them. It was a blank blue (in my skin scheme) bar with nothing in it. Restarting Firefox usually solved it, but sometimes it took two or three restarts to make it show. Once they appeared the bookmarks worked just fine.

I dunno. I am 65 and getting too old to keep up with technology, I guess. My first computer (other than a slide rule - yeah, I'm old) was a TI-99 with a cassette tape drive. Then the Commodore Vic-20, then the Commodore 64. Now my cheapie, semi-smart phone has about a gazillion times the computing power, memory, video processing, etc of the old TI-99.

more options

I was not born during Commodore's time, but it is still very famous!

Now let's get back to your problem. As I understand it, help we provided don't solve the problem. The randomness is strange… Did you try to restart Firefox with Add-ons disabled? To do it, click on the menu button on the top right, click on the ? in a circle below then Restart with Add-ons Disabled.

more options

Try to open a new window and close the current window in case there is a problem with the current window.

See also:

more options

Banban said

I was not born during Commodore's time, but it is still very famous! Now let's get back to your problem. As I understand it, help we provided don't solve the problem. The randomness is strange… Did you try to restart Firefox with Add-ons disabled? To do it, click on the menu button on the top right, click on the ? in a circle below then Restart with Add-ons Disabled.

No, I said it appears to be fixed SO FAR. I had already tried with all add-ons and such disabled and even with my antivirus disabled. None of that seemed to work. The suggestions you and Cor-el made APPEAR to be working as I have loaded it three times and it has not failed so far. As I said, time will tell.

Yeah, the randomness got to me, too. There was no way I could reproduce the problem at will. I tried disabling everything, even using safe mode when it was acting up. It happens when it happens. I could go a week or more with no problem then it would do it two days in a row, off and on.

So far, the fixes you suggest have worked and I thank you both. I have opened it and closed it several times with no problem. If it comes back I'll post it again.

more options

Ok, thanks for you detailed answer.

We will be happy to help you if you need it!