Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo.politics and other yahoo sites won't display comment box

  • 9 replies
  • 5 have this problem
  • 925 views
  • Last reply by onkobo

more options

I got the latest Firefox 39 version. I disabled all add-ons, rebooted Windows 7, but problem persists. With google chrome everything works fine. Help on how to troubleshoot and solve this would be much appreciated. Example:

https://www.yahoo.com/politics/jeb-bush-consultant-critiques-republican-digital-124448872556.html

Modified by onkobo

Chosen solution

All right!

Deleted ALL cookies (I do it every night together with cache, but only for the last day or four hours, depending). I also had to play around with Ghost (allow facebook, twitter, yahoo analytics) and  Disconnect (disable on yahoo.com) extensions.  That seems to have done the trick. 

As for SSL, occasionally I get the warnings you mentioned. They don't make sense, because the sites are pretty trusted (banks and the like). I retry a couple of times on google chrome too and everything is OK.

I really appreciate your help on this matter and your admirable patience.

Read this answer in context 👍 1

All Replies (9)

more options

In this case, Yahoo seems to be inserting the comments directly into the page instead of using a frame showing comments from a different site (like Disqus or Facebook). How far does the feature get, for example, does Yahoo populate the comment count on the button? If you click the button, does the form open but no actual comments show? Etc.

(Screen shot attached for comparison)

more options

What I get is the strip of click-on icons (Disqus, etc) at the bottom of the page, but without the button and comment count circled in the attached screen shot. Disabling all add-ons will not help. (I also disabled the DNS Prefetching, but it did not change anything.) I appreciate your help!

more options

You get a Disqus button? That would be completely different than the page I get. I think Yahoo uses Disqus in some of its departments, but I didn't see it here.

I can't figure out what initially populates that comment button. The scripts on the page are very complicated. Sorry.

more options

I get the same strip of icons you got on the screen shot you attached to your previous reply (https://support.cdn.mozilla.net/media/uploads/images/2015-07-19-13-16-31-3afbcd.png), MINUS the two buttons next to them you circled in that attachment. Time to flush Firefox down the bowl. Thanks again.

more options

Do you allow cookies, third party cookies, and local DOM storage? If any of those are blocked, try unblocking them.

Cookies: Websites say cookies are blocked - Unblock them

Local storage:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste stora and pause while the list is filtered

(3) If the dom.storage.enabled is bolded and "user set" to false, double-click it to restore the default value of true

more options

Actually, I can still get comment on that page even with cookies disabled and local storage disabled.

I think based on your original question that you already tried Firefox's Safe Mode, but just in case:

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

I did restart several times with ALL add-ons disabled and restarted Windows 7 too. dom.storage is set correctly.

As you will notice from the screenshot I took, only five icons are displayed. The sixth (the "Copy" link) is missing.

http://i.share.pho.to/14e66a02_o.png

more options

Thank you for the screen shot. Yours has a different format from what I see. For example, when I view the page, the tweets are boxed (see attached screen shot) and the Read More button looks different. Yours is not the mobile format; I'm not sure what's going on with it.

Did you ever try this:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on yahoo.com, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Any difference?


On a different note, have you encountered any issues with Firefox objecting to website SSL certificates?

more options

Chosen Solution

All right!

Deleted ALL cookies (I do it every night together with cache, but only for the last day or four hours, depending). I also had to play around with Ghost (allow facebook, twitter, yahoo analytics) and  Disconnect (disable on yahoo.com) extensions.  That seems to have done the trick. 

As for SSL, occasionally I get the warnings you mentioned. They don't make sense, because the sites are pretty trusted (banks and the like). I retry a couple of times on google chrome too and everything is OK.

I really appreciate your help on this matter and your admirable patience.