X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

how do i stop yahoo hijacking my searches

Posted

I have deleted yahoo from my search options and it no longer shows up under choices but still is the default. How do i remove keyword.url

I have deleted yahoo from my search options and it no longer shows up under choices but still is the default. How do i remove keyword.url

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • CANON iMAGE GATEWAY Mycamera Plugin
  • NPWLPG
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

Diego Victor 658 solutions 4175 answers

Hello,

  1. Go to your profile folder
  2. Exit Firefox
  3. Look for a file called user.js if it exist delete or rename it.
  4. Also open the pref.js file, look for the entry:
    user_pref("keyword.url","xxx")
  5. Erase this line and save it
  6. Restart Firefox
Hello, # Go to your [[Profiles - Where Firefox stores your bookmarks, passwords and other user data|profile folder]] # Exit Firefox # Look for a file called '''user.js''' if it exist delete or rename it. # Also open the '''pref.js''' file, look for the entry: <blockquote>user_pref("keyword.url","xxx")</blockquote> # Erase this line and save it # Restart Firefox
bohl3r 1 solutions 9 answers

I've provided 2 different sets of instructions, I recommend you try each of them, if one doesn't work try the other.

First Set of Instructions You can choose from different search providers such as Google, Yahoo or Bing when you search the Internet using Firefox. For more information, see the article Search the Web on Firefox.

If you want to change the default search engine that Firefox uses,

In Firefox 33 or below:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

If you also want to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.

Starting in Firefox 34:
Note: The following may not apply to localized versions of Firefox.

Use one of these methods to change the default search engine:

  • Click the menu button New Fx Menu and choose Options on Windows or Preferences on Mac or Linux, then select the Search settings panel.
  • Click on the magnifying glass icon in the Search bar, then click on Change Search Settings, as shown here:
search prefs 34

In the Search settings panel that opens, select a different search engine from the drop-down menu (see this screenshot).




Other set of Instructions It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. Click the menu button New Fx Menu and choose Add-ons.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the Remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

After Firefox restarts, install the Search Reset Tool. This will remove the rest of the traces of this program from your Firefox.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Did this fix the problem? Please let us know!

I've provided 2 different sets of instructions, I recommend you try each of them, if one doesn't work try the other. <b><i>First Set of Instructions</i></b> You can choose from different search providers such as Google, Yahoo or Bing when you search the Internet using Firefox. For more information, see the article [[Search bar - add, change and manage search engines on Firefox]]. If you want to change the default search engine that Firefox uses, '''In Firefox 33 or below:''' #Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo. #If you would like to select another search engine, simply pick the engine from the dropdown list. If you also want to change the order of the search engines, do this: #From the dropdown list, select ''Manage Search Engines...''. #In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select ''Move up'' or ''Move down'' from the buttons on the right side in order to change the order of the search engines. '''Starting in Firefox 34:'''<br> ''Note: The following may not apply to localized versions of Firefox.''<br> Use one of these methods to change the default search engine: * Click the menu button [[Image:New Fx Menu]] and choose '''Options''' on Windows or '''Preferences''' on Mac or Linux, then select the '''Search''' settings panel. * Click on the magnifying glass icon in the Search bar, then click on Change Search Settings, as shown here: :[[Image:search prefs 34]] In the Search settings panel that opens, select a different search engine from the drop-down menu (see [/en-US/gallery/image/20002 this screenshot]). <b><i>Other set of Instructions</i></b> It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily: # Click the menu button [[Image:New Fx Menu]] and choose Add-ons. # In the Add-ons Manager tab, select the Extensions panel. # Select the toolbar you wish to remove. # Click the Remove button. # Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart. After Firefox restarts, install the [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Search Reset Tool]. This will remove the rest of the traces of this program from your Firefox. For further information, please read [[Remove a toolbar that has taken over your Firefox search or home page]]. Did this fix the problem? Please let us know!

Question owner

Thank you. I appreciate the suggestions. Yahoo continues to persevere.

The profile folder didn't have a user.js file and the pref.js didn't open; I got an error - Invalid Character code 800A03F6. There was also a prefs.js.lpbak that also wouldn't open.

I'm on Firefox 35.0.1. I have been able to remove the check from yahoo and to remove yahoo altogether but it still takes over. It does let me direct it to use a different engine but only on an individual search basis.

The extension panel didn't have a yahoo entry.

Thank you. I appreciate the suggestions. Yahoo continues to persevere. The profile folder didn't have a user.js file and the pref.js didn't open; I got an error - Invalid Character code 800A03F6. There was also a prefs.js.lpbak that also wouldn't open. I'm on Firefox 35.0.1. I have been able to remove the check from yahoo and to remove yahoo altogether but it still takes over. It does let me direct it to use a different engine but only on an individual search basis. The extension panel didn't have a yahoo entry.
Diego Victor 658 solutions 4175 answers

Chosen Solution

Try [[Using Multiple Profiles|create a new profile]].

Question owner

thank you

thank you
Bcav 0 solutions 2 answers

goffen98attownisp.com said

I have deleted yahoo from my search options and it no longer shows up under choices but still is the default. How do i remove keyword.url

I had this problem also and found a very easy solution. Go to "tools"/"options"/"search" - at the bottom of the text, click on "Add more search engines" which will take you to another page with several options - click on "Google default" - that solved it for me.

''goffen98attownisp.com [[#question-1046949|said]]'' <blockquote> I have deleted yahoo from my search options and it no longer shows up under choices but still is the default. How do i remove keyword.url </blockquote> I had this problem also and found a very easy solution. Go to "tools"/"options"/"search" - at the bottom of the text, click on "Add more search engines" which will take you to another page with several options - click on "Google default" - that solved it for me.