Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not checking my plug-ins to show they are updated

  • 4 replies
  • 24 have this problem
  • 2276 views
  • Last reply by John99

more options

After I updated the Java Adobe Flash yesterday, the function for checking plug-ins for updates was okay. This morning, it just sits there and spins without doing anything.

Have never had this problem in the past.

Chosen solution

Please try and check directly using Adobe's site if you have problems with https://www.mozilla.org/plugincheck/ { It is working ok for me right now.)

There are or have been known issues with Mozilla servers recentlyhttps://support.mozilla.org/en-US/for.../711040?last=63882#post-63882. I guess highly publicised issues requiring FlashPlayers updates have increased loads.

Check your Flashplayer is up to date by visiting http://www.adobe.com/software/flash/about/ separately with each browser.

Read this answer in context 👍 3

All Replies (4)

more options

Chosen Solution

Please try and check directly using Adobe's site if you have problems with https://www.mozilla.org/plugincheck/ { It is working ok for me right now.)

There are or have been known issues with Mozilla servers recentlyhttps://support.mozilla.org/en-US/for.../711040?last=63882#post-63882. I guess highly publicised issues requiring FlashPlayers updates have increased loads.

Check your Flashplayer is up to date by visiting http://www.adobe.com/software/flash/about/ separately with each browser.

more options

john99, I did not need to use the suggestions you provided, however they are certainly valid, because this morning the plug-in checking option is functional without any problems at all.

Therefore it must have been a "known issue" you referenced above with Mozilla Servers. All of the other recommendations are excellent, and I appreciate you taking the time to respond and provide those links!!

                                :>)
more options

I also updated my adobe flashplayer however I'm still getting this message that the old one is still there and needs updating. How & Where do I find the program on my computer to verify it's updated ?


Outdated Plugins Plugin Status Action

Adobe Flash PlayerRealNetworks(tm) RealDownloader

PepperFlashVideoShim Plug-In vulnerable

1.3.3.66

Update Now


These plugins are up to date Plugin Status Action

Adobe Flash PlayerShockwave Flash 16.0 r0 Up to Date

16.0.0.305

https://www.mozilla.org/en-US/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update

https://support.mozilla.org/en-US/products/firefox/download-and-install

https://support.mozilla.org/en-US/questions/1044011#question-reply

more options

Hi metro.

Would you mind starting your own question thread please. When you do so please try and follow the prompts to provide full information.

If you visit the Mozilla or the Adobe test site with Firefox you would not be expected to get

PepperFlashVideoShim Plug-In	vulnerable

Please use the link

Sorry for the inconvenience, but it should make it easier to help you.