X
Tap here to go to the mobile version of the site.

Support Forum

How do I get HTML5 videos working again?

Posted

I updated to Firefox 35 recently and now HTML5 videos will not work. I do have NoScript, but disabling or removing it does not fix the problem. Switching to safe mode does not fix the problem. The problem is solved by using a fresh profile or deleting the prefs.js file, but this is not an option for me, as restoring all my settings from scratch would be a time-consuming hassle I'd rather not deal with.

I know the problem is with the update to Firefox 35 specifically because everything was working fine before and stopped working after. To be absolutely certain, I turned on my laptop that had the same exact extensions and settings imported to it from this computer with FEBE a while back. It was using version 34.0.5 and everything was fine with that version. I tested it with the Vine website, all videos worked. It also downloaded the update to Firefox 35 in the background and as soon as I restarted it, the HTML5 videos were broken.

It's definitely something Mozilla changed but forgot to alter/remove an old setting that's gumming up the works. If I could just figure out which line(s) in the prefs.js file was causing the issue, I would delete/modify it myself in Notepad.

For the record, I already had media.windows-media-foundation.enabled set to false. All videos that use Flash seem to work. I think Vimeo uses HTML5, but it's the only non-Flash video site I could find that still works. Flash and Java have been updated to the latest versions.

I updated to Firefox 35 recently and now HTML5 videos will not work. I do have NoScript, but disabling or removing it does not fix the problem. Switching to safe mode does not fix the problem. The problem is solved by using a fresh profile or deleting the prefs.js file, but this is not an option for me, as restoring all my settings from scratch would be a time-consuming hassle I'd rather not deal with. I know the problem is with the update to Firefox 35 specifically because everything was working fine before and stopped working after. To be absolutely certain, I turned on my laptop that had the same exact extensions and settings imported to it from this computer with FEBE a while back. It was using version 34.0.5 and everything was fine with that version. I tested it with the Vine website, all videos worked. It also downloaded the update to Firefox 35 in the background and as soon as I restarted it, the HTML5 videos were broken. It's definitely something Mozilla changed but forgot to alter/remove an old setting that's gumming up the works. If I could just figure out which line(s) in the prefs.js file was causing the issue, I would delete/modify it myself in Notepad. For the record, I already had media.windows-media-foundation.enabled set to false. All videos that use Flash seem to work. I think Vimeo uses HTML5, but it's the only non-Flash video site I could find that still works. Flash and Java have been updated to the latest versions.

Chosen solution

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

As I said, safe mode does not solve the problem. It's not any of my extensions. I tried turning off hardware acceleration earlier but that wasn't it either.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

It only has these two lines: user_pref("protocol-handler.warn-external.dnUpdate", false); user_pref("browser.sessionstore.resume_from_crash", false);

Pretty sure they're extension-related, so I won't touch them.

Are there any media prefs that do not have the default value?
  • media.*.enabled

As I said, media.windows-media-foundation.enabled was set to false and it was the only entry with that search term that was not set to default. I changed it to true and restarted and this fixed everything. Funny thing, though, doing the opposite has been a proven solution for people having this issue in the past. This very website says to do that. You said to do that! https://support.mozilla.org/en-US/questions/961627

So, anybody reading this for future reference, you may or may not have changed this setting sometime in 2013. Firefox 35 requires you to change it back. Problem solved.

Read this answer in context 33

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • ACE Stream Plug-in Version 2.2.5.1-next, Copyright (c) 2012-2014 Innovative Digital Technologies
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • FireFox PDF Architect Previewer
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • MetaStream 3 Plugin r4
  • PDF Architect 2
  • ScorchPlugin
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • SumatraPDF Browser Plugin

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • Add Bookmark Here ² 31.0.20150113 (abhere2@moztw.org)
  • Add-on Compatibility Reporter 2.0.5 (compatibility@addons.mozilla.org)
  • Amazon Price Tracker - Keepa.com 1.45 (amptra@keepa.com)
  • ChatZilla 0.9.91.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Download Status Bar 12.3.0 ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • Echofon 2.5.2 (twitternotifier@naan.net)
  • Enhanced Steam 7.2.2 (jid0-SmvlvxGpvCyG252KbVMqIKR79Uc@jetpack)
  • FEBE 8.2 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • FlashGot 1.5.6.8 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Linkification 1.3.9 ({35106bca-6c78-48c7-ac28-56df30b51d2a})
  • Nightly Tester Tools 3.7 ({8620c15f-30dc-4dba-a131-7c5d20cf4a29})
  • NoScript 2.6.9.10 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Organize Status Bar 0.6.4 ({35106bca-6c78-48c7-ac28-56df30b51d2c})
  • PDF Architect 2 Creator 1.0 (pdf_architect_2_conv@pdfarchitect.org)
  • PDF Architect Converter For Firefox 1.0 (FFPDFArchitectConverter@pdfarchitect.com)
  • Personal Menu 6.2.0 (CompactMenuCE@Merci.chao)
  • Screengrab (fix version) 0.98.05c ({02450914-cdd9-410f-b1da-db004e18c671})
  • Session Manager 0.8.1.6 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Simple Timer + Clocks 1.4.1 (simpletimerClocks@grbradt.org)
  • Status-4-Evar 2014.07.06.05 (status4evar@caligonstudios.com)
  • Tab Mix Plus 0.4.1.6 ({dc572301-7619-498c-a57d-39143191b318})
  • Test Pilot 1.2.3 (testpilot@labs.mozilla.com)
  • Textarea Cache 0.9.3.2 ({578e7caa-210f-4967-a0d3-88fe5b59a39f})
  • udtool 0.7.3 ({e167d208-935f-4ac0-bfbb-339143481691})
  • UDToolbar 0.59.2 ({7BC5A936-2E6F-4d8a-BAB5-77C555E0AD71})
  • udwidget 0.0.4.69 (udwidget@gmail.com)
  • Metal Lion Australis Scrollbars II 2.0.1.5 ({FDBAD97E-A258-4fe3-9CF6-60CF386C4422}) (Inactive)
  • Metal Lion Customise Palette 1.0.4 (customizepalette@srazzano.com) (Inactive)
  • TS Magic Player 1.1.40 (magicplayer@torrentstream.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 770
  • adapterDescription2:
  • adapterDeviceID: 0x1184
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterSubsysID: 37793842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-12-2013
  • driverDate2:
  • driverVersion: 9.18.13.2723
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 770 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4193 solutions 58537 answers

What are you using as a viewer? Check for updates.


YouTube HTML5 Test

What are you using as a viewer? Check for updates. '''[https://www.youtube.com/html5 YouTube HTML5 Test]'''

Question owner

FredMcD, not sure I understand the question. Sites that use HTML5 videos use their own unique player, such as Tumblr, Vine or Instagram and none of these sites work for me right now. I clicked on your link and I got red box exclamation points for Media Source Extensions, MSE & H.264 and MSE & WebM VP9 but blue box checkmarks for HTMLVideoElement, H.264 and WebM VP8.

As I said, Java and Flash are updated, don't know what else I could update. I also said that a fresh profile works, so there's something in prefs.js that I need to remove or change that's affecting the new way Firefox handles HTML5 video.

FredMcD, not sure I understand the question. Sites that use HTML5 videos use their own unique player, such as Tumblr, Vine or Instagram and none of these sites work for me right now. I clicked on your link and I got red box exclamation points for Media Source Extensions, MSE & H.264 and MSE & WebM VP9 but blue box checkmarks for HTMLVideoElement, H.264 and WebM VP8. As I said, Java and Flash are updated, don't know what else I could update. I also said that a fresh profile works, so there's something in prefs.js that I need to remove or change that's affecting the new way Firefox handles HTML5 video.
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

Are there any media prefs that do not have the default value?

  • media.*.enabled

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

Are there any media prefs that do not have the default value? *media.*.enabled Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. *http://kb.mozillazine.org/Preferences_not_saved

Chosen Solution

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

As I said, safe mode does not solve the problem. It's not any of my extensions. I tried turning off hardware acceleration earlier but that wasn't it either.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

It only has these two lines: user_pref("protocol-handler.warn-external.dnUpdate", false); user_pref("browser.sessionstore.resume_from_crash", false);

Pretty sure they're extension-related, so I won't touch them.

Are there any media prefs that do not have the default value?
  • media.*.enabled

As I said, media.windows-media-foundation.enabled was set to false and it was the only entry with that search term that was not set to default. I changed it to true and restarted and this fixed everything. Funny thing, though, doing the opposite has been a proven solution for people having this issue in the past. This very website says to do that. You said to do that! https://support.mozilla.org/en-US/questions/961627

So, anybody reading this for future reference, you may or may not have changed this setting sometime in 2013. Firefox 35 requires you to change it back. Problem solved.

''cor-el [[#answer-677980|said]]'' <blockquote>Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. </blockquote> As I said, safe mode does not solve the problem. It's not any of my extensions. I tried turning off hardware acceleration earlier but that wasn't it either. <blockquote>Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.</blockquote> It only has these two lines: user_pref("protocol-handler.warn-external.dnUpdate", false); user_pref("browser.sessionstore.resume_from_crash", false); Pretty sure they're extension-related, so I won't touch them. <blockquote> Are there any media prefs that do not have the default value? *media.*.enabled </blockquote> As I said, media.windows-media-foundation.enabled was set to false and it was the only entry with that search term that was not set to default. I changed it to true and restarted and <u>this fixed everything</u>. Funny thing, though, doing the opposite has been a proven solution for people having this issue in the past. This very website says to do that. <b>You</b> said to do that! https://support.mozilla.org/en-US/questions/961627 So, anybody reading this for future reference, you may or may not have changed this setting sometime in 2013. Firefox 35 requires you to change it back. Problem solved.

Modified by TigerNightmare

cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

Looks that the user.js had been created by malware as there is not need to disable restoring tabs in case of crashes. The other user_pref line would also suggest this.

  • user_pref("protocol-handler.warn-external.dnUpdate", false); *user_pref("browser.sessionstore.resume_from_crash", false);

You can delete the user.js file and reset the two mentioned prefs of the about:config page.

The media.windows-media-foundation.enabled pref relates to the built-in HTML5 media player with regard to supporting H.264 and some other formats and disables the HTML5 media player for those formats. I'm not sure what happens if media.directshow.enabled is still set to true.

Do you remember if you toggled this pref yourself because you would only do that in case of issues with playing media files via the HTML5 media player?

Looks that the user.js had been created by malware as there is not need to disable restoring tabs in case of crashes. The other user_pref line would also suggest this. *user_pref("protocol-handler.warn-external.dnUpdate", false); *user_pref("browser.sessionstore.resume_from_crash", false); You can delete the user.js file and reset the two mentioned prefs of the <b>about:config</b> page. The media.windows-media-foundation.enabled pref relates to the built-in HTML5 media player with regard to supporting H.264 and some other formats and disables the HTML5 media player for those formats. I'm not sure what happens if media.directshow.enabled is still set to true. Do you remember if you toggled this pref yourself because you would only do that in case of issues with playing media files via the HTML5 media player?

Question owner

I really doubt it's malware. I have an extension called Session Manager that can save, restore and automatically backup multiple browsing sessions and I haven't had any issues. It's probably an old, leftover file since it was last modified in 2009.

media.windows-media-foundation.enabled is set to true by default, according to what it says in the about:config window. That's why HTML5 videos worked on a blank profile but not in safe mode. I don't remember if I've had this problem before and set it to false myself, but it's plausible.

I really doubt it's malware. I have an extension called Session Manager that can save, restore and automatically backup multiple browsing sessions and I haven't had any issues. It's probably an old, leftover file since it was last modified in 2009. media.windows-media-foundation.enabled is set to true by default, according to what it says in the about:config window. That's why HTML5 videos worked on a blank profile but not in safe mode. I don't remember if I've had this problem before and set it to false myself, but it's plausible.
Kyriosity 0 solutions 1 answers

Same issue. Safe mode doesn't resolve it. Disabling extensions doesn't resolve it. All media prefs are set to default. Is there anything else I can check?

Same issue. Safe mode doesn't resolve it. Disabling extensions doesn't resolve it. All media prefs are set to default. Is there anything else I can check?
Birdieguy 0 solutions 7 answers

cor-el said

Are there any media prefs that do not have the default value?
  • media.*.enabled
Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

TigerNightmare said

cor-el said
Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

As I said, safe mode does not solve the problem. It's not any of my extensions. I tried turning off hardware acceleration earlier but that wasn't it either.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

It only has these two lines: user_pref("protocol-handler.warn-external.dnUpdate", false); user_pref("browser.sessionstore.resume_from_crash", false);

Pretty sure they're extension-related, so I won't touch them.

Are there any media prefs that do not have the default value?
  • media.*.enabled

As I said, media.windows-media-foundation.enabled was set to false and it was the only entry with that search term that was not set to default. I changed it to true and restarted and this fixed everything. Funny thing, though, doing the opposite has been a proven solution for people having this issue in the past. This very website says to do that. You said to do that! https://support.mozilla.org/en-US/questions/961627

So, anybody reading this for future reference, you may or may not have changed this setting sometime in 2013. Firefox 35 requires you to change it back. Problem solved.

Thank you, TigerNightmare for pointing this out! The support here has failed in addressing this issue ever since I first tried to seek help about it.

I, too, simply changed the default value of "media.windows-media-foundation.enabled" back to TRUE, which is the opposite of what I, too, was told to do in prior support sessions.

Happy to see that someone has finally proven that the people at Mozilla Support really don't have their sht together.

Thanks again TigerNightmare!

''cor-el [[#answer-677980|said]]'' <blockquote> Are there any media prefs that do not have the default value? *media.*.enabled Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. *http://kb.mozillazine.org/Preferences_not_saved </blockquote> ''TigerNightmare [[#answer-678011|said]]'' <blockquote> ''cor-el [[#answer-677980|said]]'' <blockquote>Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. </blockquote> As I said, safe mode does not solve the problem. It's not any of my extensions. I tried turning off hardware acceleration earlier but that wasn't it either. <blockquote>Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.</blockquote> It only has these two lines: user_pref("protocol-handler.warn-external.dnUpdate", false); user_pref("browser.sessionstore.resume_from_crash", false); Pretty sure they're extension-related, so I won't touch them. <blockquote> Are there any media prefs that do not have the default value? *media.*.enabled </blockquote> As I said, media.windows-media-foundation.enabled was set to false and it was the only entry with that search term that was not set to default. I changed it to true and restarted and <u>this fixed everything</u>. Funny thing, though, doing the opposite has been a proven solution for people having this issue in the past. This very website says to do that. <b>You</b> said to do that! https://support.mozilla.org/en-US/questions/961627 So, anybody reading this for future reference, you may or may not have changed this setting sometime in 2013. Firefox 35 requires you to change it back. Problem solved. </blockquote> Thank you, TigerNightmare for pointing this out! The support here has failed in addressing this issue ever since I first tried to seek help about it. I, too, simply changed the default value of "media.windows-media-foundation.enabled" back to <b>TRUE</b>, which is the opposite of what I, too, was told to do in prior support sessions. Happy to see that someone has finally proven that the people at Mozilla Support really don't have their sht together. Thanks again TigerNightmare!
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

That advice was given in 2013 and during that time support for HTML5 in Firefox and on website was still in early stages, so no everything was working smoothly. Disabling features is a lot of times only needed temporarily and you need to check regularly if it works in a next release.

That advice was given in 2013 and during that time support for HTML5 in Firefox and on website was still in early stages, so no everything was working smoothly. Disabling features is a lot of times only needed temporarily and you need to check regularly if it works in a next release.