X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do you get html5 to work with Firefox?

Posted

I have disabled and removed adobe flash player. I go to youtube, enable the html5 trial version, and try to view videos and it won't work. If I enable flash, the videos work fine. I can get html5 to work in Chrome, but it will not work in Firefox. Why?

Chosen solution

Because every video works in Chrome with html5.

Chrome includes an integrated Flash player. So in order to test whether you are playing natively or using Flash, you would need to disable that. Adobe Flash Player plug-in - Google Chrome Help.

Chrome might natively play more videos, because for a long time, Firefox has not played H.264-encoded videos due to patent issues. I think there has been some movement on that, at least in the mobile space, but I haven't looked into it recently.

But back to Firefox. Did you try these typical Flash fixes?

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Win Vista & Win 7 & maybe Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

More Information

niklos 0 solutions 2 answers

Hello, The plug-in html5 trial only works with youtube Webm format for firefox and opera. Download & Install & Use the plug-in official for firefox, convert youtube videos in html5 and display them in a window with all the commands. The link is https://addons.mozilla.org/en-US/firefox/addon/save-my-youtube-day/?src=api

The images below explain how I did it to see the video in youtube with html5

Did this fix your problems? Report back to us! Thank you.

Modified by niklos

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8905 answers

in firefox 20 and above you can also enable h.264 playback when your operating sysytem supports it & provides the codecs.

enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.enabled. double-click it and change its value to true.

Question owner

Alright, so after doing the both above, some videos worked and some didn't. I assume all videos should work though?

Not sure why some would work and some wouldn't. I just went to the homepage of youtube and some would play and others would say that adobe flash player was required.

Niklos: All I did was install the plugin. It seemed like there were more instructions after that, which you said were described in the pictures, but I didn't see anything like that. So I'm not sure what else you wanted after installing the plugin.

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

On the HTML5 trial page, there are some additional restrictions at the bottom which might explain some of the non-playing videos:

  • Some videos with ads are not yet supported (they will play in the Flash player)
  • On Firefox and Opera, only videos with WebM transcodes will play in HTML5
  • If you've opted in to other testtube experiments, you may not get the HTML5 player (Feather is supported, though)
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

By the way, a lot of sites -- especially restaurants for some reason -- won't work without Flash. Why did you disable/remove it?

Helpful Reply

It is starting to sound like Google is being a dick and gearing their service to be fully functional with their browser and not others, unless it is the fault of Firefox. Because every video works in Chrome with html5.

Flash is being annoying. Frequently, it will freeze Firefox, and then I will get an error message saying that the flash player stopped working. I almost always get this freeze on startup of the browser (if I forgot to disable Flash) and then I get other times while using Firefox as well. I only get this problem when flash is enabled, therefore it is flash. You can argue that it is only my computer, which maybe it is, but I cannot find a solution, nor have I been able to solve it, except by disabling flash.

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Chosen Solution

Because every video works in Chrome with html5.

Chrome includes an integrated Flash player. So in order to test whether you are playing natively or using Flash, you would need to disable that. Adobe Flash Player plug-in - Google Chrome Help.

Chrome might natively play more videos, because for a long time, Firefox has not played H.264-encoded videos due to patent issues. I think there has been some movement on that, at least in the mobile space, but I haven't looked into it recently.

But back to Firefox. Did you try these typical Flash fixes?

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Win Vista & Win 7 & maybe Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Question owner

You are correct about the Chrome thing. I went into the settings and only saw one or two extensions, so I assumed that those are all extensions/plugins. I am unfamiliar with Chrome; kind of dumb that the plugins aren't present in the settings, another reason not to switch.

After disabling flash in chrome, roughly the same videos that don't play in FF don't play in chrome either.

I did all of the above and still get the flash player stopped working. - I disabled hardware acceleration in both FF and in the Flash settings - I also disabled Protected Mode

Still getting the same problems. So it still seems like it is a flash problem and not my computer.

Also, what's the advantages of having protected mode enabled?

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Protected mode spins up numerous separate instances of the Flash player so that bad Flash content is more isolated and has less opportunity to attack your system. Unfortunately, it seems that this feature causes problems on some systems.

Rather than disabling Flash entirely, have you tried any of the add-ons that block Flash on a page until you approve it, for example, Flashblock (you might want to allow HTML5 video automatically in its settings rather than having both treated the same)? Perhaps that would at least limit the issue to pages where you wanted to use Flash.

Question owner

Seems like a smart plugin. I allowed all html5. When I went to one of the adobe flash player articles you provided, I didn't receive the error as I was before.

It's good that this plugin provides a whitelist, because otherwise I would definitely not use it, as it would be too intrusive for a site such as youtube. I'll just have to build up a whitelist over time.

Looks like this is my best bet for now. Thanks for the help. Hopefully, this problem gets solved soon.

Thanks again.