X
Tap here to go to the mobile version of the site.

Support Forum

script error composing email in outlook

Posted

Hello,

I get a script error ("warning unresponsive script") when composing an email in Outlook and only when running in Firefox. I am on the current release (34.0). This problem did not happen right away after going to the current release but much later. Problem was sporadic at first but is now persistent. Trying the stop or continue options do not work. Firefox is stuck in an endless loop. None of the other tabs will work. I have to use TaskMaster to shut down Firefox.

The problem happens only when I'm formatting bullets (numbered, ordered, etc) within the text of the email. The first bullet will compose OK. When I hit enter to compose a second bullet, I will consistently get the unresponsive script error.

The specific script is copied over below.

    Script: https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16

I ran the debug program and have attached a screen print of the results.

I presented this problem to the Microsoft Community after searching the site for help. They gave me the standard reply to reset Firefox to the default values and to contact Firefox.

Your help will be appreciated. Thanks.

Hello, I get a script error ("warning unresponsive script") when composing an email in Outlook and only when running in Firefox. I am on the current release (34.0). This problem did not happen right away after going to the current release but much later. Problem was sporadic at first but is now persistent. Trying the stop or continue options do not work. Firefox is stuck in an endless loop. None of the other tabs will work. I have to use TaskMaster to shut down Firefox. The problem happens only when I'm formatting bullets (numbered, ordered, etc) within the text of the email. The first bullet will compose OK. When I hit enter to compose a second bullet, I will consistently get the unresponsive script error. The specific script is copied over below. Script: https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16 I ran the debug program and have attached a screen print of the results. I presented this problem to the Microsoft Community after searching the site for help. They gave me the standard reply to reset Firefox to the default values and to contact Firefox. Your help will be appreciated. Thanks.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nitro PDF plugin for Firefox and Chrome
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

FredMcD
  • Top 10 Contributor
4188 solutions 58450 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Fred, As noted in my original problem, I already did the standard stuff which had no effect.

My Firefox options are already set to clear cookies at sign-off. To humor you, I clear cache again and again it had no effect.

Did you look at the debug results?

Fred, As noted in my original problem, I already did the standard stuff which had no effect. My Firefox options are already set to clear cookies at sign-off. To humor you, I clear cache again and again it had no effect. Did you look at the debug results?
FredMcD
  • Top 10 Contributor
4188 solutions 58450 answers

Did you try the second part of my post (Safe Mode) ?

I do not know how to read those yet.

Did you try the second part of my post (Safe Mode) ? I do not know how to read those yet.

Question owner

Fred,

Running in Safe Mode made no difference. Problem still happens.

While I appreciate your efforts to try to help me, I really wanted someone to take a look at the debug results and figure out what the cause of the problem is. Can you pass this onto someone else in the forum who can do so?

Thanks and Happy Holidays.

Fred, Running in Safe Mode made no difference. Problem still happens. While I appreciate your efforts to try to help me, I really wanted someone to take a look at the debug results and figure out what the cause of the problem is. Can you pass this onto someone else in the forum who can do so? Thanks and Happy Holidays.
FredMcD
  • Top 10 Contributor
4188 solutions 58450 answers

I've called the big guys to help you. Good luck.

One last thing. Go to that web page. Then, holding down the <Shift> key, reload the page.

I've called the big guys to help you. Good luck. One last thing. Go to that web page. Then, holding down the '''<Shift>''' key, reload the page.
guigs 1072 solutions 11697 answers

It looks like its a script from a version of sizzlejs, which is based off of jQuery version 1.7, however the dom script loading limit is 10 seconds. If you extend this time, does the unresponsive script warning continue to pop up.

However, the best bet is to forget the site from the cache and try a new login. This will reload the script and start from scratch. I have confirmed with another user that this is not happening for them.

Try this:

  1. Go to about:permissions
  2. Search for the microsoft compose url
  3. When selected click the "Forget this site"
  4. Then go to the Firefox Menu and click on Options
  5. Under Privacy and history, select "Use custom settings"
  6. Then click on "Show cookies"
  7. search for microsoft cookies and delete them.

Restart Firefox and navigate to the email to login and try a fresh compose.

It looks like its a script from a version of sizzlejs, which is based off of jQuery version 1.7, however the dom script loading limit is 10 seconds. If you extend this time, does the unresponsive script warning continue to pop up. However, the best bet is to forget the site from the cache and try a new login. This will reload the script and start from scratch. I have confirmed with another user that this is not happening for them. Try this: # Go to about:permissions #Search for the microsoft compose url # When selected click the "Forget this site" #Then go to the Firefox Menu and click on Options # Under Privacy and history, select "Use custom settings" # Then click on "Show cookies" #search for microsoft cookies and delete them. Restart Firefox and navigate to the email to login and try a fresh compose.

Question owner

Hi G2,

Am already using custom setting within Firefox privacy and have it set up to delete all cookies when I exit/close. Nevertheless, I checked and no cookies were saved.

Did the about:permissions steps from above but did not find anything in the list resembling a Microsoft compose URL. As a double-check, did several searches but got no results.

Did the script loading time limit change between Firefox versions? I did not have this problem before. I found a laptop that's running an older Firefox 33.1 version. I tried the recreate the problem on it but could not.

Thanks for your efforts. Happy Holidays ...

Hi G2, Am already using custom setting within Firefox privacy and have it set up to delete all cookies when I exit/close. Nevertheless, I checked and no cookies were saved. Did the about:permissions steps from above but did not find anything in the list resembling a Microsoft compose URL. As a double-check, did several searches but got no results. Did the script loading time limit change between Firefox versions? I did not have this problem before. I found a laptop that's running an older Firefox 33.1 version. I tried the recreate the problem on it but could not. Thanks for your efforts. Happy Holidays ...
guigs 1072 solutions 11697 answers

Happy Holidays as well! Did the script loading time limit change between Firefox versions? I did not have this problem before...

I do not believe so. I asked another outlook user to try this and there was no issue composing an email.

However I am also not sure how debugging their javascript will help except that the error in their script might be something they are experts in if that is the path for solving this. Though normally if this is not happening on other computers/accounts and it still happens in Safe mode, we know its not an add on or hardware acceleration.

Does this happen in a new profile? Profile Manager - Create, remove, or switch Firefox profiles

Happy Holidays as well! ''Did the script loading time limit change between Firefox versions? I did not have this problem before...'' I do not believe so. I asked another outlook user to try this and there was no issue composing an email. However I am also not sure how debugging their javascript will help except that the error in their script might be something they are experts in if that is the path for solving this. Though normally if this is not happening on other computers/accounts and it still happens in Safe mode, we know its not an add on or hardware acceleration. Does this happen in a new profile? [[Use the Profile Manager to create and remove Firefox profiles]]

Question owner

G2 -

This problem happens regardless of the hardware that I'm using (desktop PC, laptop, notebook, etc), regardless of the profile, and only when I'm running Hotmail/Outlook in Firefox.

The problem does not happen when I'm composing an email in Microsoft IE.

As noted in my original post, I've already presented this problem to the Microsoft Community for help thinking that it was an Hotmail/Outlook problem. But based on their analysis and feedback, it's a Firefox problem.

What's next??

G2 - This problem happens regardless of the hardware that I'm using (desktop PC, laptop, notebook, etc), regardless of the profile, and only when I'm running Hotmail/Outlook in Firefox. The problem does not happen when I'm composing an email in Microsoft IE. As noted in my original post, I've already presented this problem to the Microsoft Community for help thinking that it was an Hotmail/Outlook problem. But based on their analysis and feedback, it's a Firefox problem. What's next??

Question owner

G2 -

I forgot to mention that a secondary and probably unrelated problem is font control. When running Hotmail/Outlook in Firefox and composing an email, the font will change as I'm typing. Sometimes between paragraphs and sometimes within the line. It will change to the default font (Calibri) in spite of the fact that I've selected Arial both in Firefox and in Hotmail/Outlook.

Within Firefox Content/Font options, I've tried both options allowing and not allowing pages to choose their own fonts with no effect.

Any thoughts on this?

This is an annoying problem but I've put up with it.

G2 - I forgot to mention that a secondary and probably unrelated problem is font control. When running Hotmail/Outlook in Firefox and composing an email, the font will change as I'm typing. Sometimes between paragraphs and sometimes within the line. It will change to the default font (Calibri) in spite of the fact that I've selected Arial both in Firefox and in Hotmail/Outlook. Within Firefox Content/Font options, I've tried both options allowing and not allowing pages to choose their own fonts with no effect. Any thoughts on this? This is an annoying problem but I've put up with it.
guigs 1072 solutions 11697 answers

Helpful Reply

The default font did not cause a script error. So far, we have tried Safe Mode, clearing the cache and on a new account on a different computer.

I am slightly stumped why I cannot reproduce this. Adding a bullet point and a few more in version 35 is smooth as glass in outlook.com.

Wait! I changed the font to Arial and there was an unresponsive script warning, bingo!

Error: POST https://bay180.mail.live.com/Handlers/ScenarioQos.mvc [HTTP/1.1 200 OK 282ms] no element found ScenarioQos.mvc:1 Error in parsing value for 'font-size'. Declaration dropped. RteFrameResources.aspx POST https://bn1msgr2010706.gateway.messenger.live.com/gateway/gateway.dll [HTTP/1.1 200 OK 62040ms] Error: Script terminated by timeout at: i.event.fix@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:38274 i.event.dispatch@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:36087 i.event.add/s@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:32963

I do not have an ETA for this issue, however I have submitted the bug here:

Note: before posting on a bug please see the following: Bugzilla Etiquette

The default font did not cause a script error. So far, we have tried Safe Mode, clearing the cache and on a new account on a different computer. I am slightly stumped why I cannot reproduce this. Adding a bullet point and a few more in version 35 is smooth as glass in outlook.com. Wait! I changed the font to Arial and there was an unresponsive script warning, bingo! Error: POST https://bay180.mail.live.com/Handlers/ScenarioQos.mvc [HTTP/1.1 200 OK 282ms] no element found ScenarioQos.mvc:1 Error in parsing value for 'font-size'. Declaration dropped. RteFrameResources.aspx POST https://bn1msgr2010706.gateway.messenger.live.com/gateway/gateway.dll [HTTP/1.1 200 OK 62040ms] Error: Script terminated by timeout at: i.event.fix@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:38274 i.event.dispatch@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:36087 i.event.add/s@https://a.gfx.ms/jquery_IxInqeqWhsTYFrwY33VHww2.js:16:32963 I do not have an ETA for this issue, however I have submitted the bug here: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1117220] Note: before posting on a bug please see the following: [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette]

Question owner

Hi G2 -

Belated thanks for your persistence in working this bug and for submitting your results.

It appears that, once this bug has been triggered, it remains persistent. I have not been able to get away from it, unless I use IE instead of Firefox. As I'd first noted, this error does not happen in IE.

Thanks again.

Hi G2 - Belated thanks for your persistence in working this bug and for submitting your results. It appears that, once this bug has been triggered, it remains persistent. I have not been able to get away from it, unless I use IE instead of Firefox. As I'd first noted, this error does not happen in IE. Thanks again.
vaswolter 0 solutions 7 answers

I'm a non-techsavvy person - I'm attaching a screenshot of what I'm talking of. This thing pops up everytime i go to my outlook account to check my mails. What's this? Please help. Thanks in advance V.R.-Wolter

I'm a non-techsavvy person - I'm attaching a screenshot of what I'm talking of. This thing pops up everytime i go to my outlook account to check my mails. What's this? Please help. Thanks in advance V.R.-Wolter

Question owner

Hey VR -

Well, I'm about as non-German speaking as you are non-techsavvy. However, it looks like your screen print is the same "warning unresponsive script" pop-up that I got in English.

If you followed the thread above, you will see that Guigs2 figured out what the problem and has reported it. Unfortunately, the problem has NOT been fixed. So, you'll just have to work around it as I've done.

vj

Hey VR - Well, I'm about as non-German speaking as you are non-techsavvy. However, it looks like your screen print is the same "warning unresponsive script" pop-up that I got in English. If you followed the thread above, you will see that Guigs2 figured out what the problem and has reported it. Unfortunately, the problem has NOT been fixed. So, you'll just have to work around it as I've done. vj
vaswolter 0 solutions 7 answers

Thanks vj - this happens only when I want to check my outlook mails, but not when I check other mail accounts (Yahoo etc.), all on Firefox - it started after updating Firefox to 37; in other words could this mean it's somehow connected with Microsoft? Regards VR

Thanks vj - this happens only when I want to check my outlook mails, but not when I check other mail accounts (Yahoo etc.), all on Firefox - it started after updating Firefox to 37; in other words could this mean it's somehow connected with Microsoft? Regards VR