Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 34.0.5 on Yosemite 10.10.1 refuses to work on YouTube

  • 11 replies
  • 9 have this problem
  • 1758 views
  • Last reply by FredMcD

more options

I have Firefox 34.0.5 and installed and uninstall Flash Player multiple times. When I go to YouTube all I see is a black window. There are no controls whatsoever. I have disabled adblocking and noscript and no difference. I can not even get the animation to play properly on Adobe Flash About page. The problem is Firefox since Safari has no problem with either of these things. I have tried disabling all addons and that of course made no difference whatsoever.

Shockwave Flash 15.0.0.239 is set to Always Activate. I even tried disabling all of my addons and clearing cache and no difference what soever.

Chosen solution

No I even reset Firefox so it got rid of the extensions and did not help. I finally took a final jab at it. Went and deleted firefox and got rid of all the profile directories and anything I could find related to Firefox or Mozilla on the Mac. Did a clean install and now Flash is working.

Read this answer in context 👍 0

All Replies (11)

more options

I just reset Firefox and the problem still exists even after reinstalling Flash for the upteenth time.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

I did all that and did not help the problem. What helped the problem was uninstalling Flash. Youtube videos played then because YouTube was using HTML5 rather than Flash. This happened on two different versions of OSx Mavericks and Yosemite and Firefox. If Flash is installed then all I see is a black square for youtube videos in FFox. There are not even normal player controls!

more options

This machine also has Mavericks and it has exactly the same problem with Firefox under Mavericks. Chrome on Mavericks has no problem with playing YouTube videos nor going to the Flash About Player which shows the animation as well as the version installed!

more options

Disable Mavericks and then try again.

more options

Excuse me? Disable Mavericks? The o/s are independent of each other. Yosemite has the same problem. Flash is totally useless in Firefox.

more options

Are you using Flashblock? There is a new version on the addons site that should fix the problem if you are still using version 1.5.17.

more options

I have reset Firefox settings so that there are no plugins installed. I have deleted the profile for FFox it does not matter. FFox refuses to run any Flash related media period. I can not even access Adobe Flash Manager in Firefox. Chrome and Safari has no such problem.

more options

Are you using any extensions? Obviously, you need to have the Flash plugin installed to use Flash, but you said nothing about extensions. Some of them can interfere.

more options

Chosen Solution

No I even reset Firefox so it got rid of the extensions and did not help. I finally took a final jab at it. Went and deleted firefox and got rid of all the profile directories and anything I could find related to Firefox or Mozilla on the Mac. Did a clean install and now Flash is working.

more options

Sometimes, a re-install is the way to go. Good Work.