Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

news.com.au articles not loading in latest firefox version

  • 15 replies
  • 1 has this problem
  • 1 view
  • Last reply by apurla

more options

The new version of firefox 33.1.1 has stuffed the loading of articles on both http://www.chariot.net.au/ direct call and on news.com.au website call

news.com.au page will load, but articles dont load, goes to vertical list in blue site type map, other than strangely the article headlines on the associated papaers at the bottom of the page.

Previous version of firefox all OK, just upgraded wifes firefox to 33.1.1, lost articles same as mine, not a great move!!!

Can firfox please fix this

All Replies (15)

more options

Hi, apurla!

I tried the site myself and didn't have any problems loading the articles. Let's see if we can figure out what's causing the issue.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

It sounds as though either the site's style sheets are not loading, or are not being applied. If you try to open one of them directly, will it load? Note: it's just a ton of black-text-on-white.

http://resources.newscdn.com.au/cs/nca/latest/public/css/vertical/shared/base.css

And more generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Toscher and jscher2000,

Toscher

Thanks for replying. Tried SafeMode before posting still acted the same.

My other computer also worked OK until it upgraded to 33.1.1 and then went the same.

Reloaded a new copy of Firefox and loaded it over the "updatde" 33.1.1 no avail.

Rebooted no avail.

Tried Fiefox add-ons disabled - no avail

Updated Quicktime - no avail.

Cleaned out windows/prefetch and windows/temp file.

Ran spyware and got rid of adware - no change

Switched off addblock - no change

Works OK on Internet Explorer

jscher

Just cleared out cache and cookies - Closed down Firefox, reopened, still the same.

Have resisted removing firefox completely and reloading new downloaded version - this maybe the only answer. Whats stopping me is that the earlier version of Firefox was OK - all happened after the upgrade.

more options

Hi apurla, I don't know whether scrubbing all traces of Firefox off your system will help, and you may lose a lot of data. Here are a couple of things you can try that are half-steps in that direction.

(1) Create a new profile to test whether the problem remains. (2) Replace Firefox's program folders in case stray files are causing issues.

Here are the details for those:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also will have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box, or Run (hold down the Windows key and press R):

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Go ahead and click the Create Profile button, give it a name like Nov21, and skip the option to change the folder location. Then start Firefox in the new profile you created.

Until you go back to the Profile Manager and start up in your regular profile, your desktop shortcut should fire up the new profile.

Does the page lay out any better?

Note: When returning to the Profile Manager, you might be tempted to use the Delete Profile button on your new test profile. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.


Clean Reinstall procedure:

(1) Download a fresh installer for Firefox 33 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) If applicable, exit out of Firefox or make sure it is fully terminated in Task Manager.

(3) Rename the program folder

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

You might need to exit and start again to test whether Firefox is now remembering preference changes.

Note: Some recently installed plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Does the news site lay out any better?

Modified by jscher2000

more options

Thanks jscher

Before I attempt all that, I went onto my laptop, and that too has the same problem being 33.1.1 which would mean that I'd have to do 3 computers - seems strange that all 3 would have the same problem.

My second laptop has Firefox version 31 and loads properly no problem.

At the moment I'm not convinced that it is outside Firefox - 33.1.1 update caused this and I think it has a bug in it.

Another possibility is that news.com.au web designers havent upgraded their side to cope with 33.1.1.

Do we know if Firefox engineers are looking at this?.

more options

I think there's still a question mark about how to reproduce the problem. Could you give specific pages that do not layout correctly?

The second one is where I pulled the style sheet link I mentioned before: http://resources.newscdn.com.au/cs/nca/latest/public/css/vertical/shared/base.css

Will that load for you? It should just be a ton of text (styles rules for the page).

If that loads, and you go back and reload an article on the news site, is there any difference?

more options

jscher,

The page you found loads - lots of programming gobblygook

Here's the problem sequence

1) Home page http://www.chariot.net.au/

2) Down the right hand side there's a block headed news headlines where there is a list of news items. Normally selecting any of these the news item turns up.

An alternative is to pick the news.com.au at the bottom rh side of the block. This takes you to the news.com.au web page which loads normally.

Pick one of the main items on the left and the blue list appears as it did when picked off the chariot front page.

Go down to the papers below ( Courier Mail, Advertiser etc) and pick the story there and it loads!!!!!

more options

What you're describing sounds like what I see if I disable styling. You can see the effect on another site using:

(menu bar) View > Page Style > No Style

If you do not normally display the menu bar, tap the Alt key or press F10 to display it temporarily.

(This only affects the active tab, other tabs are not affected.)

That's why I was wondering about whether you could load the style sheet. Since you can, I am having trouble figuring out why Firefox isn't applying it to the article. With just one site having this issue, ruling out cache issues and trying Safe Mode, it's hard to spot a pattern.

more options

The only pattern that seems to be occuring is its increasing occurance - now my wifes i-pad has gone the same. I'm seriously wondering if its a problem that certain websites are IE preferred and they don't work as well on firefox - I have a site that I have to use IE on as the printout seems to be affected in firefox. I'm thinking it could be a news.com.au compatability issue with the upgraded firefox 33.1.1.

For now, thanks you guys for trying to help. Never used this process but its great.

If I get any changes I'll post it up.

Thanks again

more options

Hmm, the site looks normal for me in Firefox 31.1.1, but it's possible we have different settings and add-ons that are making it work better for me.

With the iPad affected, I wonder whether there is anything unusual about your network connection? Does your router include any filtering features that could be a factor? Of course, that wouldn't explain IE continuing to work...

more options

My first laptop that was playing up with 31.1.1 yesterday but didnt today and now it is showing version 31.1!!! The mystery deepens !!

more options

Looks like I've solved it!!!

Went on IE to get the news and it wouldnt play any videos. Went to a known site and played a video and it wanted flash player becuse it wasnt installed!!!

Yet I have had flashplayer for years and it constantly updates.

So installed flashplayer through IE, then it booted up foirefox and low and behold a video played.

Closed it all down and then rebooted Firefox and the articles come up as per normal.

Looks like 33.1.1 disengages flashplayer or doesnt do an update for it.

Will check the other computers and let you know the outcomes.

more options

Now my wifes i-pad has gone down. No idea how to sort this one for safari but seems to be the same problem

Both ordinary computers are now ok

The sequence I used was 1) Boot up IE and go to bbc.co.uk/football and pick one of the videos that wont start but it tells you need flashplayer and ask you to load it - pick it and then download the latest flashplayer and run.

2)Repeat 1) and pick the same video which should start - this apparently is a neccesary step to start flashplayer.

3) Cancel IE, start firefox and then try a news item in chariot.net.au - should work.

4) If you do the sequence thru firefox you have to close and reopen firefox - i actually rebooted the machine also if there's still a problem.

5) Make sure under add-ons that flashplayer is set to "always activate".

more options

This is a confusing result because Firefox uses a plugin for Flash and IE uses an ActiveX control. I think the only time you would use an ActiveX control for Flash in Firefox is if you were using an "IE Tab" type extension to embed IE into a Firefox tab.

That said, the Flash installer might have cleaned up some messed up settings that affect Flash in all browsers.

While Firefox defaults the Flash player to Always Activate, if it did get switched to "Ask to Activate" then you could activate Flash using the notification icon in the address bar (looks like a small Lego block). The problem is that usually you wouldn't notice this if the page didn't advertise that there was a video...

more options

Confusing - your dead right. This morning I booted up firefox and picked a news item and got both - news item and blue list!!!! Closed it all down, rebooted firefox and everythings OK - must have a gremlin in there with a sore head me thinks. Flash was set to Always Activate.

Haven't solved the i-pad yet though. Referring that to wifes sons.