Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

reset plugin behavior

  • 10 replies
  • 7 have this problem
  • 15996 views
  • Last reply by JunoRebel

more options

Situation before: -have set Shockwave Flash to 'ask to activate'. -worked well, like expected: on a page with Flash, FF pops up a button to allow Flash or to continue blocking it

Then: - accidentally clicked 'continue to block this site' instead of 'allow Flash'

Situation now: -FF does not pop up the button anymore to activate Flash on that site; Flash content is not shown -i can 1) go to Options-->Add-ons-->set Shockwave Flash to 'always activate' and then the Flash content works on that page. This is unwanted because it does so too on all other pages. Or, 2) i can set it to 'never activate' which is also unwanted. Or, 3) i can set it to what is must be, 'ask to activate'. However FF does still not ask me what to do for that particular site and it keeps blocking Flash content even with the setting 'ask to activate'.

Have tried: -to set it to 'always activate', restart FF, set it to 'ask to activate' -->no changes -have deleted "pluginreg.dat" after closing FF in combination with the above as well as without it: no effect -have opened "about:permissions" but there are no options for the Flash plugin, not global and neither per site

To see Flash content on that particular page i must have the plugin to 'always activate' which i do no want.

How can i get FF to pop up that message with permission buttons again?

Chosen solution

Okay, so, here's the hard way. Maybe there is an add-on that makes this a breeze, but I tend to use the tools in my kit.

The nuclear option for clearing saved permissions is to delete the permissions.sqlite database and have Firefox start building up your site-specific permissions from scratch.

Hopefully you won't need to do that for this: you can delete that one permission, or similar permissions, using the SQLite Manager extension. This is a somewhat nerdy, but if you mess up, you should be able to recover by deleting the database and building it up from scratch again.

SQLite Manager adds itself to the Tools menu on the menu bar (tap the Alt key to display the bar if needed). When you start SQLite Manager, it may suggest to open the last database you used. You can cancel that.

On the SQLite Manager toolbar, click the (Select Profile Database) button, choose permissions.sqlite, and click Go. After the database loads:

  • click moz_hosts in the list of Tables in the left column
  • click the Browse & Search tab
  • click the Search button
  • in the row for Type, change the match operator from = to contains, then type hidden and click OK

This should show all plugin-hidden-notification permissions. You can click one and then click the Delete button to remove it.

I'm not sure how long it would take for Firefox to notice this change but I was impatient and decided to exit and start Firefox up again to speed the process. That worked.

It's a long way to go to get the Infobar back, but if you can't live without it...

Read this answer in context 👍 6

All Replies (10)

more options

When you are on the page, call up the Page Info dialog using one of these methods:

  • right-click and choose View Page Info > Permissions
  • (menu bar) Tools > Page Info > Permissions
  • click the padlock or globe icon > More Information > Permissions

You should find a list of permissions for each of your plugins. Can you fix it there?

more options

Thanks for your time and knowledge. Much appreciated.

Sorry to say this is not yet the solution. It gives me a workaround, though.

The options i have in View Page Info > Permissions for Adobe Flash: -default behavior (it was set to this) -always ask (which is the intended default behavior) -always allow -always block

Now, the last 2 do exactly what they must. So it does provide me with a workaround: i can activate all flash content on that particular site without activating it for other pages.

But setting it to 'always ask' does not change FF's behavior for that site, that is: it still won't show the buttons to block/activate the content, and the content is still blocked.

Have repeated the steps from my OP to be sure, but that made no difference. I have even told FF to always allow Flash, went to the page and set permission for the page to 'always ask'. FF still blocks Flash content, and still doesn't ask permission to show it.

more options

So I went to YouTube, got the Infobar sliding down, and clicked Continue Blocking. As you describe, the bar does not come back.

The "Lego" icon to allow Flash is still in the address bar, even though the Infobar does not appear. You could use that icon for now. I realize it doesn't call attention to itself, so it might be annoying to have to think to check.

The "Continue blocking" option appears to add a new entry to the permissions.sqlite database (site-specific permissions) that suppresses the Infobar forever. (See attached screenshot from the SQLite Manager extension, with annotation from the MDN article)

I'm going to experiment with this a bit.

more options

Chosen Solution

Okay, so, here's the hard way. Maybe there is an add-on that makes this a breeze, but I tend to use the tools in my kit.

The nuclear option for clearing saved permissions is to delete the permissions.sqlite database and have Firefox start building up your site-specific permissions from scratch.

Hopefully you won't need to do that for this: you can delete that one permission, or similar permissions, using the SQLite Manager extension. This is a somewhat nerdy, but if you mess up, you should be able to recover by deleting the database and building it up from scratch again.

SQLite Manager adds itself to the Tools menu on the menu bar (tap the Alt key to display the bar if needed). When you start SQLite Manager, it may suggest to open the last database you used. You can cancel that.

On the SQLite Manager toolbar, click the (Select Profile Database) button, choose permissions.sqlite, and click Go. After the database loads:

  • click moz_hosts in the list of Tables in the left column
  • click the Browse & Search tab
  • click the Search button
  • in the row for Type, change the match operator from = to contains, then type hidden and click OK

This should show all plugin-hidden-notification permissions. You can click one and then click the Delete button to remove it.

I'm not sure how long it would take for Firefox to notice this change but I was impatient and decided to exit and start Firefox up again to speed the process. That worked.

It's a long way to go to get the Infobar back, but if you can't live without it...

more options

Great. Very, very nice work. It works (of course). Thanks a lot.


"It's a long way to go to get the Infobar back, but if you can't live without it..."

I'm still alive, but barely - you were just in time! ;-)

more options

Just need to clarify, i realise: i chose the easy way, with SQLite Manager.

more options

Note that you should also see exceptions for the current domain in the drop down of the "Site Identity Button" (globe/padlock) on the location/address bar.

more options

Thanks for your response, but I don't quite understand it. Exceptions for the current domain - exceptions to what, exactly?

Does this somehow provide a similar procedure to what jscher2000 writes in my chosen solution? Or does it just lead to another way to make the same changes you can make in the Page Info Dialog?

Sorry, i don't understand what you're trying to help me with. What can i do with the information you provide?

more options

Exceptions to some settings from the default value like you see in "Tools > Page Info > Permissions" including an allow or block cookie exception and settings for plugins.

more options

The dropdown of the site identity does not hold any information regarding permissions for content. At least in my case. It shows permissions for Full Screen, and/or holds information about the security/owner.

Are you sure you're not referring to the icon next to that? On youtube that icon resembles a Lego block. If you do, that information is of little use here (it was already mentioned) and if you don't, i really don't understand how from there i would find exception cookies and settings. And it's actually still not clear to me if this is an entirely new option with information that's only found there, or if it's just another method of getting to Page Permissions.

But the issue is already fixed and since i'm still unsure why you're pointing me here, i'll stop posting now. I do thank you for your time and effort to try and help me, but I'm sorry to say i'm still unsure if your information is useful for me/this issue, and how.