Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

youtube in opening in older firefox v10 only but not in newer one.

  • 2 replies
  • 2 have this problem
  • 23 views
  • Last reply by FredMcD

more options

Using WINDOWS 7, when i updates my firefox from 10 to 23, youtube page stop loading ( page not found) in newer firefox.. at same time youtube was working on my cell phone and also on laptop having firefox v10,, i restore older version 10 and youtube start load and work fine.. NOTE: youtube still not loading on any other latest browser but just loading on firefox 10

Using WINDOWS 7, when i updates my firefox from 10 to 23, youtube page stop loading ( page not found) in newer firefox.. at same time youtube was working on my cell phone and also on laptop having firefox v10,, i restore older version 10 and youtube start load and work fine.. NOTE: youtube still not loading on any other latest browser but just loading on firefox 10

All Replies (2)

more options

Please update to Firefox 29.0.1 (Update Firefox to the latest release) and tell me if you can still access Youtube.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > Network > Cached Web Content: Clear Now

and

  • Remove Cookies

Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.