Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I open Google Maps with Firefox (Mac OS-X V 10.6.8) the map initially opens then the screen quickly turns black and toolbars on left are upside down.

  • 5 replies
  • 36 have this problem
  • 86 views
  • Last reply by jscher2000

more options

When I open Google Maps with Firefox (Mac OS-X V 10.6.8) the map initially opens then the screen quickly turns black and toolbars on left are upside down. Using Firefox V 26.0. Google Maps works fine with Safari, but Firefox is my primary browser and each time I attempt to open Google Maps on with Firefox I get the same result: Quick view of map then a black screen with tool bar window on left of screen upside down. Is there a fix?

Chosen solution

Separate issue: Is something holding you back from upgrading to Firefox 28? Please let us know so we can suggest solutions or workarounds.

The reason, of course, is that Firefox 26 is not secure. Mozilla discloses security flaws after each new release.

Read this answer in context 👍 0

All Replies (5)

more options

Sometimes inexplicable display issues are caused by an incompatibility between Firefox and your graphics card driver software. The standard workaround is to disable Firefox's use of hardware acceleration. However, this may degrade the appearance of fonts.

Firefox menu > Preferences > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This will take effect the next time you Quit out of Firefox and start it up again.

more options

More generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

You also can clear Firefox's cache completely using:

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Chosen Solution

Separate issue: Is something holding you back from upgrading to Firefox 28? Please let us know so we can suggest solutions or workarounds.

The reason, of course, is that Firefox 26 is not secure. Mozilla discloses security flaws after each new release.

more options

Problem was solved by downloading newest version (28) of Firefox. Many thanks for the easy fix! One comment: When I checked the previous version of Firefox (v26) on my Mac it said it was up to date. Did not mentioned that v 28 was available... Shouldn't users be notified when a new version is released?

more options

Usually Firefox will check for updates on its own. However, I only really understand how that works on Windows.