Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 37.0.2 upside down bug

  • 2 replies
  • 2 have this problem
  • 11 views
  • Last reply by wyrenth

more options

I update firefox to 37.0.2

In change log is writen that google maps upside down bug is fixed but is still not.

With Nvidia latest drivers installed, google maps is still upside down on win 7 x64

On XP with integrated ati card all is OK in 37.0.1 and also now in 37.0.2, problem is still on Pc that have Nvidia card, here map is still upside down.

All Replies (2)

more options

This actually did not get fixed in 37.0.2 (the bug fixed in 37.0.2 was another issue with google maps, not the upside down bug). Please disable Hardware Acceleration to use Google Maps until this is fixed. Turning off hardware acceleration

more options

This issue occurs for me when OMTC is disabled and Hardware Acceleration is enabled. To remedy this, go into about:config and set the following:

  • layers.offmainthreadcomposition.enabled = true

Unfortunately, disabling OMTC and enabling Hardware Acceleration is a fix for text rendering issues in Firefox. So you're forced to choose between readable text and readable maps.

Google Chrome does not appear to suffer from this issue. I'd really prefer not to migrate, but this "pick your poison" complication is starting to press the issue...