X
Tap here to go to the mobile version of the site.

Support Forum

My toolbar on Yahoo mail disappeared - how to restore it?

Posted

The mail program on Yahoo has been frozen in Firefox, no other browser. Yesterday, I opened it, and i was unable to delete mail because the whole toolbar with delete, reply, forward, spam, etc. was no longer on my mail window. I tried to send an email, but this function was also disabled.

Basically, the only thing that Firefox enables in Yahoo mail is loading new emails. I had to use Safari and Chrome to perform these functions on the toolbar that is still missing in Firefox.

What happened? How to restore these functions?

The mail program on Yahoo has been frozen in Firefox, no other browser. Yesterday, I opened it, and i was unable to delete mail because the whole toolbar with delete, reply, forward, spam, etc. was no longer on my mail window. I tried to send an email, but this function was also disabled. Basically, the only thing that Firefox enables in Yahoo mail is loading new emails. I had to use Safari and Chrome to perform these functions on the toolbar that is still missing in Firefox. What happened? How to restore these functions?

Chosen solution

These buttons do move elsewhere when you have the preview pane on the right, but from the screenshot I can see that you do not, plus you don't have the view button or the select all/group button. You can try changing turning your preview pane on and trying it both on the right and on the bottom to see if that helps:

  1. Click the cog icon in the top right and click 'Settings' from the menu.
  2. Under 'Viewing email', change the setting for 'Preview pane'.
  3. Click the save button.

You can also try setting your viewing mode to basic:

  1. Go to 'Settings' > 'Viewing email' as before.
  2. Select the 'Basic' option next to 'Mail version' and click save.

You can change back to the full featured version by clicking 'Switch to the newest Yahoo Mail' near the top right.

Please tell us how you get on with our suggestions.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Shockwave Flash 12.0 r0
  • Widevine Media Optimizer 6.0.0.12607
  • NDS Player Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Amazon MP3 Downloader Plugin 1.0.17
  • 5.1.10411.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

Moses
  • Moderator
458 solutions 3599 answers

There's two meanings to toolbar here.

  • The actual toolbar that has a search box along with various Yahooo functions
  • OR the toolbar that has Send, Reply, New, etc, etc, etc.

Can you take a screenshot so we can know exactly what you are talking about?

There's two meanings to toolbar here. *The ''actual'' toolbar that has a search box along with various Yahooo functions *OR the toolbar that has Send, Reply, New, etc, etc, etc. Can you take a screenshot so we can know exactly what you are talking about? *Please see [[How do I create a screenshot of my problem?]]
cor-el
  • Top 10 Contributor
  • Moderator
16230 solutions 146520 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

COR-EL - Thanks for trying to help. I cannot translate anything you wrote out of computer speak into English! Safe-mode? Extensions? Cookies? All Greek to me :-(

I have a MacBook Pro, does this help at all? I am a writer and a photographer - film, not SM card stuff :-)


MOSES - Thank you for your reply, as well. I will get a screen shot of this as soon as I get home and locate my instructions for this in my One-to-One notebook.

In the meantime, the toolbar I am writing about that took a powder is the 2nd one you mentioned - the one with "reply, forward, delete, spam", etc.

Thanks in advance to you both, I'll be back tonight with a screenshot!

COR-EL - Thanks for trying to help. I cannot translate anything you wrote out of computer speak into English! Safe-mode? Extensions? Cookies? All Greek to me :-( I have a MacBook Pro, does this help at all? I am a writer and a photographer - film, not SM card stuff :-) MOSES - Thank you for your reply, as well. I will get a screen shot of this as soon as I get home and locate my instructions for this in my One-to-One notebook. In the meantime, the toolbar I am writing about that took a powder is the 2nd one you mentioned - the one with "reply, forward, delete, spam", etc. Thanks in advance to you both, I'll be back tonight with a screenshot!
WilIP 13 solutions 64 answers

Cookies and cache are information that websites you visit store on your computer - these are often preferences, such as whether you use the 'basic' version of Yahoo! mail or the 'full featured' version. Deleting these means that Yahoo! will set some of its less important settings back to their default values - useful if you accidentally changed some settings and can't figure out how to change them back. No important information is stored in cookies or cache, so deleting them will just mean that you will have to log back into some websites. Read this article on deleting cookies - try just deleting cookies for Yahoo!. If this doesn't work, delete all your cookies and check the box next to cache as well.

If you still have trouble, the problem is possibly being caused by extensions - programs that run within Firefox to provide extra functions such as video playing or advertisement blocking. To help find out which extension(s) is/are causing the problem, follow this article on using safe mode - allowing you to test websites with some of Firefox's settings temporarily reset and with extensions turned off.

Cookies and cache are information that websites you visit store on your computer - these are often preferences, such as whether you use the 'basic' version of Yahoo! mail or the 'full featured' version. Deleting these means that Yahoo! will set some of its less important settings back to their default values - useful if you accidentally changed some settings and can't figure out how to change them back. No important information is stored in cookies or cache, so deleting them will just mean that you will have to log back into some websites. Read [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored?redirectlocale=en-US&redirectslug=Deleting+cookies this article] on deleting cookies - try just deleting cookies for Yahoo!. If this doesn't work, [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored?redirectlocale=en-US&redirectslug=Deleting+cookies#w_delete-all-cookies delete all your cookies] and check the box next to cache as well. If you still have trouble, the problem is possibly being caused by extensions - programs that run within Firefox to provide extra functions such as video playing or advertisement blocking. To help find out which extension(s) is/are causing the problem, follow [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode this article] on using safe mode - allowing you to test websites with some of Firefox's settings temporarily reset and with extensions turned off.

Question owner

I sent my screen shot to you here last week! This website of "help" - an odd name for such a joke - never posted it here.

Here it is - this error has still not been corrected - not by yahoo, not by firefox. WHERE IS THE PHONE SUPPORT???

Nothing gets solves without talking to people - Thanks for trying to help, this is now 1 week wasted by me - and by all of you - probably would have taken a 30 second call if either of these companies bothered to hire PEOPLE!!! We're going back to Fred-Flintstone land! Al Bell would be rolling over in his grave.

I sent my screen shot to you here last week! This website of "help" - an odd name for such a joke - never posted it here. Here it is - this error has still not been corrected - not by yahoo, not by firefox. WHERE IS THE PHONE SUPPORT??? Nothing gets solves without talking to people - Thanks for trying to help, this is now 1 week wasted by me - and by all of you - probably would have taken a 30 second call if either of these companies bothered to hire PEOPLE!!! We're going back to Fred-Flintstone land! Al Bell would be rolling over in his grave.
Moses
  • Moderator
458 solutions 3599 answers

Hi Momus,

Please understand that we are all volunteers doing this on our own time and this website is community-powered therefore Firefox developers are unlikely to read your comments. You can, however, provide feedback for the Firefox developers at input.mozilla.org/feedback if you wish.

Also, there is no phone support for Firefox as we have this site.

Another thing, the screenshot above is the only screenshot you've sent us. We haven't received anything else. You posted on the 14th
Thanks in advance to you both, I'll be back tonight with a screenshot!

However, you've recently just sent us a screenshot yesterday (4/20/14).
You always said you sent us a screenshot last week

I sent my screen shot to you here last week! This website of "help" - an odd name for such a joke - never posted it here.
You didn't until yesterday (4/20/14)

Seeing your screenshot helps immensely though.

Please try the following steps to see if it corrects the problem. Please do them one at a time.

Let me "translate" what cor-el said:

Clearing cache

  • Click the Firefox name on your task bar > then Preferences > go tothe Advanced tab > Network tab >under Cached Web Content: Click "Clear Now"

Clearing cookies for Yahoo

  • Click the Firefox name on your task bar > then Preferences > click the Privacy tab >Select "Use custom settings for history" > Click Cookies: then "Show Cookies"
  • search for Yahoo.com and select the yahoo.com folder then click Remove Cookies.

Try to load your Mail again


2nd suggestion: Can you try to access Firefox in Safe Mode to see if the problem still exists and/or if it opens? You can follow the below instructions to start it in that mode.

  • Go to (on your menu bar) Help > Restart with add-ons disabled
  • When Firefox closes and re-opens, select Start in Safe Mode

If Firefox works fine after starting in Safe Mode, then it's most likely one of your extensions misbehaving. You can enable your add-ons back on by one until you find the conflicting extension.

  • Press the Command key, SHIFT key, then A to open your add-ons window OR go to Tools > Add-ons
  • Click the extensions tab on the left side
  • All of your extensions will say disabled. Please enable them one at a time and then try to reload the page to see if it works. If it doesn't then the problem isn't with that extension. Go down your list of extensions until you find the one that shows that bar going away.
Hi Momus, Please understand that we are all volunteers doing this on our own time and this website is community-powered therefore Firefox developers are unlikely to read your comments. You can, however, provide feedback for the Firefox developers at input.mozilla.org/feedback if you wish. Also, there is no phone support for Firefox as we have this site. Another thing, the screenshot above is the only screenshot you've sent us. We haven't received anything else. You posted on the 14th <blockquote>Thanks in advance to you both, I'll be back tonight with a screenshot! </blockquote> However, you've recently just sent us a screenshot yesterday (4/20/14).<Br> You always said you sent us a screenshot last week <blockquote>I sent my screen shot to you here last week! This website of "help" - an odd name for such a joke - never posted it here. </blockquote> You didn't until yesterday (4/20/14) Seeing your screenshot helps immensely though.<br> '''Please try the following steps to see if it corrects the problem. Please do them one at a time.''' Let me "translate" what cor-el said: <h4>Clearing cache</h4> *Click the Firefox name on your task bar > then Preferences > go tothe Advanced tab > Network tab >under Cached Web Content: Click "Clear Now" <h4>Clearing cookies for Yahoo</h4> *Click the Firefox name on your task bar > then Preferences > click the Privacy tab >Select "Use custom settings for history" > Click Cookies: then "Show Cookies" *search for Yahoo.com and select the yahoo.com folder then click Remove Cookies. Try to load your Mail again ---- 2nd suggestion: Can you try to access Firefox in Safe Mode to see if the problem still exists and/or if it opens? You can follow the below instructions to start it in that mode. *Go to (on your menu bar) Help > Restart with add-ons disabled *When Firefox closes and re-opens, select ''Start in Safe Mode'' If Firefox works fine after starting in Safe Mode, then it's most likely one of your extensions misbehaving. You can enable your add-ons back on by one until you find the conflicting extension. *Press the Command key, SHIFT key, then A to open your add-ons window OR go to Tools > Add-ons *Click the extensions tab on the left side *All of your extensions will say disabled. Please enable them one at a time and then try to reload the page to see if it works. If it doesn't then the problem isn't with that extension. Go down your list of extensions until you find the one that shows that bar going away.

Modified by Moses

WilIP 13 solutions 64 answers

Chosen Solution

These buttons do move elsewhere when you have the preview pane on the right, but from the screenshot I can see that you do not, plus you don't have the view button or the select all/group button. You can try changing turning your preview pane on and trying it both on the right and on the bottom to see if that helps:

  1. Click the cog icon in the top right and click 'Settings' from the menu.
  2. Under 'Viewing email', change the setting for 'Preview pane'.
  3. Click the save button.

You can also try setting your viewing mode to basic:

  1. Go to 'Settings' > 'Viewing email' as before.
  2. Select the 'Basic' option next to 'Mail version' and click save.

You can change back to the full featured version by clicking 'Switch to the newest Yahoo Mail' near the top right.

Please tell us how you get on with our suggestions.

These buttons do move elsewhere when you have the preview pane on the right, but from the screenshot I can see that you do not, plus you don't have the view button or the select all/group button. You can try changing turning your preview pane on and trying it both on the right and on the bottom to see if that helps: # Click the cog icon in the top right and click 'Settings' from the menu. # Under 'Viewing email', change the setting for 'Preview pane'. # Click the save button. You can also try setting your viewing mode to basic: # Go to 'Settings' > 'Viewing email' as before. # Select the 'Basic' option next to 'Mail version' and click save. You can change back to the full featured version by clicking 'Switch to the newest Yahoo Mail' near the top right. Please tell us how you get on with our suggestions.

Question owner

Thank you - I reallize you are volunteers. I DID send the screenshot on the 14th - it was never posted!

I just can't figure out why there are no paid employees doing this on the phone - an idiotic way to do business! I appreciate your time and efforts to help those of us who don't live in the electronic world :-)

Thank you - I reallize you are volunteers. I DID send the screenshot on the 14th - it was never posted! I just can't figure out why there are no paid employees doing this on the phone - an idiotic way to do business! I appreciate your time and efforts to help those of us who don't live in the electronic world :-)

Question owner

THIS was very helpful - went to that wheel/cog in the upper right and found the items you said would be there. Clicked on "Basic" and the menu bar showed up.

Before this, I couldn't even open up a single mail item in Firefox. Weird.

Many thanks to you - and all the rest of you - who took the time to reply to my plaintive wail!

THIS was very helpful - went to that wheel/cog in the upper right and found the items you said would be there. Clicked on "Basic" and the menu bar showed up. Before this, I couldn't even open up a single mail item in Firefox. Weird. Many thanks to you - and all the rest of you - who took the time to reply to my plaintive wail!
joepiccaso 0 solutions 2 answers

I empathize with Momus. It is sad that something happens out of the clear blue like this and no one knows why. My Yahoo Mail tool bar is gone and renders it useless. I can switch to the basic, but I don't like it. It works fine in IE and Chrome, so it has to be something in Firefox. I like Firefox, but I may have to lose it now. The only other thing is I dropped my paid Yahoo Mail account, because of the same thing that bothers Momus, No Support! They expect you to wade through hundreds of pages of posts and idiotic ramblings trying to find a solution. I tried to find out why I was unable to change a name in the Contacts, My daughter got married, and it will Not change. There are hundreds of Posts on changing your screen mane and stuff, and one person gave me the instructions for Editing Contacts, which I was smart enough to find on my own, but it didn't work, as I had previously posted. Just a pure waste of a couple of hours of searching the ramblings of teeny techs. Even the instruction here are difficult to follow and arcane. Virtually none of them are clear enough to even follow. If I can figure out how to save my Yahoo emails, I'll just get a Google account, which may not be any better. The lack of support, especially, when I paid for the account, is unconscionable. It looks like I'll have to switch browsers, as well, to Chrome. I cannot do IE, though. I appreciate your volunteering, but there s/b more support. I'd pay for the freak'n browser for some support, but then they'd have to drop all of the ads and crap.

I empathize with Momus. It is sad that something happens out of the clear blue like this and no one knows why. My Yahoo Mail tool bar is gone and renders it useless. I can switch to the basic, but I don't like it. It works fine in IE and Chrome, so it has to be something in Firefox. I like Firefox, but I may have to lose it now. The only other thing is I dropped my paid Yahoo Mail account, because of the same thing that bothers Momus, No Support! They expect you to wade through hundreds of pages of posts and idiotic ramblings trying to find a solution. I tried to find out why I was unable to change a name in the Contacts, My daughter got married, and it will Not change. There are hundreds of Posts on changing your screen mane and stuff, and one person gave me the instructions for Editing Contacts, which I was smart enough to find on my own, but it didn't work, as I had previously posted. Just a pure waste of a couple of hours of searching the ramblings of teeny techs. Even the instruction here are difficult to follow and arcane. Virtually none of them are clear enough to even follow. If I can figure out how to save my Yahoo emails, I'll just get a Google account, which may not be any better. The lack of support, especially, when I paid for the account, is unconscionable. It looks like I'll have to switch browsers, as well, to Chrome. I cannot do IE, though. I appreciate your volunteering, but there s/b more support. I'd pay for the freak'n browser for some support, but then they'd have to drop all of the ads and crap.

Modified by joepiccaso

Question owner

Thanks for translating -

I tried all your steps in Firefox and in the Yahoo.com cookies - reloaded my mail program in Firefox - and STILL the toolbar for all mail functions is missing.

I think this Firefox/Yahoo marriage is damaged beyond repair, other than hands-on-in-person work by some technical adviser. I have no idea why it disappeared without so much as a wrong key depressed.

More reason to be wary of electronics over mechanics! My Leica M6 is always repairable :-)

Thank you again for trying to help me correct this error!

Thanks for translating - I tried all your steps in Firefox and in the Yahoo.com cookies - reloaded my mail program in Firefox - and STILL the toolbar for all mail functions is missing. I think this Firefox/Yahoo marriage is damaged beyond repair, other than hands-on-in-person work by some technical adviser. I have no idea why it disappeared without so much as a wrong key depressed. More reason to be wary of electronics over mechanics! My Leica M6 is always repairable :-) Thank you again for trying to help me correct this error!

Question owner

Keep your Firefox browser, it is better for some functions than Chrome or Safari. Internet Explorer is the most useless, hasn't been updated for Macintosh since 2002 - they even had to give up supporting it in their machines after about 2006-7.

Chrome works better for some sites, Firefox for some, and Safari for some. Just have to bounce around, I'm afraid.

Keep your Firefox browser, it is better for some functions than Chrome or Safari. Internet Explorer is the most useless, hasn't been updated for Macintosh since 2002 - they even had to give up supporting it in their machines after about 2006-7. Chrome works better for some sites, Firefox for some, and Safari for some. Just have to bounce around, I'm afraid.

Helpful Reply

Thank you -

Changing to "basic" screws up all the toolbars on every single browser. The toolbar works better in the original layout, even though it still doesn't appear in Firefox in EITHER format!!

I think this error is unable to be corrected without hands-on-in-person correcting, at this point. Nothing any of you helpful people have directed me to do has corrected the error. Thanks again for trying to help me!

Thank you - Changing to "basic" screws up all the toolbars on every single browser. The toolbar works better in the original layout, even though it still doesn't appear in Firefox in EITHER format!! I think this error is unable to be corrected without hands-on-in-person correcting, at this point. Nothing any of you helpful people have directed me to do has corrected the error. Thanks again for trying to help me!