X
Tap here to go to the mobile version of the site.

Support Forum

Fire Fox will not auto fill PW & UN in sites on new computer

Posted

I am setting up a new computer and have set preferences to save PW & UN when opening sites. This function does not work even though FF has asked if I want to save the PW and they show in the saved password folder.

I am setting up a new computer and have set preferences to save PW & UN when opening sites. This function does not work even though FF has asked if I want to save the PW and they show in the saved password folder.

Chosen solution

Details like websites remembering you (log you in automatically) are stored in a cookie.
So you now appear to keep the cookies from those websites.
This should have nothing to do with the places.sqlite file.

Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.

  • Tools > Options > Privacy > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Version 5.2.4.18058
  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • VLC media player Web Plugin 2.0.6
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.4.1 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • FLV Runner 10.23.0.822 ({3bbd3c14-4c16-4989-8366-95bc9179779d}) (Inactive)
  • Geomate.jr Manager 1.0.3.2 (navitfound@apisphere.com) (Inactive)
  • Geomate.jr Upgrader 1.0.3.2 (navitloader@apisphere.com) (Inactive)
  • HP Smart Web Printing 4.5 (smartwebprinting@hp.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • SweetPacks A14 10.23.0.822 ({ecf9d4ae-b571-42c2-9745-74fdb8b0d27a}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Radeon X1600/X1650 Series
  • adapterDescription2:
  • adapterDeviceID: 0x71c2
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 2-10-2010
  • driverDate2:
  • driverVersion: 8.593.100.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: www.yahoo.com
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3201318&SearchSource=2&CUI=UN37882895381203685&UM=2&q=
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1395254733
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 53661
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np-mswmp: 2
  • plugin.state.npconduitfirefoxplugin: 2
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394055052

Misc

  • User JS: No
  • Accessibility: No
Daniel Phillips 14 solutions 77 answers

You can check the value the signon.autofillForms pref on the about:config page.

Start Firefox in [Firefox issues using Safe Mode] to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

You can check the value the '''signon.autofillForms''' pref on the '''about:config''' page. * http://kb.mozillazine.org/signon.autofillForms Start Firefox in [[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode|Troubleshoot Firefox issues using Safe Mode]] to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). * Don't make any changes on the Safe mode start window. * https://support.mozilla.org/kb/Safe+Mode * https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

I am sorry but I could not follow any of your suggestions. I am having the same issue with a new computer. I opened a new site and saved the PW when asked to do so but FF did not apply that when I reopened the site. I have used this function for years and would like to continue.

I am sorry but I could not follow any of your suggestions. I am having the same issue with a new computer. I opened a new site and saved the PW when asked to do so but FF did not apply that when I reopened the site. I have used this function for years and would like to continue.
Daniel Phillips 14 solutions 77 answers

What part of my instructions were you not able to follow?

What part of my instructions were you not able to follow?

Question owner

I got as far as opening signon.autofillForms but did not see anything about a "about.config" page

In the second set of instructions are you talking about Safe Mode on the computer or is there a Safe Mode within FF?

I got as far as opening signon.autofillForms but did not see anything about a "about.config" page In the second set of instructions are you talking about Safe Mode on the computer or is there a Safe Mode within FF?
Daniel Phillips 14 solutions 77 answers

In the awesome bar (the one you enter the URLs in) type; about:config. You will see a search bar at the top, where you can search for signon.autofillForms and check check it'll it's set to 'true'.

I'm talking about the built in safe mode in Firefox

In the awesome bar (the one you enter the URLs in) type; about:config. You will see a search bar at the top, where you can search for signon.autofillForms and check check it'll it's set to 'true'. I'm talking about the built in safe mode in Firefox
Moses
  • Moderator
459 solutions 3607 answers

To add to what Daniel said, here are the instructions to start Firefox in Safe Mode.

  • Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

To add to what Daniel said, here are the instructions to start Firefox in Safe Mode. * Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]]
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers

Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password.

Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords.


Does the Password Manager show all stored names and passwords?

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password. Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list. You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords. *http://kb.mozillazine.org/User_name_and_password_not_remembered ----- Does the Password Manager show all stored names and passwords? *Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords" Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing

Question owner

signon.autofillforms is True

The password manager has saved UN & PW for the sites in question.

Not sure I understand autocomplete=off but I did double click on the UN box in one of the sites in question and there was nothing there that in a drop down box that referred to this question.

This function had worked for years and just stopped.

The site in question will autofill the UN & PW once I type the first letter of the UN but will not do it automatically when I open the site.

signon.autofillforms is True The password manager has saved UN & PW for the sites in question. Not sure I understand autocomplete=off but I did double click on the UN box in one of the sites in question and there was nothing there that in a drop down box that referred to this question. This function had worked for years and just stopped. The site in question will autofill the UN & PW once I type the first letter of the UN but will not do it automatically when I open the site.

Modified by HowieE

cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

It is possible that some JavaScript is interfering and that the real input fields are hidden or not empty.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? It is possible that some JavaScript is interfering and that the real input fields are hidden or not empty.

Question owner

I hope this is what you meant but not sure http://www.airforums.com/

I hope this is what you meant but not sure http://www.airforums.com/
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers

Yes.
The user name field on this page isn't empty: onfocus="if (this.value == 'User Name') this.value = ;"

This make Firefox not fill the name on page load and possibly also not when you click the field although it might work if you first click the name field to clear this field and then switch the focus temporarily to another element on the page and then click once again in the name field.

Yes.<br /> The user name field on this page isn't empty: onfocus="if (this.value == 'User Name') this.value = '';" This make Firefox not fill the name on page load and possibly also not when you click the field although it might work if you first click the name field to clear this field and then switch the focus temporarily to another element on the page and then click once again in the name field.

Question owner

I think you may have hit on something with your Java comment. As I remember Java has caused problems before. I know it did with my Schwab account and that may have been the problem when this issue happened in the past.

Now that said I have no idea of what you are saying in your comment with this comment

The user name field on this page isn't empty: onfocus="if (this.value == 'User Name') this.value = ;"

Was that referring to the page I posted above and if so how did you determine the UN field is empty?

I think you may have hit on something with your Java comment. As I remember Java has caused problems before. I know it did with my Schwab account and that may have been the problem when this issue happened in the past. Now that said I have no idea of what you are saying in your comment with this comment The user name field on this page isn't empty: onfocus="if (this.value == 'User Name') this.value = ;" Was that referring to the page I posted above and if so how did you determine the UN field is empty?
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers
To avoid confusion: *http://kb.mozillazine.org/JavaScript_is_not_Java

Question owner

Please excuse my ignorance in the terms.

I now have 2 computers that will not auto fill UN & PW when using FF. I know this is not correct and am looking for help in correcting this if possible. This has happened at least twice before and unfortunately I did not record the final solution when presented.

I do not have first hand knowledge of the inner working and setting within the computer and as such have to ask for explanations on a lower level.

Please excuse my ignorance in the terms. I now have 2 computers that will not auto fill UN & PW when using FF. I know this is not correct and am looking for help in correcting this if possible. This has happened at least twice before and unfortunately I did not record the final solution when presented. I do not have first hand knowledge of the inner working and setting within the computer and as such have to ask for explanations on a lower level.

Question owner

I have gone back and found the comments posted the last time i had this issue. In first reading I did not see a conclusion but others may see something i missed.

https://support.mozilla.org/en-US/questions/930048?esab=a&as=s&r=6&page=2

I have gone back and found the comments posted the last time i had this issue. In first reading I did not see a conclusion but others may see something i missed. https://support.mozilla.org/en-US/questions/930048?esab=a&as=s&r=6&page=2
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers

In the case of the web page that you posted above there isn't a problem with autocomplete=off, but is this case the user name field isn't empty (i.e. the value of the user name field = "User Name").
The password manager will only fill a name and password automatically if the name field is empty and it is not possible to override this and you need to double-click the empty name field or type the first letter(s) to get a drop-down list.

In the case of the web page that you posted above there isn't a problem with autocomplete=off, but is this case the user name field isn't empty (i.e. the value of the user name field = "User Name").<br /> The password manager will only fill a name and password automatically if the name field is empty and it is not possible to override this and you need to double-click the empty name field or type the first letter(s) to get a drop-down list.

Question owner

I am sorry I will have to walk away from this issue for a while. I have absolutely no idea in the world what you just said.

I posted a link to the replies I got the last time I has this issue. While I did not see a conclusion in my first reading i had hoped that others with more knowledge of the workings of FF might see the answer an solve my problem. Some how the problem was solved at that time.

I am sorry I will have to walk away from this issue for a while. I have absolutely no idea in the world what you just said. I posted a link to the replies I got the last time I has this issue. While I did not see a conclusion in my first reading i had hoped that others with more knowledge of the workings of FF might see the answer an solve my problem. Some how the problem was solved at that time.

Question owner

I have looked at the suggestions given when this issue last appeared. Here is my last comment when the issue was resolved.

After deleting the places files and NOT asking to retain the UN & PW when I signed into the site I can now automatically sign into the site. UN & PW are not saved in the password manager but they are some how retained and work. Update. Just took Yahoo,com out of the saved PW list and now I am signed in when I open the site. Not sure what this means but I now have access to the 2 of the 3 sites I did not have before.

Can someone tell me how to get to the places file so I can try this again.

I have looked at the suggestions given when this issue last appeared. Here is my last comment when the issue was resolved. '''After deleting the places files and NOT asking to retain the UN & PW when I signed into the site I can now automatically sign into the site. UN & PW are not saved in the password manager but they are some how retained and work. ''' '''Update. Just took Yahoo,com out of the saved PW list and now I am signed in when I open the site. ''' '''Not sure what this means but I now have access to the 2 of the 3 sites I did not have before.''' Can someone tell me how to get to the '''places file''' so I can try this again.

Modified by HowieE

cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157367 answers

Chosen Solution

Details like websites remembering you (log you in automatically) are stored in a cookie.
So you now appear to keep the cookies from those websites.
This should have nothing to do with the places.sqlite file.

Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.

  • Tools > Options > Privacy > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Details like websites remembering you (log you in automatically) are stored in a cookie.<br /> So you now appear to keep the cookies from those websites.<br /> This should have nothing to do with the places.sqlite file. Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed. *Tools > Options > Privacy > Cookies: Exceptions In case you are using "Clear history when Firefox closes": *do not clear the Cookies *do not clear the Site Preferences *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data. Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Question owner

You got it on this one. It was all in the cookies

Thanks

You got it on this one. It was all in the cookies Thanks