Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens my homepage AND a new tab on start-up. Help

  • 10 replies
  • 22 have this problem
  • 10388 views
  • Last reply by cor-el

more options

When I open Firefox, it opens my homepage (Google) and a new tab. How do I get it to just open my home page?

Chosen solution

What is the value of the browser.startup.homepage pref on the about:config page?

You can open the about:config page via the location bar and you can accept the warning and click "I'll be careful" to continue


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Read this answer in context 👍 1

All Replies (10)

more options

Does this occur other times that you navigate to your home page, such as:

  • Opening a new window (Ctrl+n)
  • Clicking the Home button or pressing Alt+Home on the keyboard

If so, there might be an extra vertical bar character toward the end of your home page setting. You can check that in the Options dialog:

orange Firefox button (or Tools menu) > Options > General

More info on that:

If not, it's possible that there's something odd in the shortcut you use to start Firefox. You can check here:

right-click the icon > Properties > Shortcut tab

The target field should have this, no more, no less:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
more options

By the way, does the blank tab have anything in the address bar, or just "Search or Enter address"?

more options

On starting Firefox, as in clicking on the shortcut for it on my desktop, it opens my homepage (Google) and a blank tab, which yes only says "Search or Enter address". I tried going to "right-click the icon > Properties > Shortcut tab " and doing what you said, and that didn't help. I'm pretty sure the target line said the same thing anyway. Thanks by the way for the reply.

more options

Just to circle back to the first question, if you open a new window using Ctrl+n you don't get the extra blank tab?

more options

When I hit ctrl+n, it opens up a new window of Firefox with my homepage and a new, blank tab.

more options

Chosen Solution

What is the value of the browser.startup.homepage pref on the about:config page?

You can open the about:config page via the location bar and you can accept the warning and click "I'll be careful" to continue


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

It seems after disabling an add-on called"MySearchDial", which I don't remember installing, the problem disappeared. Thanks ^.^

more options

You're welcome.

Thanks for reporting that the MySearchDial extension caused this issue.

more options

I have something that that sounds similar.

On starting Firefox I get my homepage on tab 1, Google, and also a tab titled New Tab that opens something similar to the favourites tab but it's different.

Starting Firefox in safe mode still gets that tab so it's not an add on apparently, but it shows the address it's opening. That's this - chrome://nspdlsd/content/newtab/newtab.html

Screenie shown below.

I can't find any ref to it in about:config so have no clue how to stop that blasted new tab opening.

Any ideas please?

Modified by Iain

more options

The nspdlsd in the chrome URI should give an indication of which extension is causing this issue That is probably Speed Dial