Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox anchor link works first time, fails second time

  • 11 replies
  • 4 have this problem
  • 2055 views
  • Last reply by Diego Victor

more options

My website uses anchor links of the form href=file.htm#1234 to jump to <a name=1234> in file.htm.

It works fine when the website is locally loaded on my home PC. When I upload it to my website platform it works the first time I use it and then fails jumping to the top of file.htm. IE works fine both on the website platform and on my home PC.

Chosen solution

Hello,

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.

Read this answer in context 👍 0

All Replies (11)

more options

Could you post the url of your site?

Try use id instead name, HTML5 doesnt support the tag name anymore.

more options

The URL is http://www.jbending.org.uk

For example go to Index, A, Ada - for me this goes to a page with Ada at the top

Go back to previous page and repeat "Ada". It goes to head of page.

The web pages are generated by software. I have editted one example to replace name= with id=, it didnt help.

Thanks

more options

Works perfectly here, all the times!!

Maybe the problem occurs only with your browser, try restart your Firefox

See more about anchors:

Modified by Diego Victor

more options

I have restarted Firefox. "ada" always fails as do other "A"s I tried, but "M" "Mabel" worked first time and failed second!!

So if it works for you the html cant be wrong. Are you running firefox 27.0.1 on Windows ?

more options

I'm running Firefox 27.0.1 on W8.1, i try the same link that you, Mabel and works everytime too.

Modified by Diego Victor

more options

Do you see the correct URL in the location bar?

more options

Yes, when I hover over the link to Ada I see the correct URL, but clicking on "Ada" just takes me to the top of the page.

Thanks

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Fixed it!!!!

Many thanks - it was an addon. Dont know which one - will experiment.

Many thanks.

more options

Found it - Skype Click to Call 7.0.14375.1561. Disable it everything works, Enable it doesnt.

more options

Chosen Solution

Hello,

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.