Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Middle mouse button - Dosen't work at all.

  • 15 replies
  • 26 have this problem
  • Last reply by DTravel

more options

So, my most used action within Firefox was utilizing the middle mouse button in order to open a new tab on a link. Now suddenly after a format on my PC, the middle mouse button refuses to be acknowledged at all by Firefox; can't even hold it down to auto scroll or anything. I want to confirm that the button works on other programs and games with no issues. Using using ctrl/shift+click is not optimal but what I'm doing so far. I'm using the latest version, here's a list of the things I've already tried:

- Checking out all the related about:config's with "middle" as searching field.

- Made a new profile and reset Firefox numerous times

- Disabled/removed addons/extensions

- Wiped and installed Firefox completely - Tried with no addons

- Checked options

So far no luck at all, even tried some other browsers such as aurora & chrome with the same issue essentially.

Modified by Inqy

Chosen solution

I don't know whether you have a fancier mouse with its own custom driver software. If so, it would be worth a try updating the drivers. Alternately, Firefox sometimes works better when you fall back to the standard Microsoft mouse driver instead.

Read this answer in context 👍 1

All Replies (15)

more options

Chosen Solution

I don't know whether you have a fancier mouse with its own custom driver software. If so, it would be worth a try updating the drivers. Alternately, Firefox sometimes works better when you fall back to the standard Microsoft mouse driver instead.

more options

I do have a fancier mouse indeed, gaming one. However, I did not install any additional drivers for it previously and still managed to use the middle mouse button without any issues.

But I'll explore this, thank you for the suggestion.

Edit: Installed the driver & updated firmware as well, with no change at all. Even double checked that the middle mouse button was indeed assign as such.

Modified by Inqy

more options

Well for autoscroll have you made sure it was checked in Options->Advanced ?

So you cannot use Middle-click to open links into a new tab or to middle a tab to close it?

Aurora is not another browser but is the name of one of the four main development channels of Firefox where 29.0a2 is currently on. The others are Release, Beta and Nightly.

Modified by James

more options

Open 'about:config'. Enter middle in the search bar, and check the settings.

Open a new window or tab. In the address bar, type about:config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar.

more options

@James Autoscroll dose not work either, cannot use middle button at all for anything within the browser.

I just used that as an example, of trying another version and another browser such as chrome.

@FredMcD I have as stated in the OP already attempted to change and restart browser numerous times hoping that changing the default settings would yield access to the button.

more options

Did you check the mouse settings in the Windows Control Panel?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

No difference in safe mode. Did not anything relevant in mouse settings.

more options

An update, upon assigning the middle mouse button to my right click, the button performed flawlessly within the browser in both auto scroll and opening new tabs alike.

Yet the middle mouse button itself won't work at all, regardless of what it is assigned. However, in various games it dose work as a middle mouse button or whatever it is assigned. Seems to be a problem related to my OS rather than browser.

more options

Two options;

1) Download the full installer from

LAST RESORT ! ! Reset Firefox

more options

FredMcD, the OP stated he did just that in the first post a number of times. Both of your replies in thread was suggesting to do what the OP stated he had done already. Also if you read, this issue was not just in Firefox.

Inqy, what is the mouse specifically as maybe somebody has the same or maybe find the cause and or fix somewhere.

more options

Did you try to use another mouse?

more options

@James & cor-el

It's actually kinda funny. I have an corsair M60 FPS mouse, the middle mouse button first of all worked within all the games I tried it on, just not outside them. Upon installing the driver for it and updating its firmware, it stopped working in games as well. Upon assigning the middle mouse button elsewhere, like the right click button. Games and Firefox alike had no problem executing the middle command.

I tried another mouse which worked just fine, tried the M60 on another PC and the middle mouse button did not work. So it's clearly the mouse, I naturally assumed it was Firefox since strangely enough the mouse worked just fine outside it for a while until I started messing around here.

So I'm using a replacement mouse for now and ordered a new, damn mouse didn't even last 2 years as the warranty states so I might look into that. Guess I didn't wanna switch out mouse cause my hand already hurts from current mouse ;)

Modified by Inqy

more options

I have the same problem. I was in the middle of a browsing session when clicking on the mouse wheel as the middle button stopped opening links in a new tab. None of my config settings have changed, I am using a standard mouse with no special drivers, I have restarted Firefox and rebooted the computer with no effect.

more options


TabMix Plus has been causing problems with Firefox 31.0 recently.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks Edmeister but I don't have TabMix Plus installed and there have been no additions or removals of add-ons for a long time. Other than automatic Firefox updates both my system as a whole and Firefox have been stable following the "It ain't broke so don't fix it!" model.

The mouse wheel as third button is working again now after multiple hardware reboots and Firefox restarts but I can't determine what happened beyond "it stopped working and now it works again".