X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

how to get rid of yahoo as search engine when opening firefox

Posted

When I open Firefox and enter a site in the search box, yahoo appears as the search vehicle. It takes ages to find the required site. I've tried various things but it seems that this Yahoo feature has been installed when I was doing another download.

When I open Firefox and enter a site in the search box, yahoo appears as the search vehicle. It takes ages to find the required site. I've tried various things but it seems that this Yahoo feature has been installed when I was doing another download.

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • SaveSenseLive Update
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • BonanzaDealsLive Update
  • 5.1.20913.0
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Wesley Branton
  • Top 10 Contributor
582 solutions 4953 answers

In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

In order to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.
In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps: #Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo. #If you would like to select another search engine, simply pick the engine from the dropdown list. In order to change the order of the search engines, do this: #From the dropdown list, select ''Manage Search Engines...''. #In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select ''Move up'' or ''Move down'' from the buttons on the right side in order to change the order of the search engines.

Helpful Reply

Sorry, but I had tried this and it had no effect. Yahoo does not appear in the Manage Search Engines list. When I open Mozilla Firefox, 'Mozilla Firefox' appears in the top left hand side box. Then when I enter anything in the central search box, 'Mozilla Firefox' in this top left hand side box is replaced by 'Yahoo Search Results' and the Yahoo search takes a long time.

Sorry, but I had tried this and it had no effect. Yahoo does not appear in the ''Manage Search Engines'' list. When I open Mozilla Firefox, 'Mozilla Firefox' appears in the top left hand side box. Then when I enter anything in the central search box, 'Mozilla Firefox' in this top left hand side box is replaced by 'Yahoo Search Results' and the Yahoo search takes a long time.
jscher2000
  • Top 10 Contributor
8642 solutions 70716 answers

To see whether one of your extensions may be responsible for this, could you try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

(Note: This test assumes that Google or your preferred search site remains selected on the search bar.)

To see whether one of your extensions may be responsible for this, could you try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference? (Note: This test assumes that Google or your preferred search site remains selected on the search bar.)
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157446 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- You can use the SearchReset extension to reset some preferences to the default values. *https://addons.mozilla.org/firefox/addon/searchreset/ Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons). If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Sorry, hit the wrong button when replying above. The reply was; I've tried safe mode and it seems to work - no Yahoo ! Re=started PC and opened Firefox (not in safe mode and still no Yahoo !). Hope it stays like that. One other thing : when I open Firefox, I don't get the orange box with Firefox in the top left hand corner. Where has it gone ? Thanks for the help. Ray

Sorry, hit the wrong button when replying above. The reply was; I've tried safe mode and it seems to work - no Yahoo ! Re=started PC and opened Firefox (not in safe mode and still no Yahoo !). Hope it stays like that. One other thing : when I open Firefox, I don't get the orange box with Firefox in the top left hand corner. Where has it gone ? Thanks for the help. Ray
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157446 answers

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

You get the orange Firefox menu button when the Menu bar is hidden.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the hidden Menu bar)
  • Right-click empty toolbar area

See also:

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen You get the orange Firefox menu button when the Menu bar is hidden. *Firefox menu button > Options *View > Toolbars (press F10 to display the hidden Menu bar) *Right-click empty toolbar area See also: *https://support.mozilla.org/kb/how-do-i-get-firefox-button *https://support.mozilla.org/kb/Menu+bar+is+missing

Question owner

That works - got the Firefox menu button. Everything OK now. Many thanks for holding my hand at getting this problem sorted and for the very prompt replies. Ray

That works - got the Firefox menu button. Everything OK now. Many thanks for holding my hand at getting this problem sorted and for the very prompt replies. Ray

Question owner

Hi Edward Thanks for that. I'll make a note of your 2 tests. At the moment everything is OK. Ray

Hi Edward Thanks for that. I'll make a note of your 2 tests. At the moment everything is OK. Ray