Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can you turn off the spell checker in Firefox? (The menu option doesn't work.)

  • 2 replies
  • 3 have this problem
  • 4 views
  • Last reply by cor-el

more options

There was a solution to this I came across a long time ago, but I don't remember what it was. I want to turn off my spell checker in Firefox. The usual instructions given for doing this are to go into Options->Advanced and de-select "Check my spelling as I type". This doesn't work. Period. And this is a bug that has been around for a long time in Firefox.

What's a way to disable this? I don't like seeing a bunch of red lines under correctly spelled words that just happen to not be in Firefox's default dictionary, and I don't want to have to add things to my dictionary either.

All Replies (2)

more options

After turning off spell checking in the Options dialog, you will need to reload the page (try Ctrl+Shift+r to bypass the cached version of the page) to see the effect of the change. Does that work for you?

If there is a particularly stubborn form you've discovered that Firefox insists on spell-checking, could you provide a link?

more options

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.