X
Tap here to go to the mobile version of the site.

Support Forum

After I update plugins how to stop tab from starting when I start Firefox

Posted

Every time I start Firefox an update plug in tab comes up even though every plug in is updated or disabled. How do I stop this tab from starting when I start Firefox.

Also I have Firefox configured to load only the 2 tabs listed as my home page.

Every time I start Firefox an update plug in tab comes up even though every plug in is updated or disabled. How do I stop this tab from starting when I start Firefox. Also I have Firefox configured to load only the 2 tabs listed as my home page.
ideato
  • Top 25 Contributor
737 solutions 5346 answers

Hello nickyb65, if you have xp with sp2 and above if you update firefox to latest version (25.0.1 at the moment) this should already solve the problem.


thank you

Hello nickyb65, '''if you have xp with sp2 and above''' if you [https://support.mozilla.org/en-US/kb/update-firefox-latest-version update firefox to latest version] (25.0.1 at the moment) this should already solve the problem. thank you
Sukanya Mandal 3 solutions 33 answers

There are two possible causes for this. You may have that tab saved accidentally as your home page (which Firefox opens each time you start) or Firefox may be having trouble saving to your settings file which results in it not realizing you have already seen the "You've been updated" message. Here is how to check it this tab as your homepage and then restore back to default :- 1) At the top of the Firefox window, click on the 'Firefox' button and then select 'Options'. 2) Select the 'General' panel ('Main' panel in Firefox 3.5). 3) In the Startup box, highlight the text in the 'Home Page:' box. 4) If it includes something similar to [http://www.mozilla.com/en-US/firefox/.../whatsnew/] [http://www.mozilla.com/en-US/firefox/.../whatsnew/] then you have accidentally added the "Firefox Updated" page to the sites that Firefox loads on startup. 5) You can fix this by clicking 'Restore to Default'. To change your home page to something else, see the How to set the home page article.

There are two possible causes for this. You may have that tab saved accidentally as your home page (which Firefox opens each time you start) or Firefox may be having trouble saving to your settings file which results in it not realizing you have already seen the "You've been updated" message. Here is how to check it this tab as your homepage and then restore back to default :- 1) At the top of the Firefox window, click on the 'Firefox' button and then select 'Options'. 2) Select the 'General' panel ('Main' panel in Firefox 3.5). 3) In the Startup box, highlight the text in the 'Home Page:' box. 4) If it includes something similar to [[http://www.mozilla.com/en-US/firefox/4.0/whatsnew/]] [[http://www.mozilla.com/en-US/firefox/3.6.x/whatsnew/]] then you have accidentally added the "Firefox Updated" page to the sites that Firefox loads on startup. 5) You can fix this by clicking 'Restore to Default'. To change your home page to something else, see the [[How to set the home page]] article.
Ed999 0 solutions 1 answers

How to stop the "Check your plugin" page showing every time Firefox starts.

To force the page to stop showing, regardless of any plugins that need updates:

1. Start Firefox

2. In the address/url box, type this:

     about:config

3. Click the 'GoTo' button

4. If a security warning appears, to proceed anyway click the button labelled:

     I'll be careful, I promise!

5. Scroll down the list displayed to:

     plugins.update.notifyUser

6. Change the setting 'Value' to: false

NB: Right-click that value then select 'Toggle' to toggle between the values TRUE and FALSE

7. Locate the file USER.JS in the Profile folder:

e.g. C:\Users\dg\AppData\Roaming\Mozilla\Firefox\Profiles\92zz56mv.default\

8. Edit that file (using Notepad.exe). Add this line:

     user_pref("plugins.update.notifyUser", false);

9. Set the file USER.JS as 'Read-only', to prevent Firefox deleting the added line automatically

10. Locate the file PREFS.JS in the same directory

11. Edit that file (using Notepad.exe). Add this line:

     user_pref("plugins.update.notifyUser", false);

12. Set the file PREFS.JS as 'Read-only', to prevent Firefox deleting the added line automatically

How to stop the "Check your plugin" page showing every time Firefox starts. To force the page to stop showing, regardless of any plugins that need updates: 1. Start Firefox 2. In the address/url box, type this: about:config 3. Click the 'GoTo' button 4. If a security warning appears, to proceed anyway click the button labelled: I'll be careful, I promise! 5. Scroll down the list displayed to: plugins.update.notifyUser 6. Change the setting 'Value' to: false NB: Right-click that value then select 'Toggle' to toggle between the values TRUE and FALSE 7. Locate the file USER.JS in the Profile folder: e.g. C:\Users\dg\AppData\Roaming\Mozilla\Firefox\Profiles\92zz56mv.default\ 8. Edit that file (using Notepad.exe). Add this line: user_pref("plugins.update.notifyUser", false); 9. Set the file USER.JS as 'Read-only', to prevent Firefox deleting the added line automatically 10. Locate the file PREFS.JS in the same directory 11. Edit that file (using Notepad.exe). Add this line: user_pref("plugins.update.notifyUser", false); 12. Set the file PREFS.JS as 'Read-only', to prevent Firefox deleting the added line automatically
cor-el
  • Top 10 Contributor
  • Moderator
12520 solutions 115418 answers

I would advice not to set the prefs.js file to read-only as that will make Firefox endlessly numbered prefs-##.js files because it is not possible to rename such a numbered file to prefs.js.

I would advice not to set the prefs.js file to read-only as that will make Firefox endlessly numbered prefs-##.js files because it is not possible to rename such a numbered file to prefs.js.

Helpful Reply

Thanks Cor-el I do not like reconfiguring program lines. They were usually written that way for a reason. It has been my experience "as an aerospace engineer" not to change program lines unless you know the down hill affect.

Thanks Cor-el I do not like reconfiguring program lines. They were usually written that way for a reason. It has been my experience "as an aerospace engineer" not to change program lines unless you know the down hill affect.
YAZOOMILLER 0 solutions 3 answers

Helpful Reply

i have FF 27.0 (2-6-2014) and xp/sp3. Updating to current FF since FF 24.0 has NOT resolved the issue. I have changed my 'when ff starts: to both show my home page and then show a blank page - each time no change to when ff restarts = The tabs for the apps that have been updated that tell about the updated app - currently 6 ea of them - are loading with my home page and a 'blank' tab. In the Tools, Options, General, Start Up, When ff Starts: Show my home page or Show a blank page = there is a third line under those two choices that reads (in half tone print intensity) Show my windows and tabs FROM LAST TIME. Is this what is causing my problem; how do I get rid of that line..?

i have FF 27.0 (2-6-2014) and xp/sp3. Updating to current FF since FF 24.0 has NOT resolved the issue. I have changed my 'when ff starts: to both show my home page and then show a blank page - each time no change to when ff restarts = The tabs for the apps that have been updated that tell about the updated app - currently 6 ea of them - are loading with my home page and a 'blank' tab. In the Tools, Options, General, Start Up, When ff Starts: Show my home page or Show a blank page = ''there is a third line under those two choices ''that reads (in half tone print intensity) '''Show my windows and tabs FROM LAST TIME'''. Is this what is causing my problem; how do I get rid of that line..?
cor-el
  • Top 10 Contributor
  • Moderator
12520 solutions 115418 answers

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see the name without file extension.
You can see the real file type (file extension) in the Properties of the file via the right-click context menu in Windows Explorer.

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true. *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) Note that Windows hides some file extensions by default.<br /> Among them are .html and .ini and .js and .txt, so you may only see the name without file extension.<br /> You can see the real file type (file extension) in the Properties of the file via the right-click context menu in Windows Explorer.<br />