Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video controls do not show

  • 23 replies
  • 47 have this problem
  • 1989 views
  • Last reply by guigs

more options

Whenever i play a video, whether quicktime or html5, there are no video controls (play, pause etc). On trailers.apple.com, I can get the video controls to show up if click inspect element but then there's no video. I have tried reinstalling firefox, vlc, quicktime, flash, with no success. I'm using Winx64 fully patched.

All Replies (20)

more options

Hi aplhaace,

Thank you for contacting support, I understand that there are no video controls whenever a video is played in the Firefox Browser. We are happy to help.

It looks like the plug ins used for video are disabled in the Plug in menu, based on the troubleshooting information. Please enable them and please post back.

We look forward to hearing from you.

guigs

more options

Another thing we can try is launching the browser in safe mode. Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Hi,

I have made sure that my plugins are enabled (specifically quicktime and shockwave flash) and there are still no controls.

I also tried safe mode and again, no video controls. What's next?

more options

So, no controls here either when you hover the video?

Do you see a "Show Controls" or "Hide Controls" in the right-click context menu

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Hi,

So http://www.mozilla.org/en-US/firefox/video/ has the controls.

Any trailer on trailers.apple.com does not have the controls. For instance, http://trailers.apple.com/trailers/wb/islandoflemursmadagascar/#videos-large

has no video controls. However if I right click and inspect element, then the video controls appear there (but there is no video).

more options

One or the other work, weird

Long shot would there be any firewalls or anti-virus software that is running while the trailer is watched? Ref:[[ http://kb.mozillazine.org/Resetting_preferences#Software_that_changes_preference_settings]]

Another thing to check is to open up the Web Console while you watch the movie in developer tools and see if there are any errors for objects loading on the page. If there is an error message, that might hint to what is blocking it.

more options

Do you see the full video as the controls may be hidden in case the player window is not high enough to include the area with the controls?

more options

Hi,

I disabled all firewalls and antivirus -- still the same thing. I don't think my firewalls/etc are causing the issue as the controls appear just fine under chrome.

I also think this get's to cor-el's issue-- since the controls appear just fine under chrome, I don't think the window being not high enough is the issue. Here is the output from the web console:

[12:39:50.705] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/large.html [HTTP/1.1 200 OK 35ms] [12:39:51.476] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/sneakpeek/large.html [HTTP/1.1 200 OK 34ms] [12:39:52.200] GET http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/includes/settings/thehobbit2-sneakpeek.json [HTTP/1.1 304 Not Modified 36ms] [12:39:52.201] GET http://trailers.apple.com/trailers/global/v3.1/includes/ac_media_languages/en-US.json [HTTP/1.1 304 Not Modified 36ms] [12:39:52.160] Error in parsing value for 'margin-right'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large [12:39:52.160] Error in parsing value for 'margin-left'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large [12:39:52.162] Error in parsing value for 'width'. Declaration dropped. @ http://trailers.apple.com/trailers/wb/thehobbitthedesolationofsmaug/#videos-large

more options

So I got those errors and Mutation Api errors and those are usually inside of an extension. However I investigated the css file for the apple video controls and one of the css margin-left attributes has a "_" in front of it. Definitely might need to contact the developer of that css file.

I reloaded the page and tried to capture it again and I had to click on the video controls and hover over them to get the errors again.

These errors are CSS styling errors. Please try safe mode one more time after clearing the cache. Last idea is to create a new profile.

Reference for the errors of api I got that might not be the issue [http://stackoverflow.com/questions/19.../how-do-i-use-mutationobserver-instead-of-mutation-events]

more options

Hm, cleared cached, restarted --> same problem.

I'm not so sure this is a CSS issue for 2 reasons.

1) It works in chrome -- would chrome really render the CSS page so differently? 2) The controls are on top of the window... so unless they manually went out of their way to hid it, it should work -- and I can't seem to find that they manually hid it in the CSS file (plus it would vanish from chrome as well too no?).

Thanks.

more options
  • I have a silly question, if you hover over the hobbit video that was provided do the video controls appear in the new version of Firefox(version 26)?
more options

Hi,

Just checked... nope, still no controls.

more options

Ok, I have an idea, can I ask you to try to create a new profile in Firefox. Profile Manager - Create, remove, or switch Firefox profiles or the short link if you speak a different language: http://mzl.la/LL5Dxl

The new profile will have no extensions or add ons or any history, it is like a fresh install and it will not get rid of the current profile you have. Please let me know if you have any questions how to do this.

more options

Made a completely new profile, still no controls... sigh.. Any other ideas?

more options

I have three computers running Firefox 26, windows 7 x64, and quicktime plugin 7.7.4. I can confirm that on each computer there are no controls when hovering over quicktime video clips at trailers.apple.com in Firefox, but there are in Chrome and Internet Explorer. This is consistent across all three computers, different FF profiles. Safe mode doesn't change anything. I want to point fingers at the plugin itself. I have tried uninstalling and reinstalling the quicktime plugin without any change.

more options

Same issue here. FF 26.0 QT 7.74.80.86 (plugin 7.7.4.0)

Modified by TTLucian

more options

I have the same issue with the current Stable, Aurora and Nightly Builds. I Think the issue due to to problems: - One is that the order in which the elements are drawn causes the controls to remain hidden behind the running video - The other is that the mouse over is not detected correctly.

The latter can be seen when just with the mouse over the video nothing happens, but when you approach the video from the top left corner it is detected because here there (X) for closing the video extends past the frame of the video and so the (x) appears when the mouse is over this position. Once the (X) becomes visible it stays visible while the mouse cursor is anywhere over the video. The controls and the bottom right quarter of the (X), however, remain hidden behind the video.

more options

Hi culicidae, Do you have an example website? If you file a bug, please post the number here as well.

more options

No I didn't file a bug, I merely wanted to add to the above reports. The problem exists for any trailer on http://trailers.apple.com.

more options

I have this issue too. On same site (http://trailers.apple.com).

Modified by TTLucian

  1. 1
  2. 2