Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

http://kb.mozillazine.org/Images_or_animations_do_not_load out of date

  • 3 replies
  • 2 have this problem
  • 65 views
  • Last reply by cor-el

more options

I recentlty installed for the first time Firefox 25.0.1. In some pages like "http://www.britannica.com/EBchecked/topic/285876/Indian-Ocean#md-media-strip-tab-image-content" some images and menus do not show. Try to figure out why and got to the "http://kb.mozillazine.org/Images_or_animations_do_not_load". This information, last updated in 2011, refers in the Options/Preferences settings that under the "Content" tab, make sure that "Load images automatically". In the version of Firefox I am using there's no such option. What should I do? Thanks a lot.

All Replies (3)

more options

Hello,

You may not have the appropriate plugins installed for it to be displayed or your graphics driver is causing a conflict.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Hello and thank you for your complete answer,

Unfortunately my computers drivers graphic card (ATI Radeon 9200) are only for Windows XP and I am now running Windows 7. So, I do not think that an update would do any good. Nevertheless something is not quite clear to me. Why does IE 11 show nicely the page in question and Firefox 25 don't ? Even after I unchecked the Use hardware accelaration as you suggested.

I would appreciate very much any further help you can give.

more options

If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also: